[SRU] [Backport Request] smartmontools DB out of date

Bug #1013342 reported by AI_Guy on 2012-06-14
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
smartmontools (Debian)
Fix Released
Unknown
smartmontools (Ubuntu)
Undecided
Unassigned

Bug Description

Have a Intel 320 SSD. Partial output smartctl shows:
Device is: Not in smartctl database [for details use: -P showall]
...
ID# ATTRIBUTE_NAME FLAG VALUE WORST THRESH TYPE UPDATED WHEN_FAILED RAW_VALUE
3 Spin_Up_Time 0x0020 100 100 000 Old_age Offline - 0
4 Start_Stop_Count 0x0030 100 100 000 Old_age Offline - 0
5 Reallocated_Sector_Ct 0x0032 100 100 000 Old_age Always - 0
9 Power_On_Hours 0x0032 100 100 000 Old_age Always - 5736
12 Power_Cycle_Count 0x0032 100 100 000 Old_age Always - 131
170 Unknown_Attribute 0x0033 100 100 010 Pre-fail Always - 0
171 Unknown_Attribute 0x0032 100 100 000 Old_age Always - 0
172 Unknown_Attribute 0x0032 100 100 000 Old_age Always - 0
183 Unknown_Attribute 0x0030 100 100 000 Old_age Offline - 0
184 Unknown_Attribute 0x0032 100 100 090 Old_age Always - 0
187 Reported_Uncorrect 0x0032 100 100 000 Old_age Always - 0
192 Power-Off_Retract_Count 0x0032 100 100 000 Old_age Always - 47
199 UDMA_CRC_Error_Count 0x0030 100 100 000 Old_age Offline - 0
225 Load_Cycle_Count 0x0032 100 100 000 Old_age Always - 32189
226 Load-in_Time 0x0032 100 100 000 Old_age Always - 322
227 Torq-amp_Count 0x0032 100 100 000 Old_age Always - 50
228 Power-off_Retract_Count 0x0032 100 100 000 Old_age Always - 344166
232 Unknown_Attribute 0x0033 100 100 010 Pre-fail Always - 0
233 Unknown_Attribute 0x0032 100 100 000 Old_age Always - 0
241 Unknown_Attribute 0x0032 100 100 000 Old_age Always - 32189
242 Unknown_Attribute 0x0032 100 100 000 Old_age Always - 33031

Could build a newer version myself, but all could benefit from a rebuild of the repository version.
Additional info:

$lsb_release -rd
Description: Ubuntu 10.04.4 LTS
Release: 10.04
$ apt-cache policy smartmontools
smartmontools:
  Installed: 5.38-3ubuntu3
  Candidate: 5.38-3ubuntu3
  Version table:
 *** 5.38-3ubuntu3 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

new Version issued

 Date 2012-06-30
9 Summary: smartmontools release 5.43
10 -----------------------------------------------------------
11 - smartctl options '-g, --get' and '-s, --set' to get/set
12 various ATA settings: AAM, APM, Read look-ahead, Write
13 cache, Security (freeze), Standby mode/timer.
14 - smartd directive '-e' to set (most of) the above settings
15 on startup.
16 - smartctl options '-f hex' and '-f hex,[id|val]'.
17 - smartctl does not start ATA self-test if another test is
18 already running. Override with new option '-t force'.
19 - smartctl supports extended self-test polling times
20 greater than 255 minutes.
21 - Controller-independent SAT detection: '-d sat,auto[+TYPE]'.
22 - smartd.conf DEFAULT directive.
23 - Many HDD, SSD and USB additions to drive database.
24 - Linux and FreeBSD: Support for SATA disks behind Areca SAS
25 RAID controllers and HP Smart Array controllers.
26 - Windows: Support for SATA disks behind Areca controllers.
27 - Windows smartd: directives '-l offlinests,ns' and
28 '-l selfteststs,ns'.
29 - Windows installer: Combined 32-/64-bit support.
30 - FreeBSD: fixed crash on SCSI devices with FreeBSD9-RC1

http://sourceforge.net/apps/trac/smartmontools/browser/tags/RELEASE_5_43/smartmontools/NEWS

Tks in advance!

Help making Ubuntu better

summary: - smartmontools DB out of date
+ [Upgrade Software Version] smartmontools DB out of date
tags: added: precise quantal upgrade-software-version
Changed in smartmontools (Debian):
status: Unknown → Fix Released
summary: - [Upgrade Software Version] smartmontools DB out of date
+ [Backport Request] smartmontools DB out of date

@ Al_Guy

Title changed to backport request - Hope this helps.

Otherwise you may get a System-Notification as soon as Precise Pagoloin 12.04.01 is released sometime in 2012 August, or you consider to run the stable Lucid til it's last days. It's up to you!.

Newer Versions of Software are commonly only available in companion with newer Ubuntu Versions

On the subject of "smartmontools release 5.43" I'll open a new bug, since this one is closed @debian.

Thanks for reporting this bug.

tags: added: lucid natty
removed: quantal
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in smartmontools (Ubuntu):
status: New → Confirmed
Norbert (nrbrtx) wrote :

smartmontools are still outdated - 5.41 2011-06-09 r3365 is very old.
Please upgrade this package in Ubuntu Precise 12.04.5.

SMART information is very important - it may prevent HDD/SSD fail or data loss.
So the bug has High importance.

summary: - [Backport Request] smartmontools DB out of date
+ [SRU] [Backport Request] smartmontools DB out of date
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.