PyGIWarning: Gtk was imported without specifying a version first.

Bug #1673591 reported by Tom Metro on 2017-03-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
smart-notifier (Ubuntu)
Undecided
Unassigned

Bug Description

On Ubuntu 16.04.2 with smart-notifier 0.28-5, the following warning is output to the terminal on launch:

% smart-notifier
/usr/share/smart-notifier/smart_notifier/gui.py:23: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk

A test of smart-notifier like:
% echo test | sudo smart-notifier --notify

showed that it is working. So apparently just a warning.

This is similar to bug #1598896, but the details are a bit different.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers