gutsy->hardy upgrade error

Bug #210699 reported by Michael Vogt on 2008-04-02
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
slocate (Ubuntu)
High
Michael Vogt

Bug Description

Binary package hint: slocate

The following error occurred during a automatic gutsy->hardy upgrade test:

Preparing to replace findutils 4.2.31-1ubuntu2 (using .../findutils_4.2.32-1ubun
tu1_i386.deb) ...^M
Unpacking replacement findutils ...^M
Setting up findutils (4.2.32-1ubuntu1) ...^M
^M
(Reading database ... 2397074 files and directories currently installed.)^M
Preparing to replace slocate 3.1-1ubuntu3 (using .../slocate_3.1-1.1ubuntu3_i386
.deb) ...^M
Removing `diversion of /usr/bin/locate to /usr/bin/locate.notslocate by slocate'
^M
Removing `diversion of /usr/bin/updatedb to /usr/bin/updatedb.notslocate by sloc
ate'^M
Removing `diversion of /usr/share/man/man1/locate.1.gz to /usr/share/man/man1/lo
cate.notslocate.1.gz by slocate'^M
Removing `diversion of /usr/share/man/man1/updatedb.1.gz to /usr/share/man/man1/
updatedb.notslocate.1.gz by slocate'^M
Removing `diversion of /etc/cron.daily/find to /etc/cron.daily/find.notslocate b
y slocate'^M
dpkg-divert: rename involves overwriting `/etc/cron.daily/find' with^M
  different file `/etc/cron.daily/find.notslocate', not allowed^M
dpkg: error processing /var/cache/apt/archives/slocate_3.1-1.1ubuntu3_i386.deb (
--unpack):^M
 subprocess pre-installation script returned error exit status 2^M
Selecting previously deselected package locate.^M
dpkg: regarding .../locate_4.2.32-1ubuntu1_i386.deb containing locate:^M
 locate conflicts with slocate (<= 3.1-1.1)^M
  slocate (version 3.1-1ubuntu3) is present and installed.^M
dpkg: error processing /var/cache/apt/archives/locate_4.2.32-1ubuntu1_i386.deb (
--unpack):^M
 conflicting packages - not installing locate^M
Preparing to replace dlocate 0.5-0.3 (using .../archives/dlocate_0.94_all.deb) .
..^M
Unpacking replacement dlocate ...^M

Michael Vogt (mvo) wrote :
Michael Vogt (mvo) wrote :
Michael Vogt (mvo) wrote :

Some additional information:

# dpkg -S /etc/cron.daily/find
diversion by slocate from: /etc/cron.daily/find
diversion by slocate to: /etc/cron.daily/find.notslocate
findutils: /etc/cron.daily/find

# dpkg-divert --list '*find*'
diversion of /etc/cron.daily/find to /etc/cron.daily/find.notslocate by slocate

Michael Vogt (mvo) wrote :

It looks like the problem is a incorrect --compare-version. It seems to depend on the ordering of the unpack of the packages if it is triggered or not as the new "locate" package has a call to rm_conffile too and if that gets unpacked before slocate all is fine.

Debug output:
# sh -ex /var/lib/dpkg/info/findutils.preinst upgrade 4.2.31-1-1ubuntu2
+ set -e
+ dpkg --compare-versions 4.2.31-1-1ubuntu2 le-nl 4.2.31-1
#

Changed in slocate:
milestone: none → ubuntu-8.04
Michael Vogt (mvo) wrote :

Maybe this is a corner case, the gutsy upgrade image has /etc/cron.daily/find and the diversion from slocate both inside. That seems to trigger the bug.

Michael Vogt (mvo) wrote :

This is hopefully fixed with the latest findutils upload, testing the fix in a upgrade test now.

Changed in slocate:
status: New → Fix Committed
Michael Vogt (mvo) wrote :

I verified that the fix works in the upgrader tester (it works now were it used to fail).

Changed in slocate:
assignee: nobody → mvo
importance: Undecided → High
status: Fix Committed → Fix Released
danDDv77 (danddv77) wrote :

¿here?
I had got an error upgrading gutsy->hardy, Graphic driver crashed and now it works at 800*600, and I can not install any because I see same error once and again.
It is ... slocate error 7.

Here on Terminal, installing Envy on my unoperating system :PP
http://img118.imageshack.us/img118/1714/33310587iu3.png

Michael Vogt (mvo) wrote :

@danDDv77: the error you see is a different one AFACIS please file it against slocate as a new bug

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers