Comment 6 for bug 189462

Seth (bugs-sehe) wrote :

I hit the problem too. I upgraded to hardy, reviewed the packages 'deinstalled' (get-selections) and thought: hey, don't junk slocate, I use that!

So I apt-get install slocate, but it won't fly:

sehe@sehe-desktop:/etc/alternatives$ sudo updatedb
sehe@sehe-desktop:/etc/alternatives$ slocate bla
slocate: fatal error: Could not find user database '/var/lib/slocate/slocate.db': No such file or directory

I think it is broken. For one, it could be symlinked (perhaps using update-alternatives). Furthermore, it should be documented somewhere. It was never on a list of 'these packages are no longer supported' when deciding to upgrade.

I'll have a look at mlocate, but I feel bad about having to 'magically' guess what new command to use instead of slocate