Merge slingshot 0.8.1p-3 (universe) from Debian unstable (main).

Bug #444955 reported by Charlie_Smotherman on 2009-10-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
slingshot (Ubuntu)
Wishlist
Unassigned

Bug Description

Please sync slingshot 0.8.1p-3 (universe) from Debian unstable (main).

According to
http://people.ubuntuwire.org/~wgrant/rebuild-ftbfs-test/test-rebuild-20090909-karmic.html
slingshot FTBFS. This sync will correct the FTBFS

Changelog since current karmic version 0.8.1p-2:

slingshot (0.8.1p-3) unstable; urgency=low

  * No longer including backslashes in Depends/Build-Depends. (Closes: #535310)
  * Bumped Standards-Version to 3.8.2 (no changes needed)

 -- Ryan Kavanagh <email address hidden> Fri, 03 Jul 2009 17:59:41 -0400

Related branches

Changed in slingshot (Ubuntu):
importance: Undecided → Wishlist
Fabrice Coutadeur (fabricesp) wrote :

Hi,

The Debian package builds fine, but is not installable:
Dependency is not satisfiable: python (<< 2.6)

The generated dependency line is:
python (<< 2.6), python (>= 2.5), python-support (>= 0.90.0), python-pygame (>= 1.7.1), ttf-freefont

Can you check?

Thansk,
Fabrice

Changed in slingshot (Ubuntu):
status: New → Incomplete
Changed in slingshot (Ubuntu):
assignee: nobody → Charlie_Smotherman (porthose) (cjsmo)
status: Incomplete → In Progress
Charlie_Smotherman (cjsmo) wrote :

I changed XS-Python-Version: 2.5 to XS-Python-Version: >=2.5. I am attaching a debdiff and the diff.gz

Charlie_Smotherman (cjsmo) wrote :
Changed in slingshot (Ubuntu):
status: In Progress → New
assignee: Charlie_Smotherman (porthose) (cjsmo) → nobody
Changed in slingshot (Ubuntu):
assignee: nobody → fabrice_sp (fabricesp)
status: New → In Progress
summary: - Sync slingshot 0.8.1p-3 (universe) from Debian unstable (main).
+ Merge slingshot 0.8.1p-3 (universe) from Debian unstable (main).
Fabrice Coutadeur (fabricesp) wrote :

Uplaoded. Thansk for your contribution.
Do not forget to forward to Debian,

By the way, the debdiff you posted was between 0.8.1p-2 and 0.8.1p-3ubuntu1. I manually introduced the changes (not as lot :-) ).

Thanks again,
Fabrice

Changed in slingshot (Ubuntu):
assignee: fabrice_sp (fabricesp) → nobody
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package slingshot - 0.8.1p-3ubuntu1

---------------
slingshot (0.8.1p-3ubuntu1) karmic; urgency=low

  * debian/control: Increased XS-Python-Version to >=2.5 to build with python2.6
    (LP: #444955)

 -- Charlie Smotherman <email address hidden> Wed, 07 Oct 2009 02:51:27 -0500

Changed in slingshot (Ubuntu):
status: Fix Committed → Fix Released
Changed in slingshot (Ubuntu):
status: Fix Released → Confirmed
Fabrice Coutadeur (fabricesp) wrote :

Putting back as released: this package has been uploaded in Karmic!

Changed in slingshot (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers