slime: Required feature arc-mode was not provided (xemacs21)

Bug #478418 reported by Paul on 2009-11-08
58
This bug affects 11 people
Affects Status Importance Assigned to Milestone
slime (Debian)
Fix Released
Unknown
slime (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xemacs21

Don't know exactly why the failure occurred. Only that it occurred during upgrade from Ubuntu 9.04 to Ubuntu 9,10. Am now getting a possibly related message that the upgrade is now aborting and that my system may now be in an unstable state.

ProblemType: Package
Architecture: i386
Date: Sun Nov 8 06:51:38 2009
DistroRelease: Ubuntu 9.10
ErrorMessage:
 ErrorMessage: subprocess installed post-installation script returned error exit status 1
NonfreeKernelModules: nvidia
Package: xemacs21-mule 21.4.22-2ubuntu1
ProcVersionSignature: Ubuntu 2.6.28-16.55-generic
SourcePackage: xemacs21
Title: package xemacs21-mule 21.4.22-2ubuntu1 failed to install/upgrade:
Uname: Linux 2.6.28-16-generic i686

Paul (pvatkins) wrote :
Xolotl Loki (xoloki) wrote :

This happened for me as well during a 9.04 to 9.10 upgrade. I reported via ubuntu-bug, so hopefully all my system information has already been attached.

On my system, the upgrade failed due to this:

 Compiling /usr/share/xemacs21/site-lisp/slime/slime.el...
 While compiling toplevel forms in file /usr/share/xemacs21/site-lisp/slime/slime.el:
   !! error (("Required feature arc-mode was not provided"))
 >>Error occurred processing slime.el:
 Required feature arc-mode was not provided

xemacs still works for me, though I don't (knowingly) use the failing slime.el.

era (era) wrote :

Reassigning to the slime package

affects: xemacs21 (Ubuntu) → slime (Ubuntu)
summary: - package xemacs21-mule 21.4.22-2ubuntu1 failed to install/upgrade:
+ slime: Required feature arc-mode was not provided (xemacs21)
Conor (conor-home+launchpad) wrote :

This also happened to me. I had upgraded from 9.04 to 9.10 and later attempted to install slime.

era (era) wrote :

http://common-lisp.net/pipermail/slime-devel/2008-October/015640.html contains a diagnosis. It appears that upstream worked on this already in 2008, so upgrading to a more recent upstream version may be sufficient to fix this.

era (era) wrote :

See also bug #515630

tags: added: dist-upgrade
Changed in slime (Debian):
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in slime (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.