disregard default session in slim.conf

Bug #240101 reported by dennyhalim.com on 2008-06-15
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
slim (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: slim

in slim.conf there's this line:

# Available sessions (first one is the default).
sessions startfluxbox,openbox,bla,blabla,othersession

but slim disregard this configuration and start other session

temporary fix:
vi ~/.xsession
#and put in here whatever you want, example:
exec startfluxbox
#end ~/.xsession

z_b_longladder (z-b-longladder) wrote :

This also affects me (on 10.4).

From my slim.conf:

# Available sessions (first one is the default).
# The current chosen session name is replaced in the login_cmd
# above, so your login command can handle different sessions.
# see the xinitrc.sample file shipped with slim sources
sessions startfluxbox,default,startxfce4,openbox,ion3,icewm,wmaker,blackbox,awesome

However, despite the comment (which came in the file as installed, not my own), slim still defaults to the "default" session if F1 is not pressed, not to the first session in the list. If you cycle through the sessions using F1, they appear in the correct order (so, to use fluxbox, you press F1 once, and to go back to default you press it twice).

To reproduce:

Install slim from the apt repository
Reorder sessions in /etc/slim.conf, putting something other than "default" first
log out
log in without selecting a sessions

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in slim (Ubuntu):
status: New → Confirmed
Changed in slim (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers