Slic3r screen shows no build plate area in Bionic beta

Bug #1754909 reported by Rod Smith on 2018-03-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
slic3r (Ubuntu)
Undecided
Unassigned

Bug Description

After upgrading from Ubuntu 16.04 to the latest Bionic build (as of 10 March 2018), I tried launching Slic3r, and it did run; however, the Plater view shows no boundary for the build plate. I'm attaching a screen shot to show the problem (with a 20mm test cube loaded). The printer I'm using is a delta printer with a round build plate, and its boundaries should be visible in the Plater. Note that the build plate boundary IS shown in the 2D tab, but not in the 3D, Preview, or Layers tabs. This worked fine on the same computers under 16.04. (I've verified this issue on two computers -- a MacBook Air and a Lenovo Ideapad U530.)

Here's some version information, from the Lenovo (but both computers have up-to-date software):

$ lsb_release -rd
Description: Ubuntu Bionic Beaver (development branch)
Release: 18.04
$ $ apt-cache policy slic3r
slic3r:
  Installed: 1.2.9+dfsg-9
  Candidate: 1.2.9+dfsg-9
  Version table:
 *** 1.2.9+dfsg-9 500
        500 http://nessus.rodsbooks.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
$ apt-cache policy xserver-xorg-core
xserver-xorg-core:
  Installed: 2:1.19.6-1ubuntu2
  Candidate: 2:1.19.6-1ubuntu2
  Version table:
 *** 2:1.19.6-1ubuntu2 500
        500 http://nessus.rodsbooks.com/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status
$ uname -a
Linux bram 4.15.0-10-generic #11-Ubuntu SMP Tue Feb 13 18:23:35 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
---
ApportVersion: 2.20.8-0ubuntu10
Architecture: amd64
CurrentDesktop: Unity:Unity7:ubuntu
DistroRelease: Ubuntu 18.04
InstallationDate: Installed on 2017-10-23 (138 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
Package: slic3r 1.2.9+dfsg-9
PackageArchitecture: amd64
ProcVersionSignature: Ubuntu 4.15.0-10.11-generic 4.15.3
Tags: bionic
Uname: Linux 4.15.0-10-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dialout dip lpadmin mythtv plugdev sambashare sudo
_MarkForUpload: True

apport information

tags: added: apport-collected bionic
description: updated

apport information

apport information

apport information

Rod Smith (rodsmith) wrote :
WoodJRx (woodjrx) wrote :

Experiencing same issue in 17.10 and 18.04 upgrade. Reinstalled 18.04 fresh, still occurring.

Rod Smith (rodsmith) wrote :

The easiest workaround seems to be to use the slic3r-prusa package rather than the slic3r package. This changes the Slic3r version to be Prusa's fork, which might or might not be your preference; but at least the slic3r-prusa version's display works as expected. Note that the binary name changes from slic3r to slic3r-prusa3d with the package change, too.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers