crash displaying main menu in arabic

Bug #8253 reported by Debian Bug Importer
10
Affects Status Importance Assigned to Milestone
slang (Debian)
Fix Released
Unknown
slang (Ubuntu)
Medium
Colin Watson

Bug Description

Automatically imported from Debian bug report #256405 http://bugs.debian.org/256405

Revision history for this message
In , Christian Perrier (bubulle) wrote : Re: Bug#256405: crash displaying main menu in arabic

Quoting Joey Hess (<email address hidden>):

> Some experimentation and it looks like the problem is just with showing
> the current d-i main menu, localised to Arabic. I can reproduce the same
> problem by booting in expert mode, selecting Arabic, and pressing enter;
> when it tries to draw the main menu (same as it does when you go back
> from countrychooser), it must not like something, and it crashes.

Hmmm, and of course this happens only with Arabic.

I'll try with other RTL languages.

I should do more install tests at medium priority...:-(

Revision history for this message
In , Christian Perrier (bubulle) wrote :

Quoting Joey Hess (<email address hidden>):
> Package: debian-installer
> Severity: normal
> Tags: d-i
>
> I booted today's sid_d-i build from a usb stick. At the language
> chooser, I chose the nice new Arabic choice, and then at countrychooser,
> it was at the full list of contries, and I realized I din't speak
> Arabic, and selected the back button.
>
> At this point, the installer enters a crash loop. I'm seeing it start
> the frame buffer in preparation for starting main-menu, over and over,
> only to have it crash before it ever displays any UI.

Doing the exact same with the 20040626 sid_d-i businesscard ISO image
does not trigger the problem.

Same with medium priority install, choosing language, then Arabic as
language....the main menu then redisplays properly.

Revision history for this message
In , Steve Langasek (vorlon) wrote :

On Sat, Jun 26, 2004 at 04:35:42PM -0400, Joey Hess wrote:
> Package: debian-installer
> Severity: normal
> Tags: d-i

> I booted today's sid_d-i build from a usb stick. At the language
> chooser, I chose the nice new Arabic choice, and then at countrychooser,
> it was at the full list of contries, and I realized I din't speak
> Arabic, and selected the back button.

> At this point, the installer enters a crash loop. I'm seeing it start
> the frame buffer in preparation for starting main-menu, over and over,
> only to have it crash before it ever displays any UI.

> Some experimentation and it looks like the problem is just with showing
> the current d-i main menu, localised to Arabic. I can reproduce the same
> problem by booting in expert mode, selecting Arabic, and pressing enter;
> when it tries to draw the main menu (same as it does when you go back
> from countrychooser), it must not like something, and it crashes.

Are there any differences between the (untranslated) strings displayed
in the main menu for you on a usb stick, and those that would be on the
menu for a CD? Perhaps this bug is isolated to a particular codepoint
that's being mishandled.

--
Steve Langasek
postmodern programmer

Revision history for this message
In , Joey Hess (joeyh) wrote :

Steve Langasek wrote:
> Are there any differences between the (untranslated) strings displayed
> in the main menu for you on a usb stick, and those that would be on the
> menu for a CD? Perhaps this bug is isolated to a particular codepoint
> that's being mishandled.

Yes, the different strings would include those from iso-scan. I think
that's all, not sure.

--
see shy jo

Revision history for this message
In , Alastair McKinstry (mckinstry-computer) wrote :

Dé Domh, 2004-06-27 ag 11:29 -0500, scríobh Steve Langasek:
> On Sat, Jun 26, 2004 at 04:35:42PM -0400, Joey Hess wrote:
> > Package: debian-installer
> > Severity: normal
> > Tags: d-i
>
> > I booted today's sid_d-i build from a usb stick. At the language
> > chooser, I chose the nice new Arabic choice, and then at countrychooser,
> > it was at the full list of contries, and I realized I din't speak
> > Arabic, and selected the back button.

> > Some experimentation and it looks like the problem is just with showing
> > the current d-i main menu, localised to Arabic. I can reproduce the same
> > problem by booting in expert mode, selecting Arabic, and pressing enter;
> > when it tries to draw the main menu (same as it does when you go back
> > from countrychooser), it must not like something, and it crashes.

I suspect that the arabic shaping code is re-writing the strings and
using characters
that were not present in the original string. iso-scan saves space by
removing all
glyphs from unifont.bgf that were not present in the original string; if
the code
assumes all glyphs are present, it could crash ...

- Alastair

Revision history for this message
In , Joey Hess (joeyh) wrote :

Alastair McKinstry wrote:
> I suspect that the arabic shaping code is re-writing the strings and
> using characters
> that were not present in the original string. iso-scan saves space by
> removing all
> glyphs from unifont.bgf that were not present in the original string; if
> the code
> assumes all glyphs are present, it could crash ...

iso-scan is part of the initrd, so its template strings participate in
font reduction like those of any other udeb.

--
see shy jo

Revision history for this message
In , Steve Langasek (vorlon) wrote :

On Sun, Jun 27, 2004 at 06:11:38PM -0400, Joey Hess wrote:
> Alastair McKinstry wrote:
> > I suspect that the arabic shaping code is re-writing the strings and
> > using characters
> > that were not present in the original string. iso-scan saves space by
> > removing all
> > glyphs from unifont.bgf that were not present in the original string; if
> > the code
> > assumes all glyphs are present, it could crash ...

> iso-scan is part of the initrd, so its template strings participate in
> font reduction like those of any other udeb.

Yes, if the absence of glyphs can cause crashes, the most likely source
of trouble is that some sequence in the iso-scan main menu string is
shaped to a code point that's missing from
installer/build/needed-characters/ar. This *should* have been a
complete list of all characters generated by the shaping code, but it's
not impossible that I missed one.

--
Steve Langasek
postmodern programmer

Revision history for this message
In , Joey Hess (joeyh) wrote :

> Yes, if the absence of glyphs can cause crashes, the most likely source
> of trouble is that some sequence in the iso-scan main menu string is
> shaped to a code point that's missing from
> installer/build/needed-characters/ar. This *should* have been a
> complete list of all characters generated by the shaping code, but it's
> not impossible that I missed one.

How would I go about tracking this down? Bear in mind that I know beans about
this stuff.

--
see shy jo

Revision history for this message
In , Steve Langasek (vorlon) wrote :

On Wed, Jul 14, 2004 at 01:09:01PM -0400, Joey Hess wrote:
> > Yes, if the absence of glyphs can cause crashes, the most likely source
> > of trouble is that some sequence in the iso-scan main menu string is
> > shaped to a code point that's missing from
> > installer/build/needed-characters/ar. This *should* have been a
> > complete list of all characters generated by the shaping code, but it's
> > not impossible that I missed one.

> How would I go about tracking this down? Bear in mind that I know beans about
> this stuff.

Trivially, figure out which menu items appear in the iso-scan main menu
that don't appear in the main menu for other images; then remove the
Arabic translations for those menu items, rebuild, and test to confirm
whether the crash still occurs.

If it doesn't crash, binary searching will pinpoint the problematic
string.

--
Steve Langasek
postmodern programmer

Revision history for this message
In , Steve Langasek (vorlon) wrote :

On Wed, Jul 14, 2004 at 01:09:01PM -0400, Joey Hess wrote:
> > Yes, if the absence of glyphs can cause crashes, the most likely source
> > of trouble is that some sequence in the iso-scan main menu string is
> > shaped to a code point that's missing from
> > installer/build/needed-characters/ar. This *should* have been a
> > complete list of all characters generated by the shaping code, but it's
> > not impossible that I missed one.

> How would I go about tracking this down? Bear in mind that I know beans about
> this stuff.

... ah, but of course if there's only one string of interest, the binary
search would be very short. ;)

--
Steve Langasek
postmodern programmer

Revision history for this message
In , Joey Hess (joeyh) wrote :

Steve Langasek wrote:
> Trivially, figure out which menu items appear in the iso-scan main menu
> that don't appear in the main menu for other images; then remove the
> Arabic translations for those menu items, rebuild, and test to confirm
> whether the crash still occurs.
>
> If it doesn't crash, binary searching will pinpoint the problematic
> string.

Well, it's in iso-scan's menu item. Now what?

--
see shy jo

Revision history for this message
In , Steve Langasek (vorlon) wrote :

On Wed, Jul 14, 2004 at 04:16:39PM -0400, Joey Hess wrote:
> Steve Langasek wrote:
> > Trivially, figure out which menu items appear in the iso-scan main menu
> > that don't appear in the main menu for other images; then remove the
> > Arabic translations for those menu items, rebuild, and test to confirm
> > whether the crash still occurs.

> > If it doesn't crash, binary searching will pinpoint the problematic
> > string.

> Well, it's in iso-scan's menu item. Now what?

Investigation shows that the four Arabic ligature characters were missing
from needed-characters/ar, and that one of these characters was indeed
used in the translation of the iso-scan main menu item. Still waiting for
the results of testing to see whether adding these characters to the
reduced font fixes the problem.

--
Steve Langasek
postmodern programmer

Revision history for this message
In , Joey Hess (joeyh) wrote :

Steve Langasek wrote:
> Investigation shows that the four Arabic ligature characters were missing
> from needed-characters/ar, and that one of these characters was indeed
> used in the translation of the iso-scan main menu item. Still waiting for
> the results of testing to see whether adding these characters to the
> reduced font fixes the problem.

I tried the command line you gave me on IRC, but I'm still getting a
crash at the same place. :-(

--
see shy jo

Revision history for this message
In , Christian Perrier (bubulle) wrote : Re: Bug#272136: countrychooser: db_go fails when choosing Arabic as language

> This sounds similar to the also unexplained #256405.

By the way, 256405 does not happen anymore....

Should we close it even if it not explained?

Revision history for this message
In , Joey Hess (joeyh) wrote :

Christian Perrier wrote:
> > This sounds similar to the also unexplained #256405.
>
>
> By the way, 256405 does not happen anymore....

Yes it does, I just reproduced it.

--
see shy jo

Revision history for this message
In , Christian Perrier (bubulle) wrote : Re: Bug#272136: More progress about the "Arabic crash" in Debian Installer

severity 256405 serious
severity 272136 serious
reassign 256405 slang1-utf8
reassign 272136 slang1-utf8
merge 256405 272136
merge

Quoting Bastian Blank (<email address hidden>):
> On Mon, Sep 20, 2004 at 12:49:57AM -0700, Steve Langasek wrote:
> > Please try the attached patch to slang.
>
> I did some cleanups on the patch.

So, properly assigning the bug....

Revision history for this message
In , Martin Michlmayr (tbm) wrote : Re: Processed: Re: Bug#272136: More progress about the "Arabic crash" in Debian Installer

reassign 256405 slang1a-utf8

--
Martin Michlmayr
<email address hidden>

Revision history for this message
In , Bastian Blank (waldi) wrote :

reassign 256405 slang1a-utf8
reassign 272136 slang1a-utf8
--
You! What PLANET is this!
  -- McCoy, "The City on the Edge of Forever", stardate 3134.0

Revision history for this message
In , Christian Perrier (bubulle) wrote : Re: Bug#272136: More progress about the "Arabic crash" in Debian Installer

reassign 256405 slang1a-utf8
reassign 272136 slang1a-utf8
merge 256405 272136
thanks

Assigning to he correct package...:-)

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Automatically imported from Debian bug report #256405 http://bugs.debian.org/256405

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Sat, 26 Jun 2004 16:35:42 -0400
From: Joey Hess <email address hidden>
To: <email address hidden>
Subject: crash displaying main menu in arabic

--SLDf9lqlvOQaIe6s
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Package: debian-installer
Severity: normal
Tags: d-i

I booted today's sid_d-i build from a usb stick. At the language
chooser, I chose the nice new Arabic choice, and then at countrychooser,
it was at the full list of contries, and I realized I din't speak
Arabic, and selected the back button.

At this point, the installer enters a crash loop. I'm seeing it start
the frame buffer in preparation for starting main-menu, over and over,
only to have it crash before it ever displays any UI.

Some experimentation and it looks like the problem is just with showing
the current d-i main menu, localised to Arabic. I can reproduce the same
problem by booting in expert mode, selecting Arabic, and pressing enter;
when it tries to draw the main menu (same as it does when you go back
=66rom countrychooser), it must not like something, and it crashes.

--=20
see shy jo

--SLDf9lqlvOQaIe6s
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFA3d4ed8HHehbQuO8RAuUlAJ9Br1U4DqtMiGwQrh+IiirP5zGQwACg6CHm
nr/931wilb2RygeqKTTprak=
=Y/B+
-----END PGP SIGNATURE-----

--SLDf9lqlvOQaIe6s--

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Sun, 27 Jun 2004 08:30:50 +0200
From: Christian Perrier <email address hidden>
To: Joey Hess <email address hidden>, <email address hidden>
Subject: Re: Bug#256405: crash displaying main menu in arabic

Quoting Joey Hess (<email address hidden>):

> Some experimentation and it looks like the problem is just with showing
> the current d-i main menu, localised to Arabic. I can reproduce the same
> problem by booting in expert mode, selecting Arabic, and pressing enter;
> when it tries to draw the main menu (same as it does when you go back
> from countrychooser), it must not like something, and it crashes.

Hmmm, and of course this happens only with Arabic.

I'll try with other RTL languages.

I should do more install tests at medium priority...:-(

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Sun, 27 Jun 2004 08:53:55 +0200
From: Christian Perrier <email address hidden>
To: Joey Hess <email address hidden>, <email address hidden>
Cc: <email address hidden>
Subject: Re: Bug#256405: crash displaying main menu in arabic

Quoting Joey Hess (<email address hidden>):
> Package: debian-installer
> Severity: normal
> Tags: d-i
>
> I booted today's sid_d-i build from a usb stick. At the language
> chooser, I chose the nice new Arabic choice, and then at countrychooser,
> it was at the full list of contries, and I realized I din't speak
> Arabic, and selected the back button.
>
> At this point, the installer enters a crash loop. I'm seeing it start
> the frame buffer in preparation for starting main-menu, over and over,
> only to have it crash before it ever displays any UI.

Doing the exact same with the 20040626 sid_d-i businesscard ISO image
does not trigger the problem.

Same with medium priority install, choosing language, then Arabic as
language....the main menu then redisplays properly.

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Sun, 27 Jun 2004 11:29:19 -0500
From: Steve Langasek <email address hidden>
To: Joey Hess <email address hidden>, <email address hidden>
Subject: Re: Bug#256405: crash displaying main menu in arabic

--C7zPtVaVf+AK4Oqc
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Sat, Jun 26, 2004 at 04:35:42PM -0400, Joey Hess wrote:
> Package: debian-installer
> Severity: normal
> Tags: d-i

> I booted today's sid_d-i build from a usb stick. At the language
> chooser, I chose the nice new Arabic choice, and then at countrychooser,
> it was at the full list of contries, and I realized I din't speak
> Arabic, and selected the back button.

> At this point, the installer enters a crash loop. I'm seeing it start
> the frame buffer in preparation for starting main-menu, over and over,
> only to have it crash before it ever displays any UI.

> Some experimentation and it looks like the problem is just with showing
> the current d-i main menu, localised to Arabic. I can reproduce the same
> problem by booting in expert mode, selecting Arabic, and pressing enter;
> when it tries to draw the main menu (same as it does when you go back
> from countrychooser), it must not like something, and it crashes.

Are there any differences between the (untranslated) strings displayed
in the main menu for you on a usb stick, and those that would be on the
menu for a CD? Perhaps this bug is isolated to a particular codepoint
that's being mishandled.

--=20
Steve Langasek
postmodern programmer

--C7zPtVaVf+AK4Oqc
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFA3vXeKN6ufymYLloRAlJ8AKCXkuGpx3m9x27UA0+yrY/aIYZfbwCgkaIk
OpZgapjyrKwCAO/VZIYCcvM=
=KqFc
-----END PGP SIGNATURE-----

--C7zPtVaVf+AK4Oqc--

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Sun, 27 Jun 2004 13:10:36 -0400
From: Joey Hess <email address hidden>
To: Steve Langasek <email address hidden>
Cc: <email address hidden>
Subject: Re: Bug#256405: crash displaying main menu in arabic

--x+6KMIRAuhnl3hBn
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Steve Langasek wrote:
> Are there any differences between the (untranslated) strings displayed
> in the main menu for you on a usb stick, and those that would be on the
> menu for a CD? Perhaps this bug is isolated to a particular codepoint
> that's being mishandled.

Yes, the different strings would include those from iso-scan. I think
that's all, not sure.

--=20
see shy jo

--x+6KMIRAuhnl3hBn
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFA3v+Md8HHehbQuO8RApxZAKCIZ8il/mLkdaKnrxVYv756ZHPqtwCfZXDo
IgT5FF2jK2FDOknvaQP7IZ0=
=G0O+
-----END PGP SIGNATURE-----

--x+6KMIRAuhnl3hBn--

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-Id: <1088364955.5161.2.camel@coll>
Date: Sun, 27 Jun 2004 20:35:55 +0100
From: Alastair McKinstry <email address hidden>
To: Steve Langasek <email address hidden>, <email address hidden>
Cc: Joey Hess <email address hidden>
Subject: Re: Bug#256405: crash displaying main menu in arabic

Dé Domh, 2004-06-27 ag 11:29 -0500, scríobh Steve Langasek:
> On Sat, Jun 26, 2004 at 04:35:42PM -0400, Joey Hess wrote:
> > Package: debian-installer
> > Severity: normal
> > Tags: d-i
>
> > I booted today's sid_d-i build from a usb stick. At the language
> > chooser, I chose the nice new Arabic choice, and then at countrychooser,
> > it was at the full list of contries, and I realized I din't speak
> > Arabic, and selected the back button.

> > Some experimentation and it looks like the problem is just with showing
> > the current d-i main menu, localised to Arabic. I can reproduce the same
> > problem by booting in expert mode, selecting Arabic, and pressing enter;
> > when it tries to draw the main menu (same as it does when you go back
> > from countrychooser), it must not like something, and it crashes.

I suspect that the arabic shaping code is re-writing the strings and
using characters
that were not present in the original string. iso-scan saves space by
removing all
glyphs from unifont.bgf that were not present in the original string; if
the code
assumes all glyphs are present, it could crash ...

- Alastair

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Sun, 27 Jun 2004 18:11:38 -0400
From: Joey Hess <email address hidden>
To: <email address hidden>
Subject: Re: Bug#256405: crash displaying main menu in arabic

--gBBFr7Ir9EOA20Yy
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Alastair McKinstry wrote:
> I suspect that the arabic shaping code is re-writing the strings and
> using characters=20
> that were not present in the original string. iso-scan saves space by
> removing all
> glyphs from unifont.bgf that were not present in the original string; if
> the code
> assumes all glyphs are present, it could crash ...

iso-scan is part of the initrd, so its template strings participate in
font reduction like those of any other udeb.

--=20
see shy jo

--gBBFr7Ir9EOA20Yy
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFA30Yad8HHehbQuO8RAsnfAJ93tXAtji6zfBF/UgV86jx5bcqNDACgwsAz
cRD/idrK+DI3MinEj2LJgWo=
=Wi/k
-----END PGP SIGNATURE-----

--gBBFr7Ir9EOA20Yy--

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Sun, 27 Jun 2004 20:22:05 -0500
From: Steve Langasek <email address hidden>
To: Joey Hess <email address hidden>, <email address hidden>
Subject: Re: Bug#256405: crash displaying main menu in arabic

--4bRzO86E/ozDv8r1
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Sun, Jun 27, 2004 at 06:11:38PM -0400, Joey Hess wrote:
> Alastair McKinstry wrote:
> > I suspect that the arabic shaping code is re-writing the strings and
> > using characters=20
> > that were not present in the original string. iso-scan saves space by
> > removing all
> > glyphs from unifont.bgf that were not present in the original string; if
> > the code
> > assumes all glyphs are present, it could crash ...

> iso-scan is part of the initrd, so its template strings participate in
> font reduction like those of any other udeb.

Yes, if the absence of glyphs can cause crashes, the most likely source
of trouble is that some sequence in the iso-scan main menu string is
shaped to a code point that's missing from
installer/build/needed-characters/ar. This *should* have been a
complete list of all characters generated by the shaping code, but it's
not impossible that I missed one.

--=20
Steve Langasek
postmodern programmer

--4bRzO86E/ozDv8r1
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFA33K8KN6ufymYLloRAumEAJ96b2ZYPEuD/0rMj6tNjQcCIuC4zgCgu+Dd
NTtykplUH/6WwXQfoWK/Wso=
=HpFW
-----END PGP SIGNATURE-----

--4bRzO86E/ozDv8r1--

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Wed, 14 Jul 2004 13:09:01 -0400
From: Joey Hess <email address hidden>
To: Steve Langasek <email address hidden>, <email address hidden>
Subject: Re: Bug#256405: crash displaying main menu in arabic

--3MwIy2ne0vdjdPXF
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

> Yes, if the absence of glyphs can cause crashes, the most likely source
> of trouble is that some sequence in the iso-scan main menu string is
> shaped to a code point that's missing from
> installer/build/needed-characters/ar. This *should* have been a
> complete list of all characters generated by the shaping code, but it's
> not impossible that I missed one.

How would I go about tracking this down? Bear in mind that I know beans abo=
ut
this stuff.

--=20
see shy jo

--3MwIy2ne0vdjdPXF
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFA9Wisd8HHehbQuO8RAlmEAJwKl3QXPWbZRpILSaRcWUbyYFnQAQCgpT2j
dsEcHr2+wSk50l+XQUj0wiU=
=aNQy
-----END PGP SIGNATURE-----

--3MwIy2ne0vdjdPXF--

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Wed, 14 Jul 2004 13:51:29 -0500
From: Steve Langasek <email address hidden>
To: Joey Hess <email address hidden>
Cc: <email address hidden>
Subject: Re: Bug#256405: crash displaying main menu in arabic

On Wed, Jul 14, 2004 at 01:09:01PM -0400, Joey Hess wrote:
> > Yes, if the absence of glyphs can cause crashes, the most likely source
> > of trouble is that some sequence in the iso-scan main menu string is
> > shaped to a code point that's missing from
> > installer/build/needed-characters/ar. This *should* have been a
> > complete list of all characters generated by the shaping code, but it's
> > not impossible that I missed one.

> How would I go about tracking this down? Bear in mind that I know beans about
> this stuff.

Trivially, figure out which menu items appear in the iso-scan main menu
that don't appear in the main menu for other images; then remove the
Arabic translations for those menu items, rebuild, and test to confirm
whether the crash still occurs.

If it doesn't crash, binary searching will pinpoint the problematic
string.

--
Steve Langasek
postmodern programmer

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Wed, 14 Jul 2004 13:52:33 -0500
From: Steve Langasek <email address hidden>
To: Joey Hess <email address hidden>
Cc: <email address hidden>
Subject: Re: Bug#256405: crash displaying main menu in arabic

On Wed, Jul 14, 2004 at 01:09:01PM -0400, Joey Hess wrote:
> > Yes, if the absence of glyphs can cause crashes, the most likely source
> > of trouble is that some sequence in the iso-scan main menu string is
> > shaped to a code point that's missing from
> > installer/build/needed-characters/ar. This *should* have been a
> > complete list of all characters generated by the shaping code, but it's
> > not impossible that I missed one.

> How would I go about tracking this down? Bear in mind that I know beans about
> this stuff.

... ah, but of course if there's only one string of interest, the binary
search would be very short. ;)

--
Steve Langasek
postmodern programmer

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Wed, 14 Jul 2004 16:16:39 -0400
From: Joey Hess <email address hidden>
To: Steve Langasek <email address hidden>
Cc: <email address hidden>
Subject: Re: Bug#256405: crash displaying main menu in arabic

--mYCpIKhGyMATD0i+
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Steve Langasek wrote:
> Trivially, figure out which menu items appear in the iso-scan main menu
> that don't appear in the main menu for other images; then remove the
> Arabic translations for those menu items, rebuild, and test to confirm
> whether the crash still occurs.
>=20
> If it doesn't crash, binary searching will pinpoint the problematic
> string.

Well, it's in iso-scan's menu item. Now what?

--=20
see shy jo

--mYCpIKhGyMATD0i+
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFA9ZSnd8HHehbQuO8RAlIyAJwLCKxWncxdMWFB/hK+11L9JQ2PiACfT6K5
zo5tZoSvFUdwMxdVu1XJzco=
=fJ6h
-----END PGP SIGNATURE-----

--mYCpIKhGyMATD0i+--

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Wed, 14 Jul 2004 17:22:19 -0500
From: Steve Langasek <email address hidden>
To: Joey Hess <email address hidden>
Cc: <email address hidden>
Subject: Re: Bug#256405: crash displaying main menu in arabic

On Wed, Jul 14, 2004 at 04:16:39PM -0400, Joey Hess wrote:
> Steve Langasek wrote:
> > Trivially, figure out which menu items appear in the iso-scan main menu
> > that don't appear in the main menu for other images; then remove the
> > Arabic translations for those menu items, rebuild, and test to confirm
> > whether the crash still occurs.

> > If it doesn't crash, binary searching will pinpoint the problematic
> > string.

> Well, it's in iso-scan's menu item. Now what?

Investigation shows that the four Arabic ligature characters were missing
from needed-characters/ar, and that one of these characters was indeed
used in the translation of the iso-scan main menu item. Still waiting for
the results of testing to see whether adding these characters to the
reduced font fixes the problem.

--
Steve Langasek
postmodern programmer

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Wed, 14 Jul 2004 22:46:59 -0400
From: Joey Hess <email address hidden>
To: Steve Langasek <email address hidden>, <email address hidden>
Subject: Re: Bug#256405: crash displaying main menu in arabic

--IiVenqGWf+H9Y6IX
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Steve Langasek wrote:
> Investigation shows that the four Arabic ligature characters were missing
> from needed-characters/ar, and that one of these characters was indeed
> used in the translation of the iso-scan main menu item. Still waiting for
> the results of testing to see whether adding these characters to the
> reduced font fixes the problem.

I tried the command line you gave me on IRC, but I'm still getting a
crash at the same place. :-(

--=20
see shy jo

--IiVenqGWf+H9Y6IX
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFA9fAjd8HHehbQuO8RApnpAKCkw70aJI1zEBSv4Qsy/zjuxyUicQCggept
wkdKfOlgIceOZELR7xE/ajc=
=k6Il
-----END PGP SIGNATURE-----

--IiVenqGWf+H9Y6IX--

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Sat, 18 Sep 2004 07:14:32 +0200
From: Christian Perrier <email address hidden>
To: Joey Hess <email address hidden>, <email address hidden>,
 <email address hidden>
Subject: Re: Bug#272136: countrychooser: db_go fails when choosing Arabic as language

> This sounds similar to the also unexplained #256405.

By the way, 256405 does not happen anymore....

Should we close it even if it not explained?

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Sat, 18 Sep 2004 15:05:13 -0400
From: Joey Hess <email address hidden>
To: Christian Perrier <email address hidden>
Cc: <email address hidden>, <email address hidden>
Subject: Re: Bug#272136: countrychooser: db_go fails when choosing Arabic as language

--xo44VMWPx7vlQ2+2
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Christian Perrier wrote:
> > This sounds similar to the also unexplained #256405.
>=20
>=20
> By the way, 256405 does not happen anymore....

Yes it does, I just reproduced it.

--=20
see shy jo

--xo44VMWPx7vlQ2+2
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.5 (GNU/Linux)

iD8DBQFBTIbpd8HHehbQuO8RAuPaAKCj8ePQzE2tmWgXSAH4Y77k4t0y1gCfXLNh
g0M+6vPl1AtLG3rL1w22vgc=
=ijml
-----END PGP SIGNATURE-----

--xo44VMWPx7vlQ2+2--

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Mon, 20 Sep 2004 11:38:31 +0200
From: Christian Perrier <email address hidden>
To: Bastian Blank <email address hidden>, <email address hidden>
Cc: Steve Langasek <email address hidden>, <email address hidden>
Subject: Re: Bug#272136: More progress about the "Arabic crash" in Debian Installer

severity 256405 serious
severity 272136 serious
reassign 256405 slang1-utf8
reassign 272136 slang1-utf8
merge 256405 272136
merge

Quoting Bastian Blank (<email address hidden>):
> On Mon, Sep 20, 2004 at 12:49:57AM -0700, Steve Langasek wrote:
> > Please try the attached patch to slang.
>
> I did some cleanups on the patch.

So, properly assigning the bug....

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Mon, 20 Sep 2004 10:49:55 +0100
From: Martin Michlmayr <email address hidden>
To: <email address hidden>
Subject: Re: Processed: Re: Bug#272136: More progress about the "Arabic crash" in Debian Installer

reassign 256405 slang1a-utf8

--
Martin Michlmayr
<email address hidden>

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Mon, 20 Sep 2004 12:02:02 +0200
From: Bastian Blank <email address hidden>
To: <email address hidden>
Subject: Re: Processed: Re: Bug#272136: More progress about the "Arabic crash" in Debian Installer

reassign 256405 slang1a-utf8
reassign 272136 slang1a-utf8
--
You! What PLANET is this!
  -- McCoy, "The City on the Edge of Forever", stardate 3134.0

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Mon, 20 Sep 2004 12:11:43 +0200
From: Christian Perrier <email address hidden>
To: Christian Perrier <email address hidden>, <email address hidden>
Cc: Bastian Blank <email address hidden>, Steve Langasek <email address hidden>, <email address hidden>
Subject: Re: Bug#272136: More progress about the "Arabic crash" in Debian Installer

reassign 256405 slang1a-utf8
reassign 272136 slang1a-utf8
merge 256405 272136
thanks

Assigning to he correct package...:-)

Revision history for this message
Debian Bug Importer (debzilla) wrote :

*** Bug 8254 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Alastair McKinstry (mckinstry) wrote : Bug#256405: fixed in slang 1.4.9dbs-8
Download full text (3.5 KiB)

Source: slang
Source-Version: 1.4.9dbs-8

We believe that the bug you reported is fixed in the latest version of
slang, which is due to be installed in the Debian FTP archive:

slang1-dev_1.4.9dbs-8_i386.deb
  to pool/main/s/slang/slang1-dev_1.4.9dbs-8_i386.deb
slang1-pic_1.4.9dbs-8_i386.deb
  to pool/main/s/slang/slang1-pic_1.4.9dbs-8_i386.deb
slang1-utf8-dev_1.4.9dbs-8_i386.deb
  to pool/main/s/slang/slang1-utf8-dev_1.4.9dbs-8_i386.deb
slang1-utf8-pic_1.4.9dbs-8_i386.deb
  to pool/main/s/slang/slang1-utf8-pic_1.4.9dbs-8_i386.deb
slang1_1.4.9dbs-8_i386.deb
  to pool/main/s/slang/slang1_1.4.9dbs-8_i386.deb
slang1a-utf8-udeb_1.4.9dbs-8_i386.udeb
  to pool/main/s/slang/slang1a-utf8-udeb_1.4.9dbs-8_i386.udeb
slang1a-utf8_1.4.9dbs-8_i386.deb
  to pool/main/s/slang/slang1a-utf8_1.4.9dbs-8_i386.deb
slang_1.4.9dbs-8.diff.gz
  to pool/main/s/slang/slang_1.4.9dbs-8.diff.gz
slang_1.4.9dbs-8.dsc
  to pool/main/s/slang/slang_1.4.9dbs-8.dsc

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to <email address hidden>,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Alastair McKinstry <email address hidden> (supplier of updated slang package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing <email address hidden>)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Tue, 21 Sep 2004 20:53:30 +0100
Source: slang
Binary: slang1-utf8-dev slang1-dev slang1a-utf8 slang1-utf8-pic slang1 slang1a-utf8-udeb slang1-pic
Architecture: source i386
Version: 1.4.9dbs-8
Distribution: unstable
Urgency: low
Maintainer: Jim Mintha <email address hidden>
Changed-By: Alastair McKinstry <email address hidden>
Description:
 slang1 - The S-Lang programming library - runtime version
 slang1-dev - The S-Lang programming library, development version
 slang1-pic - The S-Lang programming library, shared library subset kit
 slang1-utf8-dev - The S-Lang programming library, development version with utf8 sup
 slang1-utf8-pic - The S-Lang programming library, shared library subset with utf8 s
 slang1a-utf8 - The S-Lang programming library with utf8 support
 slang1a-utf8-udeb - S-Lang library with utf8 support (udeb)
Closes: 256405 272136
Changes:
 slang (1.4.9dbs-8) unstable; urgency=low
 .
   * Fix segfault on zero-width chars chars in Arabic. Closes: #256405, #272136.
Files:
 b579f71d6b51eeebc36171eb4045020b 727 devel optional slang_1.4.9dbs-8.dsc
 c5b9840181842204f4d3ba4e60ef8b24 88853 devel optional slang_1.4.9dbs-8.diff.gz
 f67df0d13d4b60410df30e0e6c1cb195 335036 devel optional slang1-dev_1.4.9dbs-8_i386.deb
 5cc72dc647267adbbe69de7a4f9d81be 295708 base standard slang1_1.4.9dbs-8_i386.deb
 953a2f9ea61c5822e9144559f81f8145 270966 libdevel optional slang1-pic_1.4.9dbs-8_i386.deb
 84100714d7b73ef568d387e96b9f2832 336242 devel extra slang1-utf8-dev_1.4.9dbs-8_i386.deb
 842eed2117fd54f3788f4cd34c0ecd7e 297114 libs required slang1a-utf8_1.4.9dbs-8_i386.deb
 8ab4c4e...

Read more...

Revision history for this message
Colin Watson (cjwatson) wrote :

This only seems to apply to USB installs, which we don't support at the moment,
although I'd like to support them by final release. I don't think it's really RC
for us.

Revision history for this message
Debian Bug Importer (debzilla) wrote :
Download full text (3.7 KiB)

Message-Id: <email address hidden>
Date: Tue, 21 Sep 2004 16:17:13 -0400
From: Alastair McKinstry <email address hidden>
To: <email address hidden>
Subject: Bug#256405: fixed in slang 1.4.9dbs-8

Source: slang
Source-Version: 1.4.9dbs-8

We believe that the bug you reported is fixed in the latest version of
slang, which is due to be installed in the Debian FTP archive:

slang1-dev_1.4.9dbs-8_i386.deb
  to pool/main/s/slang/slang1-dev_1.4.9dbs-8_i386.deb
slang1-pic_1.4.9dbs-8_i386.deb
  to pool/main/s/slang/slang1-pic_1.4.9dbs-8_i386.deb
slang1-utf8-dev_1.4.9dbs-8_i386.deb
  to pool/main/s/slang/slang1-utf8-dev_1.4.9dbs-8_i386.deb
slang1-utf8-pic_1.4.9dbs-8_i386.deb
  to pool/main/s/slang/slang1-utf8-pic_1.4.9dbs-8_i386.deb
slang1_1.4.9dbs-8_i386.deb
  to pool/main/s/slang/slang1_1.4.9dbs-8_i386.deb
slang1a-utf8-udeb_1.4.9dbs-8_i386.udeb
  to pool/main/s/slang/slang1a-utf8-udeb_1.4.9dbs-8_i386.udeb
slang1a-utf8_1.4.9dbs-8_i386.deb
  to pool/main/s/slang/slang1a-utf8_1.4.9dbs-8_i386.deb
slang_1.4.9dbs-8.diff.gz
  to pool/main/s/slang/slang_1.4.9dbs-8.diff.gz
slang_1.4.9dbs-8.dsc
  to pool/main/s/slang/slang_1.4.9dbs-8.dsc

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to <email address hidden>,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Alastair McKinstry <email address hidden> (supplier of updated slang package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing <email address hidden>)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Tue, 21 Sep 2004 20:53:30 +0100
Source: slang
Binary: slang1-utf8-dev slang1-dev slang1a-utf8 slang1-utf8-pic slang1 slang1a-utf8-udeb slang1-pic
Architecture: source i386
Version: 1.4.9dbs-8
Distribution: unstable
Urgency: low
Maintainer: Jim Mintha <email address hidden>
Changed-By: Alastair McKinstry <email address hidden>
Description:
 slang1 - The S-Lang programming library - runtime version
 slang1-dev - The S-Lang programming library, development version
 slang1-pic - The S-Lang programming library, shared library subset kit
 slang1-utf8-dev - The S-Lang programming library, development version with utf8 sup
 slang1-utf8-pic - The S-Lang programming library, shared library subset with utf8 s
 slang1a-utf8 - The S-Lang programming library with utf8 support
 slang1a-utf8-udeb - S-Lang library with utf8 support (udeb)
Closes: 256405 272136
Changes:
 slang (1.4.9dbs-8) unstable; urgency=low
 .
   * Fix segfault on zero-width chars chars in Arabic. Closes: #256405, #272136.
Files:
 b579f71d6b51eeebc36171eb4045020b 727 devel optional slang_1.4.9dbs-8.dsc
 c5b9840181842204f4d3ba4e60ef8b24 88853 devel optional slang_1.4.9dbs-8.diff.gz
 f67df0d13d4b60410df30e0e6c1cb195 335036 devel optional slang1-dev_1.4.9dbs-8_i386.deb
 5cc72dc647267adbbe69de7a4f9d81be 295708 base standard slang1_1.4.9dbs-8_i386.deb
 953a2f9ea61c5822e9144559f81f8145 270966 libdevel optiona...

Read more...

Revision history for this message
Matt Zimmerman (mdz) wrote :

Fixed in hoary:

     slang | 1.4.9dbs-8 | http://archive.ubuntu.com hoary/main Sources

Changed in slang:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.