"No Carrier" on dial up

Bug #47809 reported by towsonu2003 on 2006-06-01
16
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned
sl-modem (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: sl-modem-daemon

I have a winmodem that is alsa enabled and works with this daemon.

There is something wrong how it negotiates with the ISP modem at the beginning. I am pretty sure this is an upstream bug, like Bug #47808 , but as I said there, I just couldn't find a way to file a bug to them (linmodems people, I believe)...

To replicate:
0. Have an alsa enabled winmodem that works with this daemon
1. Use wvdial (has better error output) to dial up and connect to ISP
2. Watch as wvdial can't connect half the time, saying "No Carrier".
3. Kill wvdial when it says "No Carrier" and try again.

I sometimes try to connect 20-30 minutes... And it's the same problem with kppp and other modem dialers out there...

Here is my wvdial.conf:

---------------------------------------
[Dialer Defaults]
Modem = /dev/ttySL0
Baud = 460800
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ISDN = 0
Modem Type = Analog Modem
Phone = 4104948588 # Towson University
Username = usernamehere
Password = passwordhere
Carrier Check = no
Stupid Mode = yes
------------------------------------------

Here is my modemdata.txt (a little old, and long):

-------------------------------------------
 DO use the following line as the email Subject Line, to alert cogent experts:
      scanModem,
Welcome to kernel 2.6.13
 Occassionally reponses are blocked by an Internet Provider mail filters.
 So do in a day also check the Archived responses at <email address hidden>
Code updated on: 2005_Sept_13
------------ -------------- System information ------------------------

Welcome to
 on System with processor: i686
 currently under kernel: 2.6.13
  <email address hidden> will help with Slackware problems

There are emerging complications under 2.6.10 and later kernels.
Concerning Intel-536ep and 537
   http://www.ubuntulinux.org/wiki/IntelFiveThreeSixEPModemHowto/
   http://linmodems.technion.ac.il/archive-fifth/msg00280.html
   http://linmodems.technion.ac.il/archive-fifth/msg00881.html

 The kernel was assembled with compiler: 3.3.6
 with current System compiler GCC=3.3.6
    /usr/bin/gcc -> gcc-3.3.6

Checking for kernel-headers needed for compiling.
The kernel-headers have base folder:
/lib/modules/2.6.13/build -> /usr/src/linux-2.6.13
/usr/src/linux -> linux-2.6.13
/usr/src/linux-2.6.13
 Wvdial is a dialout utility very useful for modem testing. If not encluded on
 your installation media, check your distrbutions on line software repository.
 An example is: http://linmodems.technion.ac.il/archive-fifth/msg01480.html

 Modem symbolic link is: /dev/modem -> ttyS1
 Checking for modem symbolic link support lines within /etc/udev/ files

 USB modem not detected.

00:14.5 Multimedia audio controller: ATI Technologies Inc IXP150 AC'97 Audio Controller

Modem candidates are at PCI_buses: 00:14.6

Providing detail for device at 00:14.6
  with vendor-ID:device-ID
            ----:----
Class 0703: 1002:434d Modem: ATI Technologies Inc IXP AC'97 Modem (rev 01) (prog-if 00 [Generic])
  SubSystem 103c:006b Hewlett-Packard Company: Unknown device 006b
        Flags: bus master, 66Mhz, slow devsel, latency 64, IRQ 10

                  -----PCI_IDs------- --CompilerVer-
    Feature List: Primary Subsystem Distr KernelVer kernel default CPU
 ./scanModem test 1002:434d 103c:006b slackware 2.6.13 3.3.6 3.3.6 i686

 The soft modem Subsystem operates under a controller
   1002:434d ATI
 capable of supporting under Linux AT LEAST modem Subsystem chips from manufacturers:

        AgereSystems
        Conexant
        Intel
 The Subsystem PCI id does not itself identify the modem Codec.

  Driver snd-atiixp-modem may enable codec acquisition
 regs_file is /proc/asound/card1/codec97#0/mc97#1-1+regs
 mc97 register information from: /proc/asound/card1/codec97#0/mc97#1-1+regs
    0:7c = 5349
    0:7e = 4c27
    Translating into mc97 codec: SIL27

SIL27 is an AgereSystems codec
  === Begin mc97 codec query ===
 Codec file is /proc/asound/card1/codec97#0/mc97#1-1
1-1/0: Silicon Laboratory Si3036,8 rev 7
 Subsystem 103c:006b has a SIL27 codec
 From http://linmodems.technion.ac.il/packages/smartlink/ download the
 slmodemd-2.9.9e-pre1-alsa.tar.gz. Install the slmodemd as directed therein.
 Start testing by opening a command console. Login with:
 # su - root
 Load the driver:
 # modprobe snd-atiixp-modem
 Test port creation with:
 # slmodemd --alsa --country=YourCountry hw:1
 and prepare to dialout leaving slmoded active. For details read:
    Slmodem.txt, Slmodem-ALSA.txt and Testing.txt
    http://linmodems.technion.ac.il/wvdial.html
    If using dialer WVDIAL , the following line
        Carrier Check = no
    must be added to the file /etc/wvdial.conf which is generated by the preliminary
       wvdialconf /etc/wvdialconf
    If using Kinternet of the Redhat/Fedora dialer, check the /etc/wvdialconf
    generated during their setup process for a line:
        Carrier Check = no
    For details, read Slmodem.txt, Slmodem-ALSA.txt and Testing.txt

  === End mc97 codec query ===

 Beginning check for older ac97_codec modems.
 An older ac97_modem codec was not detected.

 Checking through information gathered from LinModem ARCHIVES
 From prior reports, the modem codec type of the Subsystem is: SIL27
 The Subsystem has an Agere Systems codec SIL27
 == Checking PCI IDs through modem chip suppliers ==

 Vendor 1002 is ATI Technolgies, http://www.ati.com, producing video cards, motherboard
 and a 1002:434d ATI soft modem controller with a variety of Subsystems.
 1002:4378 is an AC97 modem controller, with atiixp support code in the CVS, Aug 2005
 For service with Smartlink slmodemd compatible hardware, see Modem/Slmodem-ALSA.txt
 For service of Conexant chipset Subsystems, the file in hsfmodem packages,
     modules/mod_mc97ati.c
 needs the 2nd line below inserted:
         {0x1002, 0x434D, PCI_ANY_ID, PCI_ANY_ID, 0, 0, CNXTHWCFG("mc97ati")},
         {0x1002, 0x4378, PCI_ANY_ID, PCI_ANY_ID, 0, 0, CNXTHWCFG("mc97ati")},
         {0,} /* terminate list */

 Under the controller 1002:434d ATI ,
 with modem subSystem 103c:006b
 Only ALSA mode usage of slmodem-2.9.n code may provide support.

 SmartLink at http://www.smlink.com/ owns vendor IDs 163c, 2000, 2003, and 2004
 The official download site is: http://www.smlink.com/main/index1.php?ln=en&main_id=40 ,
 with slmodem-2.9.10 and later releases only licensed for Smartlink chipsets.

 A slmodem-2.9.9? series retains a much broader license for other chipset support,
 has some more recent updates than the slmodem-2.9.10, and can be downloaded
from http://linmodems.technion.ac.il/packages/smartlink/ Though not all will be needed, download the most recent versions of files:
   slmodem-2.9.9?.tar.gz - provides slamr driver and slmodemd daemon
   SLMODEMD-2.9.9e-pre1-alsa.tar.gz - alreadly compiled slmodemd
   ungrab-winmodem.tar.gz - may be needed for usage with slamr.
Details on their usage are in Slmodem.txt, Slmodem-ALSA.txt and http://linmodems.technion.ac.il/slmodem-serial.html

 == Checking PCI IDs through modem chip suppliers ==

  ======= PCI_ID checking completed ======
 Update=2005_Sept_13

Analyzing information for PCMCIA device at PCI Bus 02:04.0
02:04.0 CardBus bridge: Texas Instruments PCI1520 PC card Cardbus Controller (rev 01)
        Subsystem: Hewlett-Packard Company: Unknown device 006b
        Flags: bus master, medium devsel, latency 168, IRQ 10
        Memory at d0205000 (32-bit, non-prefetchable) [size=4K]
        Bus: primary=02, secondary=03, subordinate=06, sec-latency=176
        Memory window 0: 58000000-59fff000 (prefetchable)
        Memory window 1: 5e000000-5ffff000
        I/O window 0: 0000a400-0000a4ff
        I/O window 1: 0000a800-0000a8ff
        16-bit legacy interface ports at 0001

GREPping for an inserted PCMCIA modem with filter: ommunication

Analyzing information for PCMCIA device at PCI Bus 02:04.1
02:04.1 CardBus bridge: Texas Instruments PCI1520 PC card Cardbus Controller (rev 01)
        Subsystem: Hewlett-Packard Company: Unknown device 006b
        Flags: bus master, medium devsel, latency 168, IRQ 10
        Memory at d0206000 (32-bit, non-prefetchable) [size=4K]
        Bus: primary=02, secondary=07, subordinate=0a, sec-latency=176
        Memory window 0: 5a000000-5bfff000 (prefetchable)
        Memory window 1: 60000000-61fff000
        I/O window 0: 0000ac00-0000acff
        I/O window 1: 00001000-000010ff
        16-bit legacy interface ports at 0001

GREPping for an inserted PCMCIA modem with filter: ommunication
 If a PCMCIA modem is currently inserted and the sockets activated by
    /etc/init.d/pcmcia start
 then the PCMCIA bridge is NOT transparent.

 If the modem is known to have a Lucent digital signal processing chipset,
 then PCMCIA.tar.gz variant assembled by Joern Wustenfeld is necessary,
 rather than the standard ltmodem-8.31a10.tar.gz at http://ltmodem.heby.de/
GCCversion=3.3.6

For information on modem port creation under the UDEV device file system see:
   http://linmodems.technion.ac.il/archive-fourth/msg03299.html for Conexnant modems
   http://linmodems.technion.ac.il/archive-fifth/msg01177.html for Lucent/Agere DSP modems

The following information blocks just query some ppp support items.

====================================================
   grep -rs ppp /etc/modprobe.*
-------------------------------------

-------------------------------------
 Resident PPP support modules are properly uncompressed .
 COMM services are not active
Be sure to read the section about ppp related modules and aliases in Modem/YourModem.txt
DEVPPP=crw-rw---- 1 root uucp 108, 0 2001-03-25 16:04 /dev/ppp

  The current modem symbolic link is: /dev/modem -> ttyS1
  The ports /dev/ttyS0 or 1,2,3 are for standard Controller chip modems

 No devfsd.conf file found, indicated absense of the devfsd daemon package
 for device file system (devfs) symbolic link support.

DEVFSD=
 ---- dmesg queries -------

  Beginning with Fedora 2 kernel-2.6.6-1.427, kernel-headers needed
  for compiling drivers are provide at: /lib/modules/kernel-version/build/
  Thus upgrading above kernel 2.6.5-1.358 to 2.6.6-* is Stongly Recommended

  pppd version 2.4.2 may not be fully compatible with 2.6.8 kernel releases.
  If an initial CONNECT is achieved without PPP being subsequently established,
  drop back to a 2.4.1 version. This has worked for PCTEL AMR modem users,
  supported by the http://www.smlink.com slmodem software.
  Check pppd version with:
    pppd --version
  See http://linmodems.technion.ac.il/archive-fourth/msg03167.html

  slackware is not yet providing pre-compiled drivers for WinModems
-------------------------------------------------------

I was using Slackware when I used scanModem at that time.

It sounds familiar to me, it seems to be the same bug as me, but I use a LT modem, not a smartlink.

Perhaps the problem is in ALSA

towsonu2003 (towsonu2003) wrote :

> Perhaps the problem is in ALSA

that makes sense

Gert Kulyk (gkulyk) wrote :

The modem is working for me with the alsa-driver. Please try the following settings (I know, this does not apply to all configs:)

wvdial.conf

[Dialer Defaults]
Modem = /dev/ttySL0
Baud = 57600
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init3 = AT+MS=34 # this line is essential for me
Carrier Check = no # this line, too
ISDN = 0
Modem Type = Analog Modem
Phone = YOURPHONE
Username = YOURNAME
Password = YOURPASSWORD

towsonu2003 (towsonu2003) wrote :

I'll have to get back to you on this one (not using dial up, but I'll use it sooner or later)... thanks for the suggestion :) hope that works.

Changed in sl-modem:
status: Unconfirmed → Needs Info
Changed in alsa-driver:
status: Unconfirmed → Needs Info
Daniel T Chen (crimsun) on 2006-09-25
Changed in alsa-driver:
status: Needs Info → Rejected
towsonu2003 (towsonu2003) wrote :

I'll reopen when I have an opportunity to provide info

Changed in sl-modem:
status: Needs Info → Rejected
Dragan Lukic (ldrax) wrote :

another BIG bump...

not to overload this page with data... all is said here:
http://ubuntuforums.org/showpost.php?p=2757583&postcount=6
and here:
http://ubuntuforums.org/showpost.php?p=2759865&postcount=8

I have tried everything I have found on the internet in 5 days active research, including this Init3 fix... and without results.

Here is what wvdial says:
[code]
wvdial
--> WvDial: Internet dilaer version 1.56
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending ATZ
ATZ
OK
--> Sending AT+MS=34
AT+MS=34
OK
--> Modem initialized.
--> Sending: ATDT042112242
--> Waiting for carrier.
ATDT042112242
NO CARRIER
ERROR
--> No Carrier! Trying again.
--> Sending: ATDT042112242
--> Waiting for carrier.
ATDT042112242
NO CARRIER
ERROR
--> No Carrier! Trying again.[/code]

etc... until I stop wvdial

and wvdial.conf is like this:
[code]
[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init3 = AT+MS=34
Modem Type = Analog Modem
Baud = 57600
New PPPD = yes
Modem = /dev/ttySL0
ISDN = 0
Phone = 042110042
Password = my pass
Username = my username
Carrier Check = no
Stupid Mode = yes[/code]

This modem was working in Edgy just fine, so it is not broken, and I cant change it since it is integrated in my laptop.

It would be really great if someone takes a notice of this issue, dialup is not dead yet.. and as long as laptops are shipped with them, FULL (possible) support MUST be available.

redfox7691 (claudio-bizzarri) wrote :

From ALSA bugtrack web site:

I'm not sure if this is a issue in alsa, it seems to be slmodemd's fault. slmodemd requests a period size of 48 using snd_pcm_hw_params_set_period_size_near() in setup_stream() and aborts if alsa returns anything different. Newer alsa versions return 64, and this should be gracefully handled by slmodemd. The following quick-and-dirty patch to slmodemd allows it to start and communicate, but proper error handling must be implemented:

diff -rud slmodem-2.9.11-20060727-orig/modem/modem_main.c slmodem-2.9.11-20060727/modem/modem_main.c
--- slmodem-2.9.11-20060727-orig/modem/modem_main.c 2005-09-22 10:05:27.000000000 -0300
+++ slmodem-2.9.11-20060727/modem/modem_main.c 2007-07-09 16:26:15.000000000 -0300
@@ -379,11 +379,13 @@
                ERR("cannot set periods for %s: %s\n", stream_name, snd_strerror(err));
                return err;
        }
+#if 0
        if ( rsize != size ) {
                ERR("period size %ld is not supported by %s (%ld).\n",
                    size, stream_name, rsize);
                return -1;
        }
+#endif
        rsize = size = use_short_buffer ? rsize * dev->buf_periods : rsize * 32;
        err = snd_pcm_hw_params_set_buffer_size_near(handle, hw_params, &rsize);
        if (err < 0) {

Changed in sl-modem:
status: Invalid → New
Adrianus (adrianus-kurnadi) wrote :

I have this issue and the work around I did was to downgrade sl-modem-daemon to the Edgy version. Hope this helps.
I also hope that this get fixed soon.

markovuc (markovuc) wrote :

I have the same problem, but on debian testing (lenny). After update, new version of sl-modem-daemon came in, and modem stopped working, same error ('NO CARRIER' immediately after starting of dialing).

So, I downgraded package to previous version, sl-modem-daemon_2.9.9d+e-pre2-10_i386.deb to sl-modem-daemon_2.9.9d+e-pre2-7etch2_i386.deb, and everything works fine, like before (you can download old sl-modem-daemon package from packages.debian.org, section etch, and install it with 'dpkg -i old_package_name.deb', that is all to do for downgrade). Thank you very much, Adrianus.

I have a intel HDA sound card (Fujitsu Siemens Amilo Pi 1505 laptop) with a Si3054 modem. The "fix" posted by redfox7691 allows the modem to bypass the "NO CARRIER" it would get before, but now fails with a "NO DIALTONE", so something is still bad.. I am using kubuntu hardy, sl-modem-daemon 2.9.10+2.9.9d+e-pre2-5ubuntu4.

chris (chris-bolduc) wrote :

I am having this problem using KPPP in Kubuntu Gutsy. It never dials and always says "NO CARRIER." Has this been "fixed" yet?

KInfoCenter says it is a Conexant D480 MDC V.9X modem. When I installed Gutsy, it asked me if I wanted to install a restricted driver for my modem and I said yes. I have sl-modem-daemon 2.9.10+2.9.9d+e-pre2-5ubuntu4 according to adept.

@ Chris

Try this:
Remove that driver from Restricted Driver and try this from Dell:

http://support.dell.com/support/downloads/downloahttp://support.dell.com/support/downloads/download.aspx?c=us&l=en&s=gen&releaseid=R155004&SystemID=INSPIRONI6400/E1505&servicetag=&os=UBLN&osl=en&deviceid=8593&devlib=0&typecnt=0&vercnt=1&catid=-1&impid=-1&formatcnt=1&libid=20&fileid=206745d.aspx?c=us&l=en&s=gen&releaseid=R155004&SystemID=INSPIRONI6400/E1505&servicetag=&os=UBLN&osl=en&deviceid=8593&devlib=0&typecnt=0&vercnt=1&catid=-1&impid=-1&formatcnt=1&libid=20&fileid=206745

Download deb package and install it.

I proposed to Ubuntu release team to add it for Hardy in Freezes exception.

See Bug #187262

Tell me if it works out of the box.

Sergio

2008/2/21, chris <email address hidden>:
> I am having this problem using KPPP in Kubuntu Gutsy. It never dials
> and always says "NO CARRIER." Has this been "fixed" yet?
>
> KInfoCenter says it is a Conexant D480 MDC V.9X modem. When I installed
> Gutsy, it asked me if I wanted to install a restricted driver for my
> modem and I said yes. I have sl-modem-daemon
> 2.9.10+2.9.9d+e-pre2-5ubuntu4 according to adept.
>
>
> --
> "No Carrier" on dial up
> https://bugs.launchpad.net/bugs/47809
>
> You received this bug notification because you are subscribed to sl-
> modem in ubuntu.
>

chris (chris-bolduc) wrote :

Thanks, but that link doesn't work. =(

Sergio Zanchetta (primes2h) wrote :

Sorry.
Here you have the correct link

http://support.dell.com/support/downloads/download.aspx?c=us&l=en&s=gen&releaseid=R155004&SystemID=INSPIRONI6400/E1505&servicetag=&os=UBLN&osl=en&deviceid=8593&devlib=0&typecnt=0&vercnt=1&catid=-1&impid=-1&formatcnt=1&libid=20&fileid=206745

And here is the bug link:

https://bugs.launchpad.net/ubuntu/+source/linux-restricted-modules-2.6.24/+bug/187262

Let me know, please.

2008/2/21, chris <email address hidden>:
> Thanks, but that link doesn't work. =(
>
>
> --
>
> "No Carrier" on dial up
> https://bugs.launchpad.net/bugs/47809
> You received this bug notification because you are subscribed to sl-
> modem in ubuntu.
>

chris (chris-bolduc) wrote :

Thanks, works great.

Note that it does not install properly if you just double-click the .deb file, you have to install it from the command-line:
sudo dpkg -i hsfmodem_7.60.00.06oem_i386.deb

Sergio Zanchetta (primes2h) wrote :

What happens?
It installs nice for me.
You need to wait few minutes because it builds proper kernel modules.

2008/2/22, chris <email address hidden>:
> Thanks, works great.
>
> Note that it does not install properly if you just double-click the .deb file, you have to install it from the command-line:
> sudo dpkg -i hsfmodem_7.60.00.06oem_i386.deb
>
>
> --
>
> "No Carrier" on dial up
> https://bugs.launchpad.net/bugs/47809
> You received this bug notification because you are subscribed to sl-
> modem in ubuntu.
>

chris (chris-bolduc) wrote :

OK more weirdness. That new driver gave me IRQ conflict errors with my wireless card (bcm43xx: FATAL ERROR: BCM43xx_IRQ_XMIT_ERROR) and caused my computer not to be able to hibernate (got a message "OsSleep: Should not sleep this long in this context!").

BUT, I uninstalled it and installed the restricted driver from the repository and now it works again.

Very, very odd...

Sergio Zanchetta (primes2h) wrote :

Do you mean you reinstalled sl-modem driver from restricted manager?

2008/3/2, chris <email address hidden>:
> OK more weirdness. That new driver gave me IRQ conflict errors with my
> wireless card (bcm43xx: FATAL ERROR: BCM43xx_IRQ_XMIT_ERROR) and caused
> my computer not to be able to hibernate (got a message "OsSleep: Should
> not sleep this long in this context!").
>
> BUT, I uninstalled it and installed the restricted driver from the
> repository and now it works again.
>
> Very, very odd...
>
>
> --
>
> "No Carrier" on dial up
> https://bugs.launchpad.net/bugs/47809
> You received this bug notification because you are subscribed to sl-
> modem in ubuntu.
>

chris (chris-bolduc) wrote :

Yes

Sergio Zanchetta (primes2h) wrote :

Just one thing.

Here is latests driver from dell.
http://linux.dell.com/files/ubuntu/modem-drivers/hsf/

Could you please try it and let me know?
Thanks.

2008/3/3, chris <email address hidden>:
> Yes
>
>
> --
>
> "No Carrier" on dial up
> https://bugs.launchpad.net/bugs/47809
> You received this bug notification because you are subscribed to sl-
> modem in ubuntu.
>

Hello,

  I prepared a package for the latest upstream release of sl-modem.
  The package can be found on mentors.debian.net:
  - URL: http://mentors.debian.net/debian/pool/non-free/s/sl-modem
  - Source repository: deb-src http://mentors.debian.net/debian unstable main contrib non-free
  - dget http://mentors.debian.net/debian/pool/non-free/s/sl-modem/sl-modem_2.9.11~20080817-1.dsc

  Please test it and report if your bugs got solved and any suggestions you've got.

  Thanks.

--
 أحمد المحمودي (Ahmed El-Mahmoudy)
  Digital design engineer
  SySDSoft, Inc.
 GPG KeyID: 0x9DCA0B27 (@ subkeys.pgp.net)
 GPG Fingerprint: 087D 3767 8CAC 65B1 8F6C 156E D325 C3C8 9DCA 0B27

Hello,

  For those who need a binary package, I have uploaded the package to my
  PPA (https://launchpad.net/~aelmahmoudy/+archive), also fixed an FTBFS
  for Intrepid. Binary packages for Hardy and Intrepid are available.

--
 أحمد المحمودي (Ahmed El-Mahmoudy)
  Digital design engineer
  SySDSoft, Inc.
 GPG KeyID: 0x9DCA0B27 (@ subkeys.pgp.net)
 GPG Fingerprint: 087D 3767 8CAC 65B1 8F6C 156E D325 C3C8 9DCA 0B27

Daniel T Chen (crimsun) on 2008-12-21
Changed in sl-modem:
status: New → Fix Released
finifly (fini-fly) wrote :

I just tried the new Intrepid package and I still get the No Carrier loop.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers