Ubuntu

Skype causes almost-full lockup after 30 minutes of operation

Reported by hexafraction on 2012-04-12
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
skype
Fix Released
Undecided
Unassigned
skype (Ubuntu)
Undecided
Unassigned

Bug Description

This bug is from AskUbuntu. I am filing it for somebody else. The question is at http://askubuntu.com/questions/110917/skype-causes-ubuntu-to-freeze

On either of my two computers, the whole desktop gets extremely slow after Skype runs for about 20-30 min. That is, I can no longer use it, the mouse will only move every other second for some pixels, or not at all; keyboard input does not seem to work (at least alt+f4, etc.)

 My laptop runs on an Intel Core 5, my desktop an AMD Phenom 9650. The former has an Intel HD 3000 graphics processor (rc6 and stuff enabled, which never caused crashes without Skype enabled), the latter a Nvidia GeForce 8400 GS with proprietary drivers.

I have only added Google Chrome and Dropbox to my system.

Neither in syslog nor in the xorg log are any entries near the time of the freeze. Starting Skype in the Terminal wont give any results, it seems to crash before reporting.

aeronaut (dfitze) wrote :

Thank you very much, this bug report was filed on my behalf - since the askubuntu-question was mine. The problem described does no more occur on my machines, however, I did nothing to prevent it, so I cannot tell why. Skype runs well again without freezing my desktop or laptop.

So i suggest closing this report unless someone else is having the same problem.

But thank you, Robert!

hexafraction (rarkenin) wrote :

Nobody affected any longer thus changing to Invalid... anybody may mark as new again if they have the same problem

Changed in skype (Ubuntu):
status: New → Invalid
Daniel Cunnama (cunnama) wrote :

I am still having this issue, I'm running Skype 2.2.0.35 on Ubuntu 11.10.

I can't start skype without the entire system freezing.

Changed in skype (Ubuntu):
status: Invalid → New
hexafraction (rarkenin) wrote :

@cunnama It looks like the same issue, please describe in more detail. Also, I need to know the version of Skype you are using and the Linux Distro and version you are using. Also, please mark this bug as affecting you so it can be marked as confirmed.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in skype (Ubuntu):
status: New → Confirmed
Daniel Cunnama (cunnama) wrote :

Hi Robert,

Thanks,
I am running Ubuntu 11.10 kernel 3.0.0-17-generic 64-bit and Skype 2.2.0.35 64-bit.

Basically I had skype in the startup list and the computer would be unresponsive immediately upon boot.

I've since removed it from startup but if I try and start skype manually the entire system freezes. The mouse seems to jitter around slowly as I move it making it appear to be a memory issue but I can't force shut down or anything. I have to power down in order to get out of it.

Starting from a terminal does not cause an output and I have also looked in syslog and the xorg log and there doesn't seem to be any info about it...

Daniel Cunnama (cunnama) wrote :

Hi Robert,

I've updated to 12.04 LTS and Skype seems to start and run normally once again.

I guess it will remain a mystery.

Thanks,
Daniel

Simon Woolf (semw) wrote :

Funnily enough, I only started having this problem after I upgraded to 12.04.

A few more details:

 - The system starts reacting very slowly because skype is using up all available system memory almost immediately after you log in to it. (Note: it is on log-in, not actually starting skype; disable automatic log-in to prove it).

 - After some minutes, skype crashes with an out of memory error.

 - Subsequently starting skype it runs without problems - the problem only happens the first time skype starts on a cold boot.

 - The problem occurs with both the version of skype in the repositories, and the deb available from skype.com.

 - There's a thread on the skype forums about this bug, with several guesses as to the cause and suggested workarounds: http://community.skype.com/t5/Linux/Skype-eats-all-system-memory-Linux/td-p/222

Simon

Marius B. Kotsbak (mariusko) wrote :

Simon, please see if the new 4.0 version available at skype.com solves this problem. If that is the case, solving bug #1013258 will solve this bug as well.

Changed in skype (Ubuntu):
status: Confirmed → Incomplete
Simon Woolf (semw) wrote :

Annoyingly, for the past week I hadn't had this problem at all. (Well, good for me, but annoying for bug-fixing purposes). I've just upgraded to 4.0 today, and it seems to be fine, but I don't know if that's because it's actually fixed, or if it's just that whatever changed a week ago meant I'm no longer affected.

Sorry that isn't more helpful. All I can do is report back if it ever starts happening again.

Changed in skype:
assignee: nobody → Marius Kotsbak (mariusko)
assignee: Marius Kotsbak (mariusko) → nobody
status: New → Fix Released
Changed in skype (Ubuntu):
status: Incomplete → Confirmed
papukaija (papukaija) wrote :

This bug report is being closed due to your last comment regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in skype (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers