No desktop (gtk) Qt style in skype:i386

Bug #863218 reported by Dmitry Pankratov on 2011-09-30
62
This bug affects 14 people
Affects Status Importance Assigned to Milestone
skype (Ubuntu)
Undecided
Unassigned

Bug Description

Using skype:i386 2.2.0.35-0oneiric2 package installed under Ubuntu 11.10 64-bit.
UI is using Cleanlooks Qt style instead of the desktop gtk style.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in skype (Ubuntu):
status: New → Confirmed
franco_bez (franco-bez) wrote :

This bug is a regression as with natty skype was in Ambiance Stlye.

Right after upgrade to oneiric both of my 64bit machines were affected by this bug.

A test on Virtualbox with the 32bit Version showed that only 64bit Version is affected.

AJ Fite (goldman60) wrote :

Also effects 12.04

Dmitry Pankratov (dremon) wrote :

Found a workaround:

1. Create ~/.gtkrc-2.0 file with the following line:

gtk-theme-name="Ambiance"

2. Create ~/.xprofile file with the following contents:

export GTK2_RC_FILES="$HOME/.gtkrc-2.0"

franco_bez (franco-bez) wrote :

I can no longer reproduce the bug in the latest 12.04 LTS beta2

Well I can reproduce this on my 12.04 final system with skype-bin:i386 2.2.0.35-0precise3.
Workaround by dmitry works as expected but is no good solution.
Better description of the bug: QGtkStyle tries to find the current gtk theme but is not able to do so and falls back to clearlooks. This applies to all 32bit Qt applications on a 64bit system. I believe QGtkStyle uses libgnomeui to find the correct GTK Style but is not able to do that because the lib is only available in 64bit form. Trying to install the i386 version will replace the 64bit version. The other problem is that QGtkStyle also expects the GTK Theme Engine to be in 32bit, so you have to install gtk2-engines-murrine:i386 for the default light-themes.

Wow, that's strange. I switched back to Ubuntu yesterday and reinstalled it. Now I no longer have to apply the fix by dmitry, it somehow got fixed.

disregard my comment above, I made a mistake. Bug still exists!

Dmitry Pankratov (dremon) wrote :

Interesting; I don't have it anymore in 12.04.

franco_bez (franco-bez) wrote :

Also for me the bug is gone.
Both on precise and quantal skype shows up in the correct style

Hi, a new skype version 4.1.0.20.0-0ubuntu0.12.04.2 is available, could you please try if you still have the bug with the new version?

If you still have this problem please set the status back to "new".

thanks

Changed in skype (Ubuntu):
status: Confirmed → Incomplete

I have the bug with the new version of Skype on Ubuntu 12.10. I'm still trying to use the workaround, it seems not to work.

Changed in skype (Ubuntu):
status: Incomplete → Confirmed

Also, changing the theme in QtConfig lead to an awful Skype with strange fonts, and reverting it doesn't work.

Dmitry Pankratov (dremon) wrote :

Try installing ia32-libs-multiarch:i386 package.

It worked, thank you. So this looks like a problem in the package, it has a missing dependency.

tags: added: unmetdeps

Also, if you consider important to input accented letters, there is another unmet dependency: libc6-i386
If you don't install it Skype can't find gconv, see here: https://bugs.archlinux.org/task/19768

Leonid Evdokimov (darkk) wrote :

After upgrade 12.10 (quantal) to 13.04 (raring) skype lost proper style on my amd64 laptop with following warnings:

Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

Installing these two packages solved problem for me: libcanberra-gtk-module:i386 gtk2-engines-murrine:i386

I have no idea what gtk style/engine/module is used nowadays, but my desktop settings are almost default :)

Michael Steenbeek (gymnasiast) wrote :

Also present in amd64 version of Ubuntu 13.10. But gtk2-engines-murrine:i386 libcanberra-gtk-module:i386 cannot be installed because of dependencies on other i386 libraries which conflict with their amd64 counterparts, requiring the user to remove about 300 packages dependent on it.

Seriously? I've issued this command yesterday:
sudo apt-get install libcanberra-gtk-module:i386 gtk2-engines-murrine:i386

It installed approximately 10 MB of dependencies, that's it. I am using Ubuntu 13.10 amd64.

Aldin K (aldin) wrote :

sudo apt-get install libcanberra-gtk-module:i386 gtk2-engines-murrine:i386

^^ It works for me too.

Ubuntu 13.10 x86_64, Skype 4.2.0.11

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers