should depend on a versioned skype-bin?

Bug #1372846 reported by Mark on 2014-09-23
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
skype (Ubuntu)
High
Unassigned

Bug Description

The present skype package depends only on an unversioned skype-bin, is this intentional?

Version: 4.3.0.37-0ubuntu0.12.04.1
Depends: skype-bin

I noticed this when I wanted to upgrade just skype (apt-get install skype) which failed to also upgrade skype-bin. I suppose most users will not notice this as they upgrade all packages at once.

Gunnar Hjalmarsson (gunnarhj) wrote :

Suppose it should be:

Depends: skype-bin (= ${binary:Version})

I'd like to emphasize the importance of this bug. I have seen several users at Ask Ubuntu who claimed to have installed latest version, but 4.2 was still loaded. I thought they were just confused, but now we have a theory of what might have happened.

Changed in skype (Ubuntu):
importance: Undecided → High
status: New → Triaged
Mikhail M Paremski (mishaparem) wrote :

Is this the reason Skype installation fails on my machine?

Tue Sep 30 11:41:59 $ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04.1 LTS
Release: 14.04
Codename: trusty

Tue Sep 30 11:37:00 $ sudo apt-get install skype
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 skype : Depends: skype-bin
E: Unable to correct problems, you have held broken packages.

Gunnar Hjalmarsson (gunnarhj) wrote :

Maybe. What does this result in:

dpkg-query -W skype skype-bin

And what happens if you do:

sudo apt-get install skype skype-bin

Gunnar Hjalmarsson (gunnarhj) wrote :

Any chance that someone can give this bug report some attention? It messes it up for people.

http://askubuntu.com/questions/557463

camara (b-camara81) wrote :

~$ sudo apt-get install skype skype-bin
[sudo] password for c....:
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
skype est déjà la plus récente version disponible.
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 skype : Est en conflit avec: skype-bin mais 4.3.0.37-0ubuntu0.12.04.1 devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Help please.

Gunnar Hjalmarsson (gunnarhj) wrote :

@camara: This is not a support forum, but maybe you need to activate Canonical Partner:

https://help.ubuntu.com/stable/ubuntu-help/addremove-sources.html#canonical-partner

tags: added: packaging
tags: added: trusty
Ben (7-ben-a) wrote :

This seems to be affecting me. I run 16.04. and wanted to install skype but

The following packages have unmet dependencies:
 skype : Depends: skype-bin
E: Unable to correct problems, you have held broken packages.

I then tried to install skype-bin:

The following packages have unmet dependencies:
 skype-bin:i386 : Depends: libqtwebkit4:i386 (>= 2.2~2011week36) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

And so on. I am just a user.

Gunnar Hjalmarsson (gunnarhj) wrote :

@Ben: Not related to this bug. As said above, this is not a support forum. Please seek help at e.g. <http://askubuntu.com>.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers