pulseaudio uses too much cpu for doing nothing

Bug #1345096 reported by José Marcos Andrade Ferraro on 2014-07-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
skype (Ubuntu)
Undecided
Unassigned

Bug Description

pulseaudio uses varying amounts of cpu (8 - 25%) even when there is no sound being played at all.
This happens every time I turn mu notebook on, but simply killing it solves the issue. That means it will respawn using much more reasonable cpu (0.1%).
The sound does work fine all the time.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: pulseaudio 1:4.0-0ubuntu11
ProcVersionSignature: Ubuntu 3.13.0-32.57-generic 3.13.11.4
Uname: Linux 3.13.0-32-generic i686
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ferraro 4943 F.... pulseaudio
 /dev/snd/pcmC0D0p: ferraro 4943 F...m pulseaudio
CurrentDesktop: Unity
Date: Sat Jul 19 17:03:02 2014
ExecutablePath: /usr/bin/pulseaudio
InstallationDate: Installed on 2013-05-03 (442 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release i386 (20130424)
SourcePackage: pulseaudio
UpgradeStatus: Upgraded to trusty on 2014-07-19 (0 days ago)
dmi.bios.date: 10/03/2011
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.02
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 17F9
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 10.31
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.02:bd10/03/2011:svnHewlett-Packard:pnHPPaviliondv6NotebookPC:pvr0593110000204610000620100:rvnHewlett-Packard:rn17F9:rvr10.31:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.name: HP Pavilion dv6 Notebook PC
dmi.product.version: 0593110000204610000620100
dmi.sys.vendor: Hewlett-Packard

Raymond (superquad-vortex2) wrote :

[ 47.886798] [drm] Disabling audio 0 support

Changed in pulseaudio (Ubuntu):
status: New → Incomplete
David Henningsson (diwic) wrote :

Looking at your data, it looks like skype has a low-latency stream running. I e, killing skype should also fix the issue.

Unfortunately, skype is closed source software, so not sure how to fix the root cause.

affects: pulseaudio (Ubuntu) → skype (Ubuntu)
Changed in skype (Ubuntu):
status: Incomplete → Triaged

You are right, getting rid of skype solves the issue.
Thanks a lot!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers