Please update Skype to new upstream v.4.1

Bug #1079348 reported by papukaija on 2012-11-15
52
This bug affects 10 people
Affects Status Importance Assigned to Milestone
skype (Ubuntu)
Undecided
Unassigned

Bug Description

Please update to the new upstream release v.4.1.

Changes, source: http://blogs.skype.com/garage/2012/11/skype_41_for_linux.html :

- Sign in with your Microsoft account
- Instant Message with Messenger
- User interface tweaks to improve the experience
- Implemented support for secondary logins
- Easier conference calls
- Support for Skype URIs on Web sites
- Some bug fixes, see the above link for details

Thanks.

papukaija (papukaija) on 2012-11-15
tags: added: upgrade-software-version
description: updated
summary: - Please update Skype to new upstream v4.1
+ Please update Skype to new upstream v.4.1
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in skype (Ubuntu):
status: New → Confirmed

In the meantime skype is available in my ppa
https://launchpad.net/~costamagnagianfranco/+archive/locutusofborg-ppa
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Elad Tsur (eladts) wrote :

Can you please post also the Ubuntu 10.04 (lucid) version in the PPA?

Unfortunately skype fails to build in 10.04 because of a missing library and a missing dh-apparmor, I'll take a look asap, but I hope canonical will update it

Gianfranco

On Fri, Nov 16, 2012 at 10:25:05AM -0000, LocutusOfBorg wrote:
> In the meantime skype is available in my ppa
> https://launchpad.net/~costamagnagianfranco/+archive/locutusofborg-ppa

The skype binaries are not freely redistributable. This is a violation both
of the Skype copyright and the PPA terms of use. Please remove these
packages.

  https://help.launchpad.net/PPATermsofUse

The packages distributed in the Canonical partner archive are nearly
identical to the ones distributed upstream from skype.com. Providing them
in the partner archive is largely for convenience, to let users find them
through the package manager without having to do any additional
configuration. Thus, there's no need for providing packages in a ppa.

Sorry for this, I didn't know about the copyright violation (I thought about)
I saw on launchpad 2 or 3 ppa's with skype binaries and I thought there were no copyright issues...

(I just want to help in giving an up to date package to users, "partner" repository takes always some more time to give it)

Anyway they aren't on my ppa anymore
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Maybe you should ask them to remove binaries too...

Steve Langasek (vorlon) wrote :

On Sat, Nov 17, 2012 at 09:43:20AM -0000, LocutusOfBorg wrote:
> Sorry for this, I didn't know about the copyright violation (I thought
> about) I saw on launchpad 2 or 3 ppa's with skype binaries and I thought
> there were no copyright issues...

On Sat, Nov 17, 2012 at 09:51:03AM -0000, LocutusOfBorg wrote:
> Maybe you should ask them to remove binaries too...

Yes, we should follow up on this. Can you provide a pointer to the PPAs in
question? Thanks!

Just click on overview and "Other versions of 'skype' in untrusted archives."

and here too
https://launchpad.net/ubuntu/+ppas?name_filter=skype
(here is a collection of programs containing the word skype, so you will find e.g. pidgin-skype too)

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

BTW this is really funny, I packaged skype 4.1 (for the first time) in less than 10 minutes, and built it successfully after a little change (one dependence was added).

Canonical how long will take to update it?
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Night Train (nighttrain) wrote :

today packages skype are available for updating on repository canonical partner, but there isn't skype-bin for 64 bit

skype depend skype-bin but is not possible to install

there isn't on http://archive.canonical.com/ubuntu/pool/partner/s/skype/?C=M;O=D

skype-bin there is only for i386

would you please to correct?

thanks

You have to purge any skype* and install it again
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Ok this is true, I see no skype-bin

But you can install directly skype-bin and it should work (I hope they fix the problem soon)

Whoopie (whoopie79) wrote :

There seems to be a dependency issue:

whoopie@v131:~$ LANG=C sudo apt-get install skype
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 skype : Depends: skype-bin
E: Unable to correct problems, you have held broken packages.

whoopie@v131:~$ LANG=C sudo apt-get install skype skype-bin
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 skype-bin:i386 : Breaks: skype (< 4.1.0.20-0.11.10.1) but 4.1.0.20-0ubuntu0.11.10.1 is to be installed
E: Unable to correct problems, you have held broken packages.

Night Train (nighttrain) wrote :

but, then, just as well to install the package from site of skype for linux (it works)

I’d rather to use our repository

many thanks

Am also unable to install skype 4.1.0.20 with update-manager on my Ubuntu 12.04 system.

Elad Tsur (eladts) wrote :

There is no Ubuntu 10.04 (lucid) version in the partner repository, although there is one on skype.com.

szbab (szbab-club) wrote :

same problem
on a 64 bit package skype-bin has disappeared
on a 32 bit update to uninstall skype

the deposits partners have a problem

The following packages have unmet dependencies:
 skype-bin:i386 : Breaks: skype (< 4.1.0.20-0.11.10.1) but 4.1.0.20-0ubuntu0.11.10.1 is to be installed.

please reply on bug 1082030

Changed in skype (Ubuntu):
status: Confirmed → Fix Released
Steve Langasek (vorlon) wrote :

On Thu, Nov 22, 2012 at 02:27:42PM -0000, Elad Tsur wrote:
> There is no Ubuntu 10.04 (lucid) version in the partner repository,
> although there is one on skype.com.

The 10.04 build of skype has a library dependency which is only satisfiable
on i386 in 10.04, not on amd64. The package in the partner repository will
need to be held back unless/until this can be resolved.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers