Video blinking blue during incoming call

Bug #1078068 reported by debora1c on 2012-11-12
110
This bug affects 23 people
Affects Status Importance Assigned to Milestone
skype (Ubuntu)
Undecided
Unassigned
Nominated for Xenial by Nish Aravamudan
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned
Nominated for Xenial by Nish Aravamudan

Bug Description

Hallo
I upgraded to ubuntu 12.04LTS and Skype 4.0. When I make a video call I can ear and see the other person fine, but when I start my video, the image of the incoming video call starts flashing between blue and normal video( the same for my mirror image in the little square). The other person sees me fine.
I didn't have this problem with the previous version of Skype. I tried to desinstall and install Skype form the Ubuntu Softwer Center but no change. The webcam is a Logitech. after the upgrade it didn't work anymore with Cheese, but works fine with another program called guvcview.
Thank in advance for your help

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1078068/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → skype (Ubuntu)

Hi, a new skype version 4.1.0.20.0-0ubuntu0.12.04.2 is available, could you please try if you still have the bug with the new version?

thanks

Changed in skype (Ubuntu):
status: New → Incomplete

Set back the status to new if the bug is still alive.

Hi
as requested I updated Skype to 4.1.0.20.0-0ubuntu0.12.04.2 version with update manager and rebooted the system. the problem is even worse: incoming video and my mirror are totally black (so not blinking blue anymore). My webcam is fine since I can see myself when I check in the option menu under video device. I can talk fine, the other person sees me and hear me (the incoming call comes from a windows system).
 skype 2 worked just fine in my system.
thanks

Changed in skype (Ubuntu):
status: Incomplete → New

I have noticed that if I start skype from terminal with

LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype

I have the following message:

libv4l2: error dequeuing buf: Device or resource busy

could that be the reason why I'm not able to see the incoming video call?

thanks for your help and suggestions

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in skype (Ubuntu):
status: New → Confirmed

strange enough today after update manager I've got the incoming video back. The video is still blinking blue, but better that nothing at all
starting skype from terminal I see this:
:~$ LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so /usr/bin/skype
libv4l2: error dequeuing buf: Device or resource busy
libv4l2: error dequeuing buf: Resource temporarily unavailable
libv4l2: error dequeuing buf: Device or resource busy
regards

Maybe you are affected by bug 967091 ?

I red the bug 967091, but I don't have blue faces on youtube video, just really a silly blue blinking skype.

Conf Comp User (boby1787) wrote :

First time posting.

I noticed that if i run a video in SMPlayer, pause it and then open a video conversation in skype, the incoming video no longer flickers blue.

The problem is that by doing this the outgoing video is o longer visible on my end. The reciving party sees the video perfectly though.

Hi
I confirm what you observed. I started a video with SMplayer and then paused it. I opened skype and started a video conversation and no more blue incoming video call. I could also see my mirror image fine.
I could close SMplayer, while talking on skype and video was fine as well.
If I try the reverse action (first start skype and then SMplayer with the video pause trick) doesn't work and the blue blinking video is there again
why SMplayer is so important to traduce the incoming video in skype? how the 2 programs are related?
any help?

Conf Comp User (boby1787) wrote :

Hi,

I just want to specify a few things:

1) For me, SMPlayer has to be started before a video conversation. So I can start skype, chat and do other things in the mean time. If I start a video conversation then I run SMPlayer, Skype video still flickers blue where as the opposite works out.

2) I originally used GTK UVC Video Viewer in place of SMPlayer and the same effect happened...

3) An important note in my case is that I am running Kubuntu 12.04 (with KDE back-ports enabled)
     However I have had the same problem on 12.04 with KDE back-ports NOT enabled.

4) My computer is a Dell Dimension 3000 with Intel I865G - Extreme Graphics 2
     See link for more detailed specs: http://support.dell.com/support/edocs/systems/dim3000/en/SM/specs.htm

      Because of this I noticed that the card has no hardware acceleration.... just software.
      See link for explanation: http://www.tomshardware.com/reviews/integrated-graphics-performance,674-3.html
         Quote: "The tiler, or zone renderer, design precludes (make impossible) the use of a hardware T&L engine".

Hope this sheds light on the matter.

ludic56 (ludic56) wrote :

Hello,

I have the same problem on Ubuntu 12.04 with skype 4.1.0.20.0-0ubuntu0.12.04.2 & PSeye.
I tried to start skype from terminal : LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l2convert.so /usr/bin/skype
but the video was still blinking blue and I saw this :
Corrupt JPEG data: 6 extraneous bytes before marker 0xc4
libv4l2: error dequeuing buf: Argument invalide
libv4l2: error dequeuing buf: Argument invalide

Hello,

I have the same problem with Xubuntu 12.04 + skype 4.2.0.11-1 on DELL computer (intel 865 G).
My webcam is Logitech HD C 270.

summary: - video blinking blue incomin call
+ Video blinking blue during incoming call

I thing the problem is Ubuntu not compatible with the intel video graphic 82865G.
Skype require : Video card driver with Xv support.

Chester (cd-pobox) wrote :

Same thing here (Intel 82865G). Would not be so much of an issue if we could turn off the self-image ("PIP"), as it only happens when the two videos are shown...

Nathan Osman (george-edison55) wrote :

I am having this problem as well with an old Dell notebook running Xubuntu 12.04.

'lspci' output:

    00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
    00:02.1 Display controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)

This only seems to happen with the latest version of Skype (4.2.0.11-1). Installing an older version of Skype (2.2.0.35-1) solved the problem (although it introduced some others).

The webcam is a Microsoft LifeCam VX-2000 connected via USB if that helps at all.

bmoneke (bmoneke-lc) wrote :

The same problem persists with the most recent version of Skype (skype_4.3.0.37) and Xubuntu 14.04 updated until today (September 6th 2014).
It affects Dell Computers (Dell Optiplex 170L) with an Intel 82865G integrated Graphics Controller and Xubuntu 14.04 32-bit.
Several different Webcams (Logitech, HP) were used with the same result.

Other computers with Xubuntu 14.04 64-bit and different graphics cards are not affected.

My first hypothesis was that the problem were in the 32-bit version, but other people with the same graphics cards had the same problem. Which computer was used?

My old PC was a 32bit, I don 't recall the brand. Now I have a laptop, brand "Why" 64 bit, with ubuntu 14.04 and skype is working fine.

bmoneke (bmoneke-lc) wrote :

I found a work-around:

I used the "nomodeset" option in the grub bootloader. There are two methods to set "nomedest":
Temporal: while booting press and hold shift in order to see the grub menu. Choose the entry you want to change (in a normal installation the first entry) and press "e" to edit it. Look for "quiet splash" and add "nomodeset" before it. Finally press "F10" to boot. If this worked for you, you can use the permanent way for all bootups.
Permanent: edit /etc/default/grub (for example: "sudo nano /etc/default/grub"): change the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="nomodeset quiet splash". Finally update the grub config: "sudo update-grub". The next time rebooting, you don't have to specify the boot option.

The problem is, now the graphics adaptor isn't as adaptable anymore (on a wide screen it has standard ratio resolution stretched to wide screen) and the graphics are sometimes lagging behind.

I also have this problem on a 32-bit Dell desktop. I have not tried the work around yet that bmoneke posted on 2014-09-10. Is the work-around worth it or does it cause other problems?

Hello,
I have found on net pretty dumb but working solution. Just cover your camera on skype (small one in corner) with some window (any window) and the other camera stops blinking. Aperantly problem is playing two videos simultaniously.

Hello,

If you change your the color depth (DefaultDepth) to 16, it will work without blinking.

anorakgirl (anorakgirl) wrote :

This is affecting me too.
Skype 4.3.0.37
Ubuntu 14.04.3 LTS
Asus Zenbook UX303 with Intel® Skylake ULT GT2 Graphics.

It's fine if my video is off, I can see the caller. As soon as I start my video, both video feeds start flickering blue.
The caller can still see me fine.

cement_head (andor-udel) wrote :

I think this should be fixed with the > 4.2.x kernel - so Ubuntu 16.04 LTS should not have this issue.

This is likely the SkyLake processor issue, and/or the Intel Graphics Stack on Linux

Michele Miccinesi (mih-ele) wrote :

I have the same problem on the last version of Ubuntu 64bit

I had the same problem with my Dell Latitude 5470 with Intel i7-6820HQ, Sky Lake (rev 07), running Ubuntu 15.10 (4.2.0-35-generic). I found a workaround by disabling Xvideo as suggested by Nikolay over at freedesktop in the post dated 2016-01-14 19:44:42 (https://bugs.freedesktop.org/show_bug.cgi?id=93461). Simultaneouos incoming and outgoing video now works perfectly.

cement_head (andor-udel) wrote :

Okay, the disabling of Xv is a workaround. How does one report this bug to Intel?

mdyn (tamerlaha-gmail) wrote :

The same problem on 16.04

I have the same problem with my Dell E5470 with Intel i5-6200U, Integrated HD Graphics 520, Ubuntu 16.04 (kernel 4.4.0-24-generic).

Czikus (czikus-gmail) wrote :

Same problem with Ubuntu 16.04 and kernel 4.6.3-040603-generic.

Nish Aravamudan (nacc) wrote :

Disabling xvideo does fix things, but c10 from that linked freedesktop bug seems like the most appropriate solution (2c4890001 from xf86-video-intel https://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?id=2c4890001). I will see if I can build this in a PPA to test.

cement_head (andor-udel) wrote :

@nacc This would be great to have as a PPA to test!

Nish Aravamudan (nacc) wrote :

I built it at:

https://launchpad.net/~nacc/+archive/ubuntu/lp1078068

However, in my testing, it did not fix the underlying issue. It was not quite the blue flickering, but it still flickered badly and would not resize with the Skype window. If I find some time tomorrow, I will see if there is a better fix I can find. It's possible I misunderstood https://bugs.freedesktop.org/show_bug.cgi?id=93461#c10 and Philipp simply used a tree at that HEAD.

Nish Aravamudan (nacc) wrote :

Ok, so I figured it was best to test the version in Yakkety. I rebuilt in Xenial locally and tested it, it fixed the problem for me! So that's exciting.

I've put this in the same PPA as 2:2.99.917+git20160522-1ubuntu1~16.04ppa1. I'm not sure it's appropriate to SRU the whole version, but given we're running a git snapshot (it seems) in 16.04 too, maybe it'd be fine. I'm going to update some of the bug metadata to make it clear where the bug is.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Fix Released
Changed in skype (Ubuntu):
status: Confirmed → Invalid
cement_head (andor-udel) wrote :

@nacc Just to be explicitly clear, this updated package (2:2.99.917+git20160522-1ubuntu1~16.04ppa1) should be applied to Xenial and it will fix the Xv flickering issue?

Nish Aravamudan (nacc) wrote :

@andor-udel,

Yep, but with the caveat that it's a PPA version, etc. If you could test it, that'd be great! But it obviously is not an official solution (more testing will encourage me or someone else to get it fixed officially :)

cement_head (andor-udel) wrote :

@nacc

Patch messed up my machine - all the Fn buttons stopped working and got non-responsive

On 07.07.2016 [02:43:49 -0000], cement_head wrote:
> @nacc
>
> Patch messed up my machine - all the Fn buttons stopped working and got
> non-responsive

Hrm, that seems sort of surprising as my package would have done that.
It's purely a drop-in replacement for the intel X video driver. You
rebooted after installation (or restarted X)?

Non-responsive in what sense? Your system hung/crashed?

Can you confirm that ppa-purge'ing my PPA results in your system
working? You're sure it wasn't something else that happened to install
simultaneously?

cement_head (andor-udel) wrote :

Non-responsive to Fn+<key> and to other keyboard input.

Purging permits it to behave as per expected.

Nish Aravamudan (nacc) wrote :

On 07.07.2016 [17:31:15 -0000], cement_head wrote:
> Non-responsive to Fn+<key> and to other keyboard input.

How very strange. I guess there must be a side-effect in the xorg intel
driver that tries to handle those keys, but seems odd that'd be the
case. Or it could be very specific to the hardware. My fn keys and other
input work. What machine are you seeing this on?

> Purging permits it to behave as per expected.

I'm glad I didn't permanently break your system! I assume your tests are
occurring each time after restarting X/your system?

Note that this was just a build of the version of in Yakkety already
at the time. It looks like a new Yakkety upload has occurred and I'm
pushing a rebuild to my PPA (2.99.917+git20160706-1ubuntu1~16.04ppa1),
can you test that one too once it has finisehd buiding?

cement_head (andor-udel) wrote :

System76 Lemur6 laptop.

I'll try the new one when you get it.

cement_head (andor-udel) wrote :

Yep, Nope, just as bad.

Might be a mute point, as M$ might be releasing a much needed update: http://blogs.skype.com/2016/07/08/exciting-news-for-linux-users/

lubart (slava-ua) wrote :

I had the same problem on my HP ProBook 450 G3 with Intel® HD Graphics 520 integrated card and AMD Radeon R7 M340. I saw blue blinking not only in Skype but on VLC as well.

Looks like it is a bug in the overlay in open source intel graphics driver or in its default settings. In case of VLC, as workaround, you can switch overlays off, but there is no way to do it with Skype.

Finally I found solution here https://github.com/linuxenko/ubuntu-skylake-i915-video-fix
Technically this fix just adds an instruction file 20-intel.conf, that tells how does Skylake should work. So, just add this file and reboot.

After that my video works normally.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.