FTBFS: TypeError: coercing to Unicode: need string or buffer, list found

Bug #187863 reported by Matthias Klose on 2008-01-31
4
Affects Status Importance Assigned to Milestone
kleansweep (Ubuntu)
Undecided
Unassigned
skim (Debian)
Fix Released
Unknown
skim (Ubuntu)
High
Scott Kitterman

Bug Description

Binary package hint: skim

Install file: "src/skim" as "debian/tmp/usr/bin/skim"
Chmod("[<SCons.Node.FS.File instance at 0x55c0c06c>]", 0755)
scons: *** [debian/tmp/usr/bin/skim] Exception
Traceback (most recent call last):
  File "/usr/lib/scons/SCons/Taskmaster.py", line 194, in execute
    self.targets[0].build()
  File "/usr/lib/scons/SCons/Node/__init__.py", line 366, in build
    apply(self.get_executor(), (self,), kw)
  File "/usr/lib/scons/SCons/Executor.py", line 145, in __call__
    return self.do_execute(target, kw)
  File "/usr/lib/scons/SCons/Executor.py", line 131, in do_execute
    status = apply(act, (self.targets, self.get_sources(), env), kw)
  File "/usr/lib/scons/SCons/Action.py", line 332, in __call__
    stat = self.execute(target, source, env)
  File "/usr/lib/scons/SCons/Action.py", line 694, in execute
    result = self.execfunction(target=target, source=rsources, env=env)
  File "/usr/lib/scons/SCons/Action.py", line 861, in __call__
    return apply(self.parent.actfunc, args, kw)
TypeError: coercing to Unicode: need string or buffer, list found
make: [install-stamp] Error 2 (ignored)
rm /build/user/skim-1.4.5/debian/tmp/usr/share/autostart/skim.desktop
rm: cannot remove `/build/user/skim-1.4.5/debian/tmp/usr/share/autostart/skim.desktop': No such file or directory
make: *** [install-stamp] Error 1
dpkg-buildpackage: failure: /usr/bin/fakeroot debian/rules binary gave error exit status 2
******************************************************************************
Build finished at 20080131-0249
FAILED [dpkg-buildpackage died]

Matthias Klose (doko) on 2008-01-31
Changed in skim:
importance: Undecided → High
milestone: none → hardy-alpha-5
status: New → Confirmed
Changed in skim:
status: Unknown → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kleansweep - 0.2.9-0ubuntu1

---------------
kleansweep (0.2.9-0ubuntu1) hardy; urgency=low

  * New upstream release (LP: #130421)
  * debian/patches/kubuntu_03_fix_scons_chmod_error.patch:
    Fix FTBFS caused by Chmod call in scons (LP: #187863)
  * Depend on "menu" package and use su-to-root in desktop file, which should
    improve the startup user experience (LP: #133829)
  * Updated patches/kubuntu_01_fix_desktop_file.patch:
    - remove file extension for Icon
    - remove deprecated Encoding
    - added more translations (de, fi, fr, it, lv, pl, sv, tr), most of them
      from #ubuntu-motu
  * Add debian/watch
  * debian/control:
    - Build-Depend on docbook-xml to avoid DTD related buildd failure
    - Standards-Version 3.7.3
    - Add Homepage field
  * Depend also (optionally) on gksu
  * debian/rules clean: rm -f po/*.gmo

 -- Daniel Hahler <email address hidden> Fri, 15 Feb 2008 03:17:27 +0100

Changed in kleansweep:
status: New → Fix Released
Daniel Hahler (blueyed) wrote :

I'm attaching the patch used in kleansweep for reference here. I'm not really sure, if it is correct and it certainly should get fixed "more upstream" probably, but it may be suitable workaround for you, too.

Steve Langasek (vorlon) on 2008-02-21
Changed in skim:
milestone: hardy-alpha-5 → hardy-alpha-6
ZhengPeng Hou (zhengpeng-hou) wrote :

patched it, thanks for your clues.
http://linuxfire.com.cn/~freeflying/skim.debdiff

Daniel Hahler (blueyed) wrote :

Please fix the LP-snippet in the changelog. Should be "LP: #187863", so that it gets closed/linked automatically.
Then, please attach the debdiff here and subscribe ubuntu-main-sponsors. Thank you.

http://ppa.launchpad.net/zhengpeng-hou/ubuntu/pool/main/s/skim/skim_1.4.5-2ubuntu2.dsc
they were built fine now, and also I add a conffile into it, and will
be uploaded to debian soon. and in ubuntu/debian, they are almost
the same version, I don't know if shall we upload it directly in
ubuntu or sync it from sid.
On Sat, Feb 23, 2008 at 2:45 AM, Daniel Hahler <email address hidden> wrote:
> Please fix the LP-snippet in the changelog. Should be "LP: #187863", so that it gets closed/linked automatically.
> Then, please attach the debdiff here and subscribe ubuntu-main-sponsors. Thank you.
>
>
> --
> FTBFS: TypeError: coercing to Unicode: need string or buffer, list found
> https://bugs.launchpad.net/bugs/187863
>
>
> You received this bug notification because you are subscribed to skim in
> ubuntu.
>

ZhengPeng Hou (zhengpeng-hou) wrote :

skim_1.4.5-3 hit sid archive now.

On Sat, Feb 23, 2008 at 9:29 PM, Zhengpeng Hou <email address hidden> wrote:
> http://ppa.launchpad.net/zhengpeng-hou/ubuntu/pool/main/s/skim/skim_1.4.5-2ubuntu2.dsc
> they were built fine now, and also I add a conffile into it, and will
> be uploaded to debian soon. and in ubuntu/debian, they are almost
> the same version, I don't know if shall we upload it directly in
> ubuntu or sync it from sid.
>
>
> On Sat, Feb 23, 2008 at 2:45 AM, Daniel Hahler <email address hidden> wrote:
> > Please fix the LP-snippet in the changelog. Should be "LP: #187863", so that it gets closed/linked automatically.
> > Then, please attach the debdiff here and subscribe ubuntu-main-sponsors. Thank you.
> >
> >
> > --
> > FTBFS: TypeError: coercing to Unicode: need string or buffer, list found
> > https://bugs.launchpad.net/bugs/187863
> >
> >
> > You received this bug notification because you are subscribed to skim in
> > ubuntu.
> >
>

Changed in skim:
status: New → Fix Released
Changed in skim:
assignee: nobody → kitterman
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package skim - 1.4.5-4ubuntu1

---------------
skim (1.4.5-4ubuntu1) hardy; urgency=low

  * Fake sync - Only Ubuntu change is difference orig.tar.gz
    - Fixes FTBFS (LP: #187863)

skim (1.4.5-4) unstable; urgency=low

  [ Zhengpeng Hou ]
  * polish the conffile of im-switch, make it work
     with both qt3 and qt4.

  [ Jaldhar H. Vyas ]
  * Add homepage and vcs fields to debian/control

skim (1.4.5-3) unstable; urgency=low

  * Add 07_fix_FTBFS.dpatch. Closes: #456855
  * Add conffile for im-switch, make skim can be
    used easily.
  * Changed maintainer name to better reflect who is maintaining this package.

 -- Scott Kitterman <email address hidden> Sat, 01 Mar 2008 21:08:14 -0500

Changed in skim:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.