singular version 3-0-4-3.dfsg-3.1ubuntu1 failed to build in oneiric

Bug #832790 reported by Matthias Klose on 2011-08-24
This bug report is a duplicate of:  Bug #825542: Symbol generation/lookup broken. Edit Remove
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
singular (Debian)
New
Unknown
singular (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

singular version 3-0-4-3.dfsg-3.1ubuntu1 failed to build in oneiric
Link to failed build: https://launchpad.net/ubuntu/+archive/test-rebuild-20110816/+build/2711523

Details about the rebuild:
http://people.ubuntuwire.org/~wgrant/rebuild-ftbfs-test/test-rebuild-20110816-oneiric.html

Direct link to the build log: https://launchpad.net/ubuntu/+archive/test-rebuild-20110816/+build/2711523/+files/buildlog_ubuntu-oneiric-amd64.singular_3-0-4-3.dfsg-3.1ubuntu1_FAILEDTOBUILD.txt.gz

This log snippet might be of interest, since it triggered the matcher 'Purging chroot-autobuild'.
Excerpt 21698 lines into the build log:

iparith.cc: At global scope:
iparith.cc:8158:12: warning: 'int iiTabIndex(const sValCmdTab*, int, int)' defined but not used [-Wunused-function]
iparith.cc:4083:15: warning: 'snumber* jjBI2N(long int)' defined but not used [-Wunused-function]
mpsr_Tok.cc: In function 'void mpsr_ttGen()':
mpsr_Tok.cc:538:30: warning: deprecated conversion from string constant to 'char*' [-Wwrite-strings]
/usr/bin/ld: ../kernel/libkernel.a(mod_raw.o): undefined reference to symbol 'dlclose@@GLIBC_2.2.5'
/usr/bin/ld: note: 'dlclose@@GLIBC_2.2.5' is defined in DSO /usr/lib/x86_64-linux-gnu/libdl.so so try adding it to the linker command line
/usr/lib/x86_64-linux-gnu/libdl.so: could not read symbols: Invalid operation
collect2: ld returned 1 exit status
make[2]: *** [iparith.inc] Error 1
make[2]: Leaving directory `/build/buildd/singular-3-0-4-3.dfsg/Singular'
make[1]: *** [install-nolns] Error 1
make[1]: Leaving directory `/build/buildd/singular-3-0-4-3.dfsg'
make: *** [debian/stamp-makefile-install] Error 2
dpkg-buildpackage: error: /usr/bin/fakeroot debian/rules binary-arch gave error exit status 2
******************************************************************************
Build finished at 20110823-1009
FAILED [dpkg-buildpackage died]
Purging chroot-autobuild/build/buildd/singular-3-0-4-3.dfsg

Related branches

Matthias Klose (doko) on 2011-08-24
Changed in singular (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package singular - 3-0-4-3.dfsg-3.1ubuntu2

---------------
singular (3-0-4-3.dfsg-3.1ubuntu2) oneiric; urgency=low

  * Fix FTBFS with ld --as-needed. LP: #832790.
  * Resolve unresolved symbols in shared libraries. Closes: #558958
 -- Matthias Klose <email address hidden> Tue, 13 Sep 2011 18:42:25 +0200

Changed in singular (Ubuntu Oneiric):
status: Confirmed → Fix Released
Changed in singular (Debian):
status: Unknown → New
linuxar (linuxar) wrote :

I will mark this as a duplicate of #825542 (and, more exactly, of #876264), since it is the same basic cause: the "--no-copy-dt-needed-entries" is now automatically passed to the linker and, as such, implicit linking fails.

While not exactlya duplicate, it is strongly related. I have no fix for the time being.

If you feel that "Duplicate" is too much, please unmark it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.