simutrans doesn't work with pulseaudio

Bug #276671 reported by Robin Sheat on 2008-10-01
2
Affects Status Importance Assigned to Milestone
simutrans (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: simutrans

In Intrepid, simutrans fails to start:

robin@lappi:~$ simutrans
Reading low level config data ...
Initializing tombstones ...
Reading simuconf.tab successful!
Preparing display ...
Screen Flags: requested=10, actual=10
Loading font 'font/prop.fnt'
font/prop.fnt sucessfully loaded as old format prop font!
Init done.
Initializing tombstones ...
Reading simuconf.tab successful!
Reading compatibility sound data ...
ALSA lib pcm_pulse.c:629:(pulse_prepare) PulseAudio: Unable to create stream: Invalid argument

E: stream.c: Assertion 's' failed at pulse/stream.c:971, function pa_stream_drain(). Aborting.
Aborted (core dumped)

robin@lappi:~$ apt-cache policy simutrans
simutrans:
  Installed: 100.0+ds1-2
  Candidate: 100.0+ds1-2
  Version table:
 *** 100.0+ds1-2 0
        500 http://de.archive.ubuntu.com intrepid/universe Packages
        100 /var/lib/dpkg/status

Omegamormegil (omegamormegil) wrote :

Thanks for the bug report. This bug appears to be a duplicate of https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/274577, so I'm marking it as such. You can try typing "sudo killall pulseaudio" in a terminal, and then try starting simultrans - it just might work.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers