UMAX Astra 1220U scanner support stopped working

Bug #953221 reported by Mathieu L BOUCHARD on 2012-03-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
simple-scan (Ubuntu)
Undecided
Unassigned

Bug Description

trying to scan a page using SimpleScan and an old UMAX Astra 1220U scanner fails. There is a row size problem that causes SimpleScan to think that there are 3 more pixels per row than there really are, causing an intense shear (what are supposed to be vertical lines now have a slope of 1/3). There is also a colour offset problem.

I am currently reporting about 11.10 (noncustomised). It used to work some years ago in Ubuntu (2008 approx) using SANE from inside GIMP. To get my sheet scanned today, I had someone do it for me from MacOS 9 (!!!) because I don't have Ubuntu 2008 anymore.

I think that there was also another version of Ubuntu in the meantime that made it fail in a totally different manner, but I don't have details and never reported it. This is just to say to be careful when going through previous versions of the code...

Fabio Marconi (fabiomarconi) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in simple-scan.

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://help.ubuntu.com/community/ReportingBugs.

affects: ubuntu → simple-scan (Ubuntu)
Michael Nagel (nailor) wrote :

Please try to scan using xsane / gimp for scanning. If that fails as well, the issue is not within simple-scan.

Thanks in advance.

Changed in simple-scan (Ubuntu):
status: New → Incomplete
Louis (louisgag) wrote :

I also have this issue. It seems that xsane and simple-scan are not able to make my UMAX 1220U move it's light/scanner... The scanner is recognized, but scanning is a no go.

Thanks,

Changed in simple-scan (Ubuntu):
status: Incomplete → Confirmed
Michael Nagel (nailor) wrote :

==============================================================
Hi there,

thank you for filing this bug and showing your interest in Simple Scan!

This seems to be a Hardware Issue, i.e. Simple Scan does not support your scanner perfectly -- or possibly not at all.

Unfortunately such problems happen more often then they should, and while it might indeed be a problem with Simple Scan, in our experience, most of the time it is not.
This is why we prepared a check-list at [1] that will let you find out whether or not it really is a problem with Simple Scan and what your options are in either case.

Please read that list and tell us how you decided to proceed. I will set this bug to "Incomplete", so a friendly robot will expire this bug in 60 days if you do not respond. However, we would really prefer to hear back from you!

Best Regards
Michael

[1] https://help.ubuntu.com/community/SimpleScanHardwareIssues
==============================================================

Changed in simple-scan (Ubuntu):
status: Confirmed → Incomplete
Harm Bathoorn (triantares) wrote :

I can affirm the same problem with a umax 1220U. Using xsane it works fine, be it that in xsane colour management needs to be turned off in "preferences". If not the scanner will scan but throws an error. thus: "lcms: Error #12288; File not found". Multiple times.
The xsane result is fine in both cases though.

Michael Nagel (nailor) wrote :

this does not seem to be isolated to simple scan/ubuntu.
please check how the following discussion evolves.
http://lists.alioth.debian.org/pipermail/sane-devel/2012-July/030088.html
i encourage you to participate in the upstream discussion.
more results will be achieved there than in this ticket.

best regards

Mathieu L BOUCHARD (matju) wrote :

The problem that I have is not that the scanner is not detected. I might have had that problem long ago but I didn't report it and don't remember it. The problem I reported in the description of this bug is really that the pixels scanned are improperly aligned (sometimes called a Shear transformation). This is the kind of problem that happens when the number of columns of the image is not counted correctly, such that the driver and the device disagree on that number but are oblivious about it. The slope of 1/3 I get means that the driver's image is missing 3 columns compared to what the scanner provides.

Yesterday, I plugged that scanner again for the first time since March (which is why I only reply now) and then I realised that the problem happens in 300 dpi, and something worse (lower slope) happens with 600 dpi, but 150 dpi is fine.

The shear is also accompanied by a color offset problem but I didn't measure it and I suppose that it might be another consequence of the same bug.

Mathieu L BOUCHARD (matju) wrote :

I tried it again with something that contained colour (yesterday's test was nearly a black-and-white sheet) and now I see that the large diagonal stripes also have wrong colours. The first triangle at the top has correct colors, but as the sheared pixels wrap around, they seem to have suffered large hue shifts, which is probably the result of making each pixel out of two different neighbouring pixels while confusing R,G,B channels.

I also just tried the «scanimage» command (from sane-utils) for the first time and it has the same problem.

Michael Nagel (nailor) wrote :

if the problem arises with scanimage as well, the problem is within the sane libraries/drivers.
please take this to the sane-devel mailing list: http://lists.alioth.debian.org/mailman/listinfo/sane-devel
that is probably the only place where this can be solved...

Launchpad Janitor (janitor) wrote :

[Expired for simple-scan (Ubuntu) because there has been no activity for 60 days.]

Changed in simple-scan (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers