The filters have no names when saving a file

Bug #876135 reported by kroq-gar78 on 2011-10-17
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Simple Scan
Fix Released
Low
Unassigned
simple-scan (Debian)
Fix Released
Unknown
simple-scan (Ubuntu)
Low
Unassigned
Precise
Undecided
Unassigned

Bug Description

Ubuntu Oneiric 11.10

simple-scan 3.2.0-0ubuntu1

When trying to save a file with the dialog in Simple Scan, the filters at the bottom-left say "Untitled filter" - both of them. I believe it's supposed to be "images" and "all files", but this is not the case. It's not a huge problem, but can be very confusing to a beginner or novice.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: simple-scan 3.2.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.4-kroqernel+ x86_64
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
CheckboxSubmission: 7f98738f6663bda1ae1c2900a3a1db71
CheckboxSystem: 577751a334467e78ed04da699e5debc9
Date: Sun Oct 16 20:46:23 2011
DriverPackageVersions:
 libsane 1.0.22-2ubuntu2
 libsane-extras N/A
 hplip 3.11.7-1ubuntu3
 hpoj N/A
ExecutablePath: /usr/bin/simple-scan
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
MachineType: TOSHIBA Satellite L655
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.4-kroqernel+ root=UUID=4137c0a1-11d6-4c89-853b-be780656257d ro crashkernel=384M-2G:64M,2G-:128M splash pcie_aspm=force resume2=swap:/dev/sda6 vt.handoff=7
SourcePackage: simple-scan
UpgradeStatus: Upgraded to oneiric on 2011-10-15 (1 days ago)
dmi.bios.date: 03/23/2011
dmi.bios.vendor: INSYDE
dmi.bios.version: 2.30
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Base Board Product Name
dmi.board.vendor: Intel Corp.
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: OEM Chassis Manufacturer
dmi.chassis.version: OEM Chassis Version
dmi.modalias: dmi:bvnINSYDE:bvr2.30:bd03/23/2011:svnTOSHIBA:pnSatelliteL655:pvrPSK2CU-0R901U:rvnIntelCorp.:rnBaseBoardProductName:rvrBaseBoardVersion:cvnOEMChassisManufacturer:ct10:cvrOEMChassisVersion:
dmi.product.name: Satellite L655
dmi.product.version: PSK2CU-0R901U
dmi.sys.vendor: TOSHIBA

kroq-gar78 (kroq-gar78) wrote :
Mark Alan (malan) wrote :

Same problem here

Ubuntu Oneiric 11.10

simple-scan 3.2.0-0ubuntu1

kroq-gar78 (kroq-gar78) wrote :

Mark:

I suggest you mark yourself as affected at the top where it says "This affects 1 person", or something along those lines. Then, it will automatically be confirmed and might be at a higher priority for the developers.

Michael Nagel (nailor) wrote :

this will not be fixed in the packaging of the application

Changed in simple-scan (Ubuntu):
status: New → Invalid
Michael Nagel (nailor) wrote :

Could you attach a small screenshot?

Changed in simple-scan:
status: New → Incomplete
importance: Undecided → Low
-beer30- (beer30) wrote :

I am having the same problem saving to pdf. This started after having problems with using the automatic document feeder on my new HP OfficeJet 6500 e710n. I installed the newest hplip which I downloaded from hplipopensource.com (3.11.10) via script. The adf is working now, but there is no longer correct filters / file types in the Save As... dialog box.

Attached is a screen shot. I cannot screenshot the list itself, but there are two selectable 'Untitled Filters'. Selecting either one and saving results in a 130byte empty pdf.

jay@U-Box:~/Desktop$ file Scanned\ Document.pdf
Scanned Document.pdf: PDF document, version 1.3

jay@U-Box:~/Desktop$ ls -al Scanned\ Document.pdf
-rw-r----- 1 jay jay 130 2011-12-03 10:18 Scanned Document.pdf

jay@U-Box:~/Desktop$ more Scanned\ Document.pdf
%PDF-1.3
%���
1 0 obj
<<
/Type /Catalog
/Pages 2 0 R
>>
endobj

2 0 obj
<<
/Type /Pages
/Kids [ 3 0 R 6 0 R ]
/Count 2
>>
endobj

Michael Nagel (nailor) wrote :

Thanks for the screenshot!

I can imagine a relationship between the unnamed filter and the broken PDF, even so I am not really sure it is really connected.
I cannot believe the missing filter is related to the hplip version, however. The driver should not be involved in the file export at all. Does saving in other formats still work? Could you did into that a little bit deeper?

Changed in simple-scan:
status: Incomplete → Opinion
status: Opinion → Confirmed
-beer30- (beer30) wrote :

Scans are saving in .jpg, .tif, .tiff and .png when choosing to scan as a photo. Scan will save as .tif (was not sure which other formats to try to save as) when scanned as text.

Running Oneiric 64 bit on an i7 machine I put together. Can provide logs and can dig deeper, just not sure which logs apply.

Michael Nagel (nailor) wrote :

beer30, could you please open another bug report about your problem. i am still not convinced it is related and want to keep the noise to a minimum. should it be related we can merge the reports later. thanks!

-beer30- (beer30) wrote :

Here is some debug output scanning 2 pages through the doc feeder.

-beer30- (beer30) wrote :

I can do that. Thanks, Michael.

Nicholas Skaggs (nskaggs) wrote :

This is also affecting me running the latest precise -- i purged the config files and reinstalled simple-scan, but encountered the same issue

Michael Nagel (nailor) wrote :

Nicholas, please be more verbose.
Is it reproducible ALWAYS or just sometimes, and if the latter, under what circumstances.

Also, does saving still work and this seems more like a display issue, or is it completly broken? Are you getting broken PDFs?

Thibault D (thibdrev) wrote :

Hi, same issue for me on a french Ubuntu 12.04 (beta2 with latest updates)

After scanning with my "HP Photosmart C4472", I also get this "Untitled filter" menu when trying to save the file.

Michael Nagel (nailor) wrote :

@Thibault:
Is it reproducible ALWAYS or just sometimes, and if the latter, under what circumstances.

Also, does saving still work and this seems more like a display issue, or is it completly broken? Are you getting broken PDFs?

For me, last time I checked, it was reproducible always. And no, I don't get broken PDF's. That's for me, not sure about Thibault. Ubuntu 12.04 up to date

Sincerely,
kroq-gar78

Michael Nagel (nailor) wrote :

is it reproducible with lon-localized simple-scan started via:
LC_ALL=C LANG=C LANGUAGE=C simple-scan

kroq-gar78 (kroq-gar78) wrote :

Yes. Same thing with your command.

Sincerely,
Kroq-gar78

On Mon, Apr 30, 2012 at 4:40 AM, Michael Nagel <email address hidden>wrote:

> is it reproducible with lon-localized simple-scan started via:
> LC_ALL=C LANG=C LANGUAGE=C simple-scan
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/876135
>
> Title:
> The filters have no names when saving a file
>
> Status in Simple Scan:
> Confirmed
> Status in “simple-scan” package in Ubuntu:
> Invalid
>
> Bug description:
> Ubuntu Oneiric 11.10
>
> simple-scan 3.2.0-0ubuntu1
>
> When trying to save a file with the dialog in Simple Scan, the filters
> at the bottom-left say "Untitled filter" - both of them. I believe
> it's supposed to be "images" and "all files", but this is not the
> case. It's not a huge problem, but can be very confusing to a beginner
> or novice.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.10
> Package: simple-scan 3.2.0-0ubuntu1
> ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
> Uname: Linux 3.0.4-kroqernel+ x86_64
> ApportVersion: 1.23-0ubuntu3
> Architecture: amd64
> CheckboxSubmission: 7f98738f6663bda1ae1c2900a3a1db71
> CheckboxSystem: 577751a334467e78ed04da699e5debc9
> Date: Sun Oct 16 20:46:23 2011
> DriverPackageVersions:
> libsane 1.0.22-2ubuntu2
> libsane-extras N/A
> hplip 3.11.7-1ubuntu3
> hpoj N/A
> ExecutablePath: /usr/bin/simple-scan
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64
> (20110427.1)
> MachineType: TOSHIBA Satellite L655
> ProcEnviron:
> PATH=(custom, user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.4-kroqernel+
> root=UUID=4137c0a1-11d6-4c89-853b-be780656257d ro
> crashkernel=384M-2G:64M,2G-:128M splash pcie_aspm=force
> resume2=swap:/dev/sda6 vt.handoff=7
> SourcePackage: simple-scan
> UpgradeStatus: Upgraded to oneiric on 2011-10-15 (1 days ago)
> dmi.bios.date: 03/23/2011
> dmi.bios.vendor: INSYDE
> dmi.bios.version: 2.30
> dmi.board.asset.tag: Base Board Asset Tag
> dmi.board.name: Base Board Product Name
> dmi.board.vendor: Intel Corp.
> dmi.board.version: Base Board Version
> dmi.chassis.asset.tag: No Asset Tag
> dmi.chassis.type: 10
> dmi.chassis.vendor: OEM Chassis Manufacturer
> dmi.chassis.version: OEM Chassis Version
> dmi.modalias:
> dmi:bvnINSYDE:bvr2.30:bd03/23/2011:svnTOSHIBA:pnSatelliteL655:pvrPSK2CU-0R901U:rvnIntelCorp.:rnBaseBoardProductName:rvrBaseBoardVersion:cvnOEMChassisManufacturer:ct10:cvrOEMChassisVersion:
> dmi.product.name: Satellite L655
> dmi.product.version: PSK2CU-0R901U
> dmi.sys.vendor: TOSHIBA
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/simple-scan/+bug/876135/+subscriptions
>

Robert Ancell (robert-ancell) wrote :

The upstream bindings changed again (this has happened before). The issue was there is a Gtk.FileFilter.set_name method for that collides with the Gtk.Widget.set_name method. The bindings have now renamed the method to Gtk.FileFilter.set_filter_name.

Changed in simple-scan (Ubuntu):
importance: Undecided → Low
status: Invalid → Triaged
Changed in simple-scan:
status: Confirmed → Fix Committed
Changed in simple-scan (Ubuntu):
status: Triaged → Fix Committed
Robert Ancell (robert-ancell) wrote :

Re-opened Ubuntu task as it does effect the version that is in Ubuntu.

Hello kroq-gar78, or anyone else affected,

Accepted simple-scan into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in simple-scan (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Download full text (3.2 KiB)

Thanks! It works for me now :)

Sincerely,
Kroq-gar78

On Wed, May 2, 2012 at 3:57 AM, Martin Pitt <email address hidden> wrote:

> Hello kroq-gar78, or anyone else affected,
>
> Accepted simple-scan into precise-proposed. The package will build now
> and be available in a few hours. Please test and give feedback here. See
> https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to
> enable and use -proposed. Thank you in advance!
>
> ** Also affects: simple-scan (Ubuntu Precise)
> Importance: Undecided
> Status: New
>
> ** Changed in: simple-scan (Ubuntu Precise)
> Status: New => Fix Committed
>
> ** Tags added: verification-needed
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/876135
>
> Title:
> The filters have no names when saving a file
>
> Status in Simple Scan:
> Fix Committed
> Status in “simple-scan” package in Ubuntu:
> Fix Committed
> Status in “simple-scan” source package in Precise:
> Fix Committed
>
> Bug description:
> Ubuntu Oneiric 11.10
>
> simple-scan 3.2.0-0ubuntu1
>
> When trying to save a file with the dialog in Simple Scan, the filters
> at the bottom-left say "Untitled filter" - both of them. I believe
> it's supposed to be "images" and "all files", but this is not the
> case. It's not a huge problem, but can be very confusing to a beginner
> or novice.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.10
> Package: simple-scan 3.2.0-0ubuntu1
> ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
> Uname: Linux 3.0.4-kroqernel+ x86_64
> ApportVersion: 1.23-0ubuntu3
> Architecture: amd64
> CheckboxSubmission: 7f98738f6663bda1ae1c2900a3a1db71
> CheckboxSystem: 577751a334467e78ed04da699e5debc9
> Date: Sun Oct 16 20:46:23 2011
> DriverPackageVersions:
> libsane 1.0.22-2ubuntu2
> libsane-extras N/A
> hplip 3.11.7-1ubuntu3
> hpoj N/A
> ExecutablePath: /usr/bin/simple-scan
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64
> (20110427.1)
> MachineType: TOSHIBA Satellite L655
> ProcEnviron:
> PATH=(custom, user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.4-kroqernel+
> root=UUID=4137c0a1-11d6-4c89-853b-be780656257d ro
> crashkernel=384M-2G:64M,2G-:128M splash pcie_aspm=force
> resume2=swap:/dev/sda6 vt.handoff=7
> SourcePackage: simple-scan
> UpgradeStatus: Upgraded to oneiric on 2011-10-15 (1 days ago)
> dmi.bios.date: 03/23/2011
> dmi.bios.vendor: INSYDE
> dmi.bios.version: 2.30
> dmi.board.asset.tag: Base Board Asset Tag
> dmi.board.name: Base Board Product Name
> dmi.board.vendor: Intel Corp.
> dmi.board.version: Base Board Version
> dmi.chassis.asset.tag: No Asset Tag
> dmi.chassis.type: 10
> dmi.chassis.vendor: OEM Chassis Manufacturer
> dmi.chassis.version: OEM Chassis Version
> dmi.modalias:
> dmi:bvnINSYDE:bvr2.30:bd03/23/2011:svnTOSHIBA:pnSatelliteL655:pvrPSK2CU-0R901U:rvnIntelCorp.:rnBaseBoardProductName:rvrBaseBoardVersion:cvnOEMChassisManufacturer:ct10:cvrOEMChassisVersion:
> dmi.product.name: Satellite L655
> dmi.product.version: PSK2CU-0R901U
> dmi.sys.vendor: TOSHIBA
>
> To manage notif...

Read more...

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package simple-scan - 3.4.1-0ubuntu1.1

---------------
simple-scan (3.4.1-0ubuntu1.1) precise-proposed; urgency=low

  * debian/patches/02-file-filter-labels.patch:
    - Fix save dialog filter incorrect labels (LP: #876135)
 -- Robert Ancell <email address hidden> Wed, 02 May 2012 13:51:04 +1200

Changed in simple-scan (Ubuntu):
status: Fix Committed → Fix Released
Changed in simple-scan (Ubuntu Precise):
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) wrote :

Robert, don't you think this patch should be released to simple-scan 3.4 users of other distros too?

Robert Ancell (robert-ancell) wrote :

Fixed in 3.4.2 and 3.5.1

Changed in simple-scan:
status: Fix Committed → Fix Released
Changed in simple-scan (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.