Simple scan in Ubuntu 10.10 does not scan in black and white at all.

Bug #659536 reported by Jürgen Römer on 2010-10-12
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Simple Scan
Fix Released
Low
Unassigned
simple-scan (Ubuntu)
Low
Unassigned
Maverick
Undecided
Unassigned

Bug Description

Impact: Text scans performed using proprietary brother3 driver result in a color scan
Resolution: Upstream code change (patch in comments below)
To reproduce:
1. Open simple-scan
2. Connect suitable scanner that uses this driver
3. Select Text from drop down menu beside scan button
4. Click scan
Expected result: A black and white image is shown, that scan is fast
Observed result: A color scan is shown

Simple scan changed from doing lineart scans in text mode to grayscale. brother3 driver does not use standard names for grayscale mode (as observed in attached log). brother3 mode added to list of modes that simple-scan tries.

Robert Ancell (robert-ancell) wrote :

Thanks for the bug report.

Simple Scan didn't know how to set the scan in grayscale mode, could you please run the following commands and attach the results:
$ scanimage -mode "Gray[Error Diffusion]" > page1.pnm
$ scanimage -mode "True Gray" > page2.pnm

Changed in simple-scan (Ubuntu):
importance: Undecided → Low
status: New → Triaged
  • page1.pnm Edit (460.9 KiB, image/x-portable-anymap; name="page1.pnm")
  • page2.pnm Edit (3.6 MiB, image/x-portable-anymap; name="page2.pnm")

  13.10.2010 09:56, Robert Ancell kirjoitti:
> scanimage -mode "True Gray"> page2.pnm
Thanks for the quick answer.

Both of the commands gave approximately the same result, a grayscale
image of a colour original.

  I will attach the scanned files.

The way that Simple scan worked in Ubuntu 10.04 was excellent for me. I
scan mostly text into pdf-files and the black and white text option in
Simple scan was fast. Simple scan is a very good tool in its simplicity.

Best regards
Jürgen Römer

Robert Ancell (robert-ancell) wrote :

Fixed upstream, thanks for your bug report.

Changed in simple-scan (Ubuntu):
status: Triaged → Fix Committed
Changed in simple-scan:
status: New → Fix Released
importance: Undecided → Low
Robert Ancell (robert-ancell) wrote :

Patch that adds brother3 compatible mode

tags: added: regression-release
description: updated

Accepted simple-scan into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in simple-scan (Ubuntu Maverick):
status: New → Fix Committed
tags: added: verification-needed

22.10.2010 10:55, Martin Pitt kirjoitti:
> Accepted simple-scan into maverick-proposed, the package will build now
> and be available in a few hours. Please test and give feedback here. See
> https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to
> enable and use -proposed. Thank you in advance!
>
> ** Changed in: simple-scan (Ubuntu Maverick)
> Status: New => Fix Committed
>
> ** Tags added: verification-needed
>
Have tested the new version. It scanned black and white with
"Text"-option as it should. Scanning was also as fast as in Ubuntu
10.04. The bug seems to have been fixed. Thanks a lot!

Jürgen Römer

tags: added: verification-done
removed: verification-needed
domja (dominique-jany) wrote :

For me since i've done the update (with proposed), it is fixed.

Thanks !

For french speaking users , i've posted an explain here (http://forum.ubuntu-fr.org/viewtopic.php?pid=3826375#p3826375), in the french ubuntu's forum

Pour les utilisateurs francophones, j'ai fait un post sur le forum ubuntu (voir le lien ci-dessous)

Aurevoir

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package simple-scan - 2.32.0-0ubuntu4

---------------
simple-scan (2.32.0-0ubuntu4) maverick-proposed; urgency=low

  * debian/patches/04-crop-area.patch:
    - Fix crop area being incorrectly applied (LP: #664317)
  * debian/patches/05-brother3-grayscale.patch:
    - Fix text mode scanning not working using brother propietary driver (LP: #659536)
 -- Robert Ancell <email address hidden> Fri, 22 Oct 2010 15:00:30 +1100

Changed in simple-scan (Ubuntu Maverick):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

copied to natty, too.

Changed in simple-scan (Ubuntu):
status: Fix Committed → Fix Released
David Gettis (forliberty) wrote :

This bug is still there for the brscan driver; apparently the fix only applies to the brscan3 driver. I have a Brother MFC-9700, which uses the brscan driver. In Ubuntu 10.04, Simple Scan worked as expected; a text scan was fast and black and white. Now that I've upgraded to Ubuntu 13.04, text scans are slow and grey-scale.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers