simple-scan crashed with SIGSEGV in g_closure_invoke()

Bug #618706 reported by Till Kamppeter on 2010-08-16
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
simple-scan (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: simple-scan

simple-scan crashed with a segmentation fault when I tried the new, grayscale-based text scan mode. I cropped the page to a size of around 7x10 cm and tried to save as PDF, When clicking OK in the "Save as ..." dialog, simple-scan crashed.

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: simple-scan 2.31.90.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-14.19-generic 2.6.35
Uname: Linux 2.6.35-14-generic x86_64
Architecture: amd64
Date: Mon Aug 16 16:38:27 2010
DriverPackageVersions:
 libsane 1.0.21-2ubuntu2
 libsane-extras N/A
 hplip 3.10.6-1ubuntu5
 hpoj N/A
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/simple-scan
MachineType: LENOVO 7417CTO
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.35-14-generic root=/dev/mapper/hostname-root ro quiet splash
ProcCmdline: simple-scan
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
SegvAnalysis:
 Segfault happened at: 0x40a880: movzbl (%rdx,%rax,1),%r8d
 PC (0x0040a880) ok
 source "(%rdx,%rax,1)" (0x0230b000) not located in a known VMA region (needed readable region)!
 destination "%r8d" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: simple-scan
StacktraceTop:
 ?? ()
 ?? ()
 g_closure_invoke ()
 ?? () from /usr/lib/libgobject-2.0.so.0
 g_signal_emit_valist ()
Title: simple-scan crashed with SIGSEGV in g_closure_invoke()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors: (polkit-gnome-authentication-agent-1:2221): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
dmi.bios.date: 10/13/2009
dmi.bios.vendor: LENOVO
dmi.bios.version: 7UET79WW (3.09 )
dmi.board.name: 7417CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr7UET79WW(3.09):bd10/13/2009:svnLENOVO:pn7417CTO:pvrThinkPadT400:rvnLENOVO:rn7417CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 7417CTO
dmi.product.version: ThinkPad T400
dmi.sys.vendor: LENOVO

Till Kamppeter (till-kamppeter) wrote :
visibility: private → public
Till Kamppeter (till-kamppeter) wrote :

The first around 120 bytes got saved before simple-scan crashed.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package simple-scan - 2.31.90.2-0ubuntu1

---------------
simple-scan (2.31.90.2-0ubuntu1) maverick; urgency=low

  * New upstream release:
    - Fixes (LP: #618706)
 -- Robert Ancell <email address hidden> Tue, 17 Aug 2010 10:28:34 +1000

Changed in simple-scan (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers