Resolution not set in PDF files

Bug #564106 reported by ross sumera on 2010-04-15
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Simple Scan
Fix Released
Medium
Unassigned
Baltix
Undecided
Unassigned
simple-scan (Ubuntu)
Medium
Robert Ancell
Lucid
Medium
Robert Ancell

Bug Description

Binary package hint: simple-scan

Description: Ubuntu lucid (development branch)
Release: 10.04

simple-scan_1.0.0-0ubuntu1_amd64.deb

If I Print or Preview it on the simple scan the preview or printout is okay.

But if I saved it to disk and open it via Evince then print or preview it, it is magnified maybe 150-200X or greater.

Printer scanner is Brother DCP-135C.
Evince version 2.30.0-0ubuntu1

There is no problem with Xsane and my setup is previously working fine with Karmic.

ross sumera (rsumera) wrote :

It seem the problem is now fixed after upgrading from

simple-scan (1.0.0-0ubuntu1) to 1.0.2-0ubuntu1

only checked the pdf A4 setting

Friday, April 16 2010

Changed in simple-scan (Ubuntu):
status: New → Fix Released

no, i can still reproduce this problem even with 1.0.2-0ubuntu1

i'll attach a PDF showing the problem.

Changed in simple-scan (Ubuntu):
status: Fix Released → New

one way to work around the problem is to change evince settings to scale the page.

maybe the reporter changed this evince setting and assumed the problem was fixed when it was only a changed evince setting.

the workaround is in evince, print->page handling->page scaling=shrink to printable area.

i think it's not an evince bug, i think the same problem occurs also with Acrobat Reader but I don't have it handy now, I'll check this file that I attached tomorrow at work.

ross sumera (rsumera) wrote :

The scale setting in Evince is not an issue here.

I think this bug that I reported is similar to Bug #559543

To illustrate, I have 1 page scanned using version 1.0.0-0ubuntu1

     file size = 839.4 KB (859527 bytes)

same page scanned with version 1.0.2-0ubuntu1

     file size = 67.3 KB (68912 bytes)

Changed in simple-scan (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Robert Ancell (robert-ancell) wrote :

Bug was the image resolution was not being set for PDFs generate with ImageMagick.

Changed in simple-scan:
status: New → Fix Released
importance: Undecided → Medium
summary: - Simple Scan - saved A4 pdf file when printed via Evince its magnified
+ Resolution not set PDF files
summary: - Resolution not set PDF files
+ Resolution not set in PDF files

so you're saying the bug is already fixed? can you tell me with which version of simple-scan or imagemagick, that i test it? because with the latest versions as of 12 hours ago when I uploaded this sample PDF, i could still reproduce the problem.

i see on http://bobthegnome.blogspot.com/2010/03/simple-scan-10.html that it was fixed in simple-scan 1.0.3.
i'll test quickly when I get this package. i don't see it yet in the lucid-changes mailing list:
https://lists.ubuntu.com/archives/lucid-changes/2010-April/thread.html

thanks for the quick fix!

Robert Ancell (robert-ancell) wrote :

It's too late to make it for Lucid final so it will have to be a stable release update done after release...

Accepted simple-scan into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in simple-scan (Ubuntu Lucid):
status: Triaged → Fix Committed
tags: added: verification-needed
Changed in simple-scan (Ubuntu Lucid):
assignee: nobody → Robert Ancell (robert-ancell)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package simple-scan - 1.0.3-0ubuntu1

---------------
simple-scan (1.0.3-0ubuntu1) lucid-proposed; urgency=low

  * New upstream release:
    - Set resolution on ImageMagick generated PDFs (LP: #564106)
 -- Robert Ancell <email address hidden> Tue, 20 Apr 2010 10:12:51 +1000

Changed in simple-scan (Ubuntu Lucid):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied lucid-proposed to maverick.

Changed in simple-scan (Ubuntu):
status: Fix Committed → Fix Released
Changed in simple-scan (Ubuntu Lucid):
status: Fix Released → Fix Committed
Fabio Marconi (fabiomarconi) wrote :

Not fixed, for me.
I scan and save in pdf format and the preview in Evince is magnified, if i save in jpg format the image showed in image viewer is reduced at 14%, but if i enlarge to 100% is much greater then the pdf image opened in Evince.
Printing autoadapt at page size.

Fabio Marconi (fabiomarconi) wrote :

Opened new bug 575695 evince 2.30.1 don't apear in applications menu, but is present in 'open with other application' window.

Sebastien Bacher (seb128) wrote :

the new comment seems to be a different issue than the one the change should adress no?

Andrew Cowie (andrew-cowie) wrote :

This was a problem with me for the current lucid build - scanned A4 documents did not print correctly on A4 paper. I have installed simple-scan v1.0.3 from the i386 build of 1.0.3-0ubuntu1 and this works fine. Thanks!

Martin Pitt (pitti) on 2010-06-01
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package simple-scan - 1.0.3-0ubuntu1

---------------
simple-scan (1.0.3-0ubuntu1) lucid-proposed; urgency=low

  * New upstream release:
    - Set resolution on ImageMagick generated PDFs (LP: #564106)
 -- Robert Ancell <email address hidden> Tue, 20 Apr 2010 10:12:51 +1000

Changed in simple-scan (Ubuntu Lucid):
status: Fix Committed → Fix Released
David Rahrer (david-rahrer) wrote :

I have exactly this same bug in the current version 2.31.4 for Lucid from this pp. Did it come back? Backing down to 1.03 until it's fixed.

Michael Nagel (nailor) wrote :

lets discuss the problems in current versions 2.3*.* in Bug #570782

Michael Nagel (nailor) on 2012-02-12
Changed in baltix:
status: New → Opinion
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers