Update to 3.4.3

Bug #1158558 reported by Robert Ancell on 2013-03-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
simple-scan (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned

Bug Description

Some important bug fixes have been backported from 3.6 to 3.4.

Overview of changes in simple-scan 3.4.3

  * Fix scan no longer working after an ADF scan completes
  * Fix erroneous warning about failing to set ADF source
  * Fix crash caused by signal being emitted in scan thread
  * Fix crash when starting a new document during a scan

Overview of changes in simple-scan 3.4.2

  * Fix save dialog filter labels

This is a good candidate for an SRU to precise to fix the ADF failure and crashes that cause scanned documents to be lost.

Related branches

Robert Ancell (robert-ancell) wrote :

Note the filter label patch is already applied in precise, and the ADF issue is tracked in bug 1097096. Packaging is in lp:~robert-ancell/simple-scan/update-3.4.3.

Changed in simple-scan (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
Changed in simple-scan (Ubuntu Precise):
status: New → In Progress
importance: Undecided → Medium
Changed in simple-scan (Ubuntu):
status: In Progress → Fix Released
Robert Ancell (robert-ancell) wrote :

"Fix crash caused by signal being emitted in scan thread" is bug 1022040
"Fix crash when starting a new document during a scan" is bug 843361

Hello Robert, or anyone else affected,

Accepted simple-scan into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/simple-scan/3.4.3-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in simple-scan (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Miklos Juhasz (mjuhasz) wrote :

After a whole day of scanning I can confirm that simple-scan does not crash anymore (see relevant bugs in comment #2). According to comment #1 the filter label patch is already applied in precise, and the ADF issue is tracked in bug 1097096 and marked as verification-done so I am marking this bug as verification-done. No regression spotted either.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package simple-scan - 3.4.3-0ubuntu1

---------------
simple-scan (3.4.3-0ubuntu1) precise-proposed; urgency=low

  * New upstream bugfix release (LP: #1158558):
    [ 3.4.2 ]
    - Fix save dialog filter labels
    [ 3.4.3 ]
    - Fix scan no longer working after an ADF scan completes (LP: #1097096)
    - Fix erroneous warning about failing to set ADF source
    - Fix crash caused by signal being emitted in scan thread
    - Fix crash when starting a new document during a scan
  * debian/patches/02-file-filter-labels.patch:
    - Applied upstream
 -- Robert Ancell <email address hidden> Fri, 22 Mar 2013 09:47:49 +1300

Changed in simple-scan (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers