can't scan more after "scan all from document feeder"

Bug #1097096 reported by Michał Sawicz on 2013-01-08
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Simple Scan
Fix Released
Medium
Unassigned
simple-scan (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned

Bug Description

Steps to reproduce:
* scan a single page
* scan another page
* scan all from feeder
* scan another single page
* scan all from feeder again

Expected results:
* all pages are scanned in correctly

Current results:
* can't scan anything more after scanning from the document feeder

Attached please find a debug log (stripped from extraneous "sane_read -> GOOD" lines).

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: simple-scan 3.6.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-22.33-generic 3.5.7.2
Uname: Linux 3.5.0-22-generic x86_64
NonfreeKernelModules: wl nvidia
ApportVersion: 2.6.1-0ubuntu9
Architecture: amd64
Date: Tue Jan 8 01:51:18 2013
DriverPackageVersions:
 libsane 1.0.23-0ubuntu1
 libsane-extras N/A
 hplip 3.12.6-3ubuntu4
 hpoj N/A
MachineType: Dell Inc. Latitude E6420
MarkForUpload: True
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.5.0-22-generic root=/dev/mapper/username--laptop-ubuntu--root ro rootflags=subvol=@ splash quiet vt.handoff=7
SourcePackage: simple-scan
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/18/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A08
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA08:bd10/18/2011:svnDellInc.:pnLatitudeE6420:pvr01:rvnDellInc.:rn:rvr:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude E6420
dmi.product.version: 01
dmi.sys.vendor: Dell Inc.
---
ApportVersion: 2.9.2-0ubuntu1
Architecture: amd64
DistroRelease: Ubuntu 13.04
DriverPackageVersions:
 libsane 1.0.23-0ubuntu1
 libsane-extras N/A
 hplip 3.13.3-1
 hpoj N/A
MachineType: Dell Inc. Latitude E6420
MarkForUpload: True
NonfreeKernelModules: wl nvidia
Package: simple-scan 3.6.0-2
PackageArchitecture: amd64
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.8.0-7-generic root=/dev/mapper/username--laptop-ubuntu--root ro rootflags=subvol=@ splash quiet
ProcVersionSignature: Ubuntu 3.8.0-7.16-generic 3.8.0
Tags: raring
Uname: Linux 3.8.0-7-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip fuse lpadmin plugdev sambashare sbuild sudo vboxusers
dmi.bios.date: 10/18/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A08
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA08:bd10/18/2011:svnDellInc.:pnLatitudeE6420:pvr01:rvnDellInc.:rn:rvr:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude E6420
dmi.product.version: 01
dmi.sys.vendor: Dell Inc.
---
ApportVersion: 2.9.2-0ubuntu1
Architecture: amd64
DistroRelease: Ubuntu 13.04
DriverPackageVersions:
 libsane 1.0.23-0ubuntu1
 libsane-extras N/A
 hplip 3.13.3-1
 hpoj N/A
MachineType: Dell Inc. Latitude E6420
MarkForUpload: True
NonfreeKernelModules: wl nvidia
Package: simple-scan 3.6.0-2
PackageArchitecture: amd64
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.8.0-7-generic root=/dev/mapper/username--laptop-ubuntu--root ro rootflags=subvol=@ splash quiet
ProcVersionSignature: Ubuntu 3.8.0-7.16-generic 3.8.0
Tags: raring
Uname: Linux 3.8.0-7-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip fuse lpadmin plugdev sambashare sbuild sudo vboxusers
dmi.bios.date: 10/18/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A08
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA08:bd10/18/2011:svnDellInc.:pnLatitudeE6420:pvr01:rvnDellInc.:rn:rvr:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude E6420
dmi.product.version: 01
dmi.sys.vendor: Dell Inc.

Michał Sawicz (saviq) wrote :
Michael Nagel (nailor) wrote :

Please read https://help.ubuntu.com/community/SimpleScanHardwareIssues
even if this bug report is already a lot better than those initially targeted by that wiki page.

try xsane.

Changed in simple-scan (Ubuntu):
status: New → Incomplete
Michał Sawicz (saviq) wrote :

My scanner is:

Brother DCP-7065DN

It's networked, so no vid / pid available.

I have a good faith belief that this is a bug in Simple Scan and not in sane-backends because I actually tried with xsane and it worked there - I could scan everything in sequence, no problem.

After some "apt-get upgrade" to Ubuntu 12.04-LTS I now get this exact same problem with a Brother MFC-8660DN.

I don't know which upgrade caused the problem or when it started, but with the original Ubuntu 12.04-LTS I was able to make multiple runs.

It never had this problem before. I have to quit from simple scan and restart in order to scan more pages. The last lines of simple-scan.log are:

[+53.78s] DEBUG: scanner.vala:818: sane_get_option_descriptor (12)
[+53.78s] DEBUG: scanner.vala:480: sane_control_option (4, SANE_ACTION_SET_VALUE, "Automatic Document Feeder") -> (SANE_STATUS_GOOD, "Automatic Document Feeder")
[+53.78s] DEBUG: scanner.vala:480: sane_control_option (2, SANE_ACTION_SET_VALUE, "True Gray") -> (SANE_STATUS_GOOD, "True Gray")
[+53.78s] DEBUG: scanner.vala:422: sane_control_option (3, SANE_ACTION_SET_VALUE, 150) -> (SANE_STATUS_GOOD, 150)
[+53.78s] DEBUG: scanner.vala:462: sane_control_option (10, SANE_ACTION_SET_VALUE, 215.899994) -> (SANE_STATUS_GOOD, 215.880234)
[+53.78s] DEBUG: scanner.vala:462: sane_control_option (11, SANE_ACTION_SET_VALUE, 355.599991) -> (SANE_STATUS_GOOD, 355.567444)
[+53.78s] DEBUG: scanner.vala:1124: sane_start (page=0, pass=0) -> SANE_STATUS_NO_DOCS

As you can see the last line says SANE_STATUS_NO_DOCS so it's saying that there are no documents even though there are.

Quitting and restarting simple-scan allows you to use the scanner again, but this defeats the goal of being able to scan several times (e.g. front and back of pages) and combining them into one saved document.

Just to note: the version I'm now running is

simple-scan 3.4.1-0ubuntu1.1

Michał Sawicz (saviq) wrote :

This is still an issue in current raring.

tags: added: apport-collected raring
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in simple-scan (Ubuntu):
status: Incomplete → Confirmed
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Michał Sawicz (saviq) wrote :

Sorry for double upload, apport-collect failed at first try (but seems to have uploaded stuff anyway).

Robert Ancell (robert-ancell) wrote :

Hi Michał,

The problem appears to be that simple-scan doesn't call sane_cancel() after the last page from the ADF and this is confusing the driver. Can you try lp:~robert-ancell/simple-scan/lp-1097096 and see if this fixes it?

Changed in simple-scan (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Michał Sawicz (saviq) wrote :

Hey, yes, that seems to help! :)

Robert Ancell (robert-ancell) wrote :

Fixed in simple-scan 3.6.1 and 3.7.1

Changed in simple-scan:
status: New → Fix Released
importance: Undecided → Medium
Changed in simple-scan (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package simple-scan - 3.6.1-0ubuntu1

---------------
simple-scan (3.6.1-0ubuntu1) raring; urgency=low

  * New upstream bugfix release:
    - Fix scan no longer working after an ADF scan completes (LP: #1097096)
    - Fix erroneous warning about failing to set ADF source
 -- Robert Ancell <email address hidden> Fri, 22 Mar 2013 09:24:50 +1300

Changed in simple-scan (Ubuntu):
status: Fix Committed → Fix Released

Hello Michał, or anyone else affected,

Accepted simple-scan into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/simple-scan/3.4.3-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in simple-scan (Ubuntu Precise):
status: New → Triaged
importance: Undecided → Medium
status: Triaged → Fix Committed
tags: added: verification-needed

I can confirm that this fixed the issue for me. Seems like the application is faster too. Nice work.

Now running: simple-scan 3.4.3-0ubuntu1.
Still running Ubuntu 12.04 LTS.

I do not see where I can change the tag from from verification-needed to verification-done. Perhaps I do not have rights to add/change tags on launchpad.net? But I can confirm that it fixed the issue on my system.

tags: added: verification-done
tags: removed: verification-needed

I think I found how to change the tag from from verification-needed to verification-done and did so. If I did it in error - my apologies in advance.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package simple-scan - 3.4.3-0ubuntu1

---------------
simple-scan (3.4.3-0ubuntu1) precise-proposed; urgency=low

  * New upstream bugfix release (LP: #1158558):
    [ 3.4.2 ]
    - Fix save dialog filter labels
    [ 3.4.3 ]
    - Fix scan no longer working after an ADF scan completes (LP: #1097096)
    - Fix erroneous warning about failing to set ADF source
    - Fix crash caused by signal being emitted in scan thread
    - Fix crash when starting a new document during a scan
  * debian/patches/02-file-filter-labels.patch:
    - Applied upstream
 -- Robert Ancell <email address hidden> Fri, 22 Mar 2013 09:47:49 +1300

Changed in simple-scan (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.