signon-ui crashed with SIGSEGV in SignOnUi::BrowserRequestPrivate::~BrowserRequestPrivate()

Bug #1120737 reported by Rainer Rohde on 2013-02-10
186
This bug affects 42 people
Affects Status Importance Assigned to Milestone
signon-ui (Ubuntu)
Medium
Unassigned

Bug Description

Tried to add an online account via System Settings > Online Accounts, I believe twitter, and it crashed on me.

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: signon-ui 0.12bzr13.01.09-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-5.10-generic 3.8.0-rc6
Uname: Linux 3.8.0-5-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.8-0ubuntu4
Architecture: amd64
Date: Sat Feb 9 18:37:16 2013
Disassembly: => 0x0: Cannot access memory at address 0x0
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/signon-ui
MarkForUpload: True
ProcCmdline: /usr/bin/signon-ui
ProcEnviron:
 SHELL=/bin/bash
 XDG_RUNTIME_DIR=<set>
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SegvAnalysis:
 Segfault happened at: 0x0: Cannot access memory at address 0x0
 PC (0x00000000) not located in a known VMA region (needed executable region)!
SegvReason: executing NULL VMA
Signal: 11
SourcePackage: signon-ui
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 QObjectPrivate::deleteChildren() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
 QObject::~QObject() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
Title: signon-ui crashed with SIGSEGV in QObjectPrivate::deleteChildren()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: lp lpadmin sudo

Rainer Rohde (rainer-rohde) wrote :
information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in signon-ui (Ubuntu):
status: New → Confirmed

StacktraceTop:
 ?? ()
 SignOnUi::BrowserRequestPrivate::~BrowserRequestPrivate (this=0x1850870, __in_chrg=<optimized out>) at browser-request.cpp:290
 SignOnUi::BrowserRequestPrivate::~BrowserRequestPrivate (this=0x1850870, __in_chrg=<optimized out>) at browser-request.cpp:291
 QObjectPrivate::deleteChildren (this=this@entry=0x1504fd0) at kernel/qobject.cpp:1907
 QObject::~QObject (this=0x1521ee0, __in_chrg=<optimized out>) at kernel/qobject.cpp:926

Changed in signon-ui (Ubuntu):
importance: Undecided → Medium
summary: - signon-ui crashed with SIGSEGV in QObjectPrivate::deleteChildren()
+ signon-ui crashed with SIGSEGV in
+ SignOnUi::BrowserRequestPrivate::~BrowserRequestPrivate()
tags: removed: need-amd64-retrace
Genadi Saltikov (carmageddon-2) wrote :

This also happens to me when trying to add my Google ACcount which is configured to 2-Step Verification.
When I finish entering the code from my SMS, sometimes the window disappears back to selection of account type to add, other times I get to click Verify button, and then goes back to account selection..

Steven Beer (webneo82) wrote :

I've tried to add my facebook account and a new chrome browser window appears (not in empathy window). After login, this error the crash appears.

Baldrick (bheath-nz) wrote :

+1 to Steven Beer's comment. Changing to Firefox yields same results.

Once logged into facebook account, the webpage says 'Success', but empathy fails to sign you in, and crashes instead.

I don't know why they simply don't revert to the way they had it in 12.04, signing up and in worked flawlessly.

Baldrick (bheath-nz) wrote :

It seems to work better since an update today (28/2), but you seem to have to type really quickly once you've got through the facebook login screen (which is now implemented nicely within the app) to the next screen where you have to name your device.

It seems like you've only got a second or two to fill out your device name before it times out, and you then have to physically clear the 'intruder alert' message on your facebook page. This is not enough time for the average, non-typist, user.

Hopefully this is just a bug & will get sorted before final release.

It works now for me. Thanks to all involved in sorting this out.

Using 13.04, 32bit, on a Dell Latitude, i5 laptop.

Alberto Mardegan (mardy) wrote :

The Facebook authentication issue is bug 1132030, which was an error on Facebook's server side (which got already fixed).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers