signon-ui crashed with SIGSEGV in SignOnUi::BrowserRequestPrivate::~BrowserRequestPrivate()

Bug #1111507 reported by Kamil Pajak on 2013-01-31
102
This bug affects 57 people
Affects Status Importance Assigned to Milestone
Online Accounts: Sign-on UI
Critical
Alberto Mardegan
signon-ui (Ubuntu)
Medium
Unassigned

Bug Description

Don't know details

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: signon-ui 0.12bzr13.01.09-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-2.6-generic 3.8.0-rc4
Uname: Linux 3.8.0-2-generic i686
ApportVersion: 2.8-0ubuntu3
Architecture: i386
CrashCounter: 1
Date: Thu Jan 31 15:29:56 2013
Disassembly: => 0x0: Cannot access memory at address 0x0
ExecutablePath: /usr/bin/signon-ui
InstallationDate: Installed on 2013-01-30 (1 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha i386 (20130129)
MarkForUpload: True
ProcCmdline: /usr/bin/signon-ui
ProcEnviron:
 SHELL=/bin/bash
 XDG_RUNTIME_DIR=<set>
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SegvAnalysis:
 Segfault happened at: 0x0: Cannot access memory at address 0x0
 PC (0x00000000) not located in a known VMA region (needed executable region)!
SegvReason: executing NULL VMA
Signal: 11
SourcePackage: signon-ui
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 QObjectPrivate::deleteChildren() () from /usr/lib/i386-linux-gnu/libQtCore.so.4
 QObject::~QObject() () from /usr/lib/i386-linux-gnu/libQtCore.so.4
Title: signon-ui crashed with SIGSEGV in QObjectPrivate::deleteChildren()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
XsessionErrors: (polkit-gnome-authentication-agent-1:1908): GLib-WARNING **: GChildWatchSource: Exit status of a child process was requested but ECHILD was received by waitpid(). Most likely the process is ignoring SIGCHLD, or some other thread is invoking waitpid() with a nonpositive first argument; either behavior can break applications that use g_child_watch_add()/g_spawn_sync() either directly or indirectly.

Related branches

Kamil Pajak (kamilpajak) wrote :

StacktraceTop:
 ?? ()
 SignOnUi::BrowserRequestPrivate::~BrowserRequestPrivate (this=0x98ad8d8, __in_chrg=<optimized out>) at browser-request.cpp:290
 SignOnUi::BrowserRequestPrivate::~BrowserRequestPrivate (this=0x98ad8d8, __in_chrg=<optimized out>) at browser-request.cpp:291
 QObjectPrivate::deleteChildren (this=this@entry=0x98ac7c0) at kernel/qobject.cpp:1907
 QObject::~QObject (this=0x98ab268, __in_chrg=<optimized out>) at kernel/qobject.cpp:926

Changed in signon-ui (Ubuntu):
importance: Undecided → Medium
summary: - signon-ui crashed with SIGSEGV in QObjectPrivate::deleteChildren()
+ signon-ui crashed with SIGSEGV in
+ SignOnUi::BrowserRequestPrivate::~BrowserRequestPrivate()
tags: removed: need-i386-retrace
Kamil Pajak (kamilpajak) on 2013-02-26
information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in signon-ui (Ubuntu):
status: New → Confirmed
Alberto Mardegan (mardy) on 2013-03-21
Changed in signon-ui:
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Alberto Mardegan (mardy)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:signon-ui at revision 81, scheduled for release in signon-ui, milestone 0.12

Changed in signon-ui:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package signon-ui - 0.14-0ubuntu1

---------------
signon-ui (0.14-0ubuntu1) raring; urgency=low

  * New upstream release.
    - Fix page scrolling for some websites (LP: #1158173)
    - Prevent a double deletion of the browser dialog (LP: #1111507)
    - Tests: don't use any libnotify methods.
 -- Alberto Mardegan <email address hidden> Thu, 21 Mar 2013 14:46:48 +0200

Changed in signon-ui (Ubuntu):
status: Confirmed → Fix Released
Alberto Mardegan (mardy) on 2013-04-04
Changed in signon-ui:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers