signon-ui crashed with SIGABRT in __libc_message()

Bug #1053454 reported by Christopher on 2012-09-20
310
This bug affects 58 people
Affects Status Importance Assigned to Milestone
Online Accounts: Sign-on UI
High
Alberto Mardegan
signon-ui (Ubuntu)
Medium
BunnyBoy

Bug Description

Happened on boot yesterday and now. Doesn't seem to affect anything, as I logged on as usual to the keyrings.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: signon-ui 0.10-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-15.22-generic 3.5.4
Uname: Linux 3.5.0-15-generic i686
NonfreeKernelModules: wl
ApportVersion: 2.5.2-0ubuntu4
Architecture: i386
CrashCounter: 1
Date: Thu Sep 20 09:53:38 2012
ExecutablePath: /usr/bin/signon-ui
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcCmdline: /usr/bin/signon-ui
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANGUAGE=en_CA:en
 LANG=en_CA.UTF-8
Signal: 6
SourcePackage: signon-ui
StacktraceTop:
 raise () from /lib/i386-linux-gnu/libc.so.6
 abort () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /lib/i386-linux-gnu/libc.so.6
 operator delete(void*) () from /usr/lib/i386-linux-gnu/libstdc++.so.6
Title: signon-ui crashed with SIGABRT in raise()
UpgradeStatus: Upgraded to quantal on 2012-08-17 (34 days ago)
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lpadmin netdev plugdev sambashare scanner tape vboxusers video

Related branches

Christopher (soft-kristal) wrote :

StacktraceTop:
 __libc_message (do_abort=2, fmt=0xb4dc91dc "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:201
 malloc_printerr (action=<optimized out>, str=<optimized out>, ptr=0xbfb0c904) at malloc.c:5007
 operator delete (ptr=0xbfb0c904) at ../../../../src/libstdc++-v3/libsupc++/del_op.cc:48
 QNetworkProxyFactory::~QNetworkProxyFactory (this=0xbfb0c904, __in_chrg=<optimized out>) at kernel/qnetworkproxy.cpp:1295
 ~QGlobalNetworkProxy (this=0x9f4f378, __in_chrg=<optimized out>) at kernel/qnetworkproxy.cpp:261

Changed in signon-ui (Ubuntu):
importance: Undecided → Medium
summary: - signon-ui crashed with SIGABRT in raise()
+ signon-ui crashed with SIGABRT in __libc_message()
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in signon-ui (Ubuntu):
status: New → Confirmed
Michael Terry (mterry) on 2012-09-22
visibility: private → public
David Richards (richards.dm) wrote :

#Note: I was able to recover the GUI by the following - workaround...
#
#purge old drivers fglrx
sudo apt-get remove --purge xorg-driver-fglrx fglrx*
#install new drivers
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri fglrx-modaliases
#reconfigure xorg
sudo dpkg-reconfigure xserver-xorg
#
sudo apt-get install --reinstall xserver-xorg-core

Angel Guzman Maeso (shakaran) wrote :

After uninstall fglrx is fully reproducible in quantal too for me.

Alberto Mardegan (mardy) wrote :

Hi Angel! Can you please give me more information about this crash? When does it happen? Does the crash have other effects than the popping up of the bug report dialog?

Changed in online-accounts-signon-ui:
status: New → Incomplete

I suffered this once, after upgrading to quantal. At the time, I was having multiple issues - for example, unity performance problems, problems with unity dismissing the "find applications/lenses" overlay, problems booting into gnome-shell.

I was able to submit the report when booting into gnome classic - it's not clear to me if it occurred during that gnome classic session or during the other issues.
My gnome classic session did not display a window manager.

Subsequent reboots, logging directly into gnome classic, have not triggered the problem again.

David King (amigadave) on 2012-09-24
Changed in online-accounts-signon-ui:
importance: Undecided → High
description: updated
Lars Düsing (lars.duesing) wrote :

I get this problems every time I log into gnome.
I have no other problems as the apport-dialogue.
I am using gdm as display-manager.

Alberto Mardegan (mardy) wrote :

Hi all, and thanks for reporting this bug. This crash happens when the signon-ui process is terminated, which usually happens at the end of a session. For this reason, the bug reporter catches this crash at the beginning of the next session: that's why it appears that the crash happened on login.

I have a fix almost ready, stay tuned! :-)

Although the stack trace is different, this is at all effects the same as bug 1053444.

Alberto Mardegan (mardy) on 2012-09-25
Changed in online-accounts-signon-ui:
status: Incomplete → In Progress
assignee: nobody → Alberto Mardegan (mardy)
Alberto Mardegan (mardy) on 2012-09-25
Changed in online-accounts-signon-ui:
status: In Progress → Fix Committed
tags: added: bugpattern-needed
BunnyBoy (sweetbany) on 2012-09-27
Changed in signon-ui (Ubuntu):
assignee: nobody → BunnyBoy (sweetbany)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package signon-ui - 0.11-0ubuntu1

---------------
signon-ui (0.11-0ubuntu1) quantal-proposed; urgency=low

  * New upstream release.
    - Do not instantiate invalid QDBusMessages (LP: #1040580)
    - Do not allocate the proxy factory on the
      stack (LP: #1053444) (LP: #1053454)
 -- Ken VanDine <email address hidden> Tue, 25 Sep 2012 16:47:07 -0400

Changed in signon-ui (Ubuntu):
status: Confirmed → Fix Released

Occurred in 12.10 while using it under Oracle VirtualBox 4.1.22. I was browsing the network when the file manager crashed.

David King (amigadave) on 2012-10-03
Changed in online-accounts-signon-ui:
milestone: none → 0.11
status: Fix Committed → Fix Released

where do I download fix

Alberto Mardegan (mardy) wrote :

Chris, the fix should be already available in Quantal (12.10) already. Just run the Update Manager and it should install the latest version.
Which version of signon-ui do you have currently installed?

To post a comment you must log in.