signon-ui crashed with SIGSEGV in ~QGlobalNetworkProxy()

Bug #1053444 reported by Francis Ginther on 2012-09-20
This bug affects 219 people
Affects Status Importance Assigned to Milestone
Online Accounts: Sign-on UI
High
Alberto Mardegan
signon-ui (Ubuntu)
Medium
Unassigned

Bug Description

apport reported crash immediately after login to desktop.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: signon-ui 0.10-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-15.22-generic 3.5.4
Uname: Linux 3.5.0-15-generic x86_64
NonfreeKernelModules: nvidia wl
ApportVersion: 2.5.2-0ubuntu4
Architecture: amd64
Date: Thu Sep 20 09:41:22 2012
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/signon-ui
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120627)
ProcCmdline: /usr/bin/signon-ui
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
Signal: 11
SourcePackage: signon-ui
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/libQtNetwork.so.4
 __run_exit_handlers (status=0, listp=0x7fb088b066a8 <__exit_funcs>, run_list_atexit=true) at exit.c:78
 __GI_exit (status=<optimized out>) at exit.c:100
 __libc_start_main (main=0x40d090, argc=1, ubp_av=0x7ffff5aa1378, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffff5aa1368) at libc-start.c:258
 ?? ()
Title: signon-ui crashed with SIGSEGV in __run_exit_handlers()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

Francis Ginther (fginther) wrote :

StacktraceTop:
 ~QGlobalNetworkProxy (this=0x1cbdb80, __in_chrg=<optimized out>) at kernel/qnetworkproxy.cpp:261
 QGlobalStaticDeleter<QGlobalNetworkProxy>::~QGlobalStaticDeleter (this=0x7fb089d99458, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qglobal.h:1950
 __run_exit_handlers (status=0, listp=0x7fb088b066a8, run_list_atexit=true) at exit.c:78
 __GI_exit (status=<optimized out>) at exit.c:100
 __libc_start_main (main=0x40d090, argc=1, ubp_av=0x7ffff5aa1378, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffff5aa1368) at libc-start.c:258

Changed in signon-ui (Ubuntu):
importance: Undecided → Medium
summary: - signon-ui crashed with SIGSEGV in __run_exit_handlers()
+ signon-ui crashed with SIGSEGV in ~QGlobalNetworkProxy()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in signon-ui (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
Timo Aaltonen (tjaalton) on 2012-09-21
visibility: private → public
Ursula Junque (ursinha) on 2012-09-24
tags: added: rls-q-tracking
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1053444

tags: added: iso-testing
Alberto Mardegan (mardy) on 2012-09-24
Changed in online-accounts-signon-ui:
assignee: nobody → Alberto Mardegan (mardy)
status: New → Confirmed
importance: Undecided → High

crash occured when signing into gnome classic

jerrylamos (jerrylamos) wrote :

amd64
I get
signon-ui crashed with SIGSEGV in exit()
see bug #1055828

So far, only workaround is a new install??

Alberto Mardegan (mardy) wrote :

Hi all, and thanks for reporting this bug. This crash happens when the signon-ui process is terminated, which usually happens at the end of a session. For this reason, the bug reporter catches this crash at the beginning of the next session: that's why it appears that the crash happened on login.

I have a fix almost ready, stay tuned! :-)

PS @jerrylamos: please do not reinstall! This bug, although annoying, is totally harmless, and reinstalling won't make it go away.

Changed in online-accounts-signon-ui:
status: Confirmed → In Progress
Alberto Mardegan (mardy) on 2012-09-25
Changed in online-accounts-signon-ui:
status: In Progress → Fix Committed
jerrylamos (jerrylamos) wrote :

Thanks! Just did an update/dist-upgrade and was able to get back to my chosen desktop.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package signon-ui - 0.11-0ubuntu1

---------------
signon-ui (0.11-0ubuntu1) quantal-proposed; urgency=low

  * New upstream release.
    - Do not instantiate invalid QDBusMessages (LP: #1040580)
    - Do not allocate the proxy factory on the
      stack (LP: #1053444) (LP: #1053454)
 -- Ken VanDine <email address hidden> Tue, 25 Sep 2012 16:47:07 -0400

Changed in signon-ui (Ubuntu):
status: Confirmed → Fix Released
David King (amigadave) on 2012-10-03
Changed in online-accounts-signon-ui:
milestone: none → 0.11
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers