signon-ui assert failure: *** glibc detected *** /usr/bin/signon-ui: invalid fastbin entry (free): 0x000000000234c3c0 ***

Bug #1040580 reported by Daniel Holbach on 2012-08-23
92
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Online Accounts: Sign-on UI
High
Alberto Mardegan
signon-ui (Ubuntu)
Medium
Unassigned

Bug Description

No idea what happened.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: signon-ui 0.6-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-11.11-generic 3.5.2
Uname: Linux 3.5.0-11-generic x86_64
ApportVersion: 2.5.1-0ubuntu1
Architecture: amd64
AssertionMessage: *** glibc detected *** /usr/bin/signon-ui: invalid fastbin entry (free): 0x000000000234c3c0 ***
CheckboxSubmission: 2f383a1679e8525d7196eb2518a1921f
CheckboxSystem: bb422ca46d02494cdbc459927a98bc2f
Date: Thu Aug 23 12:44:11 2012
ExecutablePath: /usr/bin/signon-ui
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110817)
ProcCmdline: /usr/bin/signon-ui
Signal: 6
SourcePackage: signon-ui
StacktraceTop:
 __libc_message (do_abort=2, fmt=0x7f6e6c474fd0 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:201
 malloc_printerr (action=3, str=0x7f6e6c471f99 "invalid fastbin entry (free)", ptr=<optimized out>) at malloc.c:5007
 QString::free(QString::Data*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
 ?? () from /usr/lib/x86_64-linux-gnu/libQtDBus.so.4
 QDBusMessage::~QDBusMessage() () from /usr/lib/x86_64-linux-gnu/libQtDBus.so.4
Title: signon-ui assert failure: *** glibc detected *** /usr/bin/signon-ui: invalid fastbin entry (free): 0x000000000234c3c0 ***
UpgradeStatus: Upgraded to quantal on 2012-06-27 (57 days ago)
UserGroups: adm admin audio cdrom dialout lpadmin plugdev sambashare

Related branches

Daniel Holbach (dholbach) wrote :

StacktraceTop:
 __libc_message (do_abort=2, fmt=0x7f6e6c474fd0 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:201
 malloc_printerr (action=3, str=0x7f6e6c471f99 "invalid fastbin entry (free)", ptr=<optimized out>) at malloc.c:5007
 QString::free(QString::Data*) () from /tmp/tmpIc5BMM/usr/lib/x86_64-linux-gnu/libQtCore.so.4
 ?? () from /tmp/tmpIc5BMM/usr/lib/x86_64-linux-gnu/libQtDBus.so.4
 QDBusMessage::~QDBusMessage() () from /tmp/tmpIc5BMM/usr/lib/x86_64-linux-gnu/libQtDBus.so.4

Changed in signon-ui (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
visibility: private → public
Changed in online-accounts-signon-ui:
assignee: nobody → Alberto Mardegan (mardy)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in signon-ui (Ubuntu):
status: New → Confirmed
Alberto Mardegan (mardy) wrote :

I cannot reproduce it. I'll try anyway to make a change that might fix this.

Changed in online-accounts-signon-ui:
status: New → In Progress
David King (amigadave) on 2012-09-24
Changed in online-accounts-signon-ui:
importance: Undecided → High
Alberto Mardegan (mardy) on 2012-09-26
Changed in online-accounts-signon-ui:
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package signon-ui - 0.11-0ubuntu1

---------------
signon-ui (0.11-0ubuntu1) quantal-proposed; urgency=low

  * New upstream release.
    - Do not instantiate invalid QDBusMessages (LP: #1040580)
    - Do not allocate the proxy factory on the
      stack (LP: #1053444) (LP: #1053454)
 -- Ken VanDine <email address hidden> Tue, 25 Sep 2012 16:47:07 -0400

Changed in signon-ui (Ubuntu):
status: Confirmed → Fix Released
Marius Gedminas (mgedmin) wrote :

This does not appear to have been fixed. I just got an apport dialog about an assertion failure in signon-ui, pointing towards this bug report. I have signon-ui 0.11.0ubuntu1, installed since Nov 02 according to my dpkg.log, and given that my last reboot was on Dec 19, I'm sure this was the version that was running when I got the crash.

I usually get these crash dialogs after I unlock my screen. I use gdm and gnome-shell.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers