/usr/bin/signonpluginprocess:11:QNetworkReply::error:OAuth2PluginNS::BasePlugin::onPostFinished

Bug #1521800 reported by errors.ubuntu.com bug bridge on 2015-12-01
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
High
David Barth
webapps-sprint
High
Alberto Mardegan
signon-plugin-oauth2 (Ubuntu)
High
Unassigned

Bug Description

The Ubuntu Error Tracker has been receiving reports about a problem regarding signon. This problem was most recently seen with version 8.58+16.04.20151106-0ubuntu1, the problem page at https://errors.ubuntu.com/problem/17dc65f889a59eed4d6d4099b339de34675bec83 contains more details.

Alberto Mardegan (mardy) wrote :

From the logs:

=========================
#0 QNetworkReply::error (this=this@entry=0x0) at access/qnetworkreply.cpp:499
No locals.
#1 0xb45a2d88 in OAuth2PluginNS::BasePlugin::onPostFinished (this=this@entry=0xc41988) at base-plugin.cpp:151
        reply = 0x0
        __func__ = "onPostFinished"
#2 0xb45b5286 in OAuth2PluginNS::BasePlugin::qt_static_metacall (_o=0xc41988, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at moc_base-plugin.cpp:121
        _t = 0xc41988
#3 0xb6c90d70 in QObject::event (this=<optimized out>, e=<optimized out>) at kernel/qobject.cpp:1245
        mce = <optimized out>
        sw = {receiver = 0xc41988, previousSender = 0x0, currentSender = {sender = 0xc45440, signal = 8, ref = 1}, switched = true}
#4 0xb6c70626 in QCoreApplication::notify (event=0xb3c02d78, receiver=0xc41988, this=0xbe831468) at kernel/qcoreapplication.cpp:997
        d = <optimized out>
#5 QCoreApplication::notifyInternal (this=0xbe831468, receiver=0xc41988, event=event@entry=0xb3c02d78) at kernel/qcoreapplication.cpp:935
        result = false
        cbdata = {0xc41988, 0xb3c02d78, 0xbe831277}
        d = <optimized out>
        threadData = 0xc28fa0
        loopLevelCounter = {threadData = 0xc28fa0}
#6 0xb6c71f50 in QCoreApplication::sendEvent (event=0xb3c02d78, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
No locals.
#7 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0xc28fa0) at kernel/qcoreapplication.cpp:1552
        e = 0xb3c02d78
        pe = <optimized out>
        r = <optimized out>
        unlocker = {m = <synthetic pointer>}
        event_deleter = {d = 0xb3c02d78}
        locker = {val = 12750780}
        startOffset = 0
        i = @0xc28fb4: 3
        cleanup = {receiver = 0x0, event_type = 0, data = 0xc28fa0, exceptionCaught = true}
#8 0xb6c72242 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1410
        data = <optimized out>
#9 0xb6caa1d8 in postEventSourceDispatch (s=0xc31400) at kernel/qeventdispatcher_glib.cpp:271
        source = 0xc31400
#10 0xb646430c in g_main_dispatch (context=0xc31280) at /build/glib2.0-KVr9W1/glib2.0-2.47.1/./glib/gmain.c:3154
        dispatch = 0xb6caa1c9 <postEventSourceDispatch(GSource*, GSourceFunc, gpointer)>
        prev_source = 0x0
        was_in_call = 0
        user_data = 0x0
        callback = 0x0
        cb_funcs = <optimized out>
        cb_data = 0x0
        need_destroy = <optimized out>
        source = 0xc31400
        current = 0xc313a8
        i = 0
=========================

It looks like the QNetworkReply::finished() was emitted from another thread, so calling sender() from the signal handler returns a NULL object.

affects: signon (Ubuntu) → signon-plugin-oauth2 (Ubuntu)
Changed in signon-plugin-oauth2 (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Alberto Mardegan (mardy) wrote :
Changed in webapps-sprint:
status: New → Confirmed
importance: Undecided → Critical
importance: Critical → High
assignee: nobody → Alberto Mardegan (mardy)
milestone: none → sprint-18
Alberto Mardegan (mardy) on 2015-12-10
summary: - /usr/bin/signonpluginprocess:11:QNetworkReply::error:OAuth2PluginNS::BasePlugin::onPostFinished:OAuth2PluginNS::BasePlugin::qt_static_metacall:QObject::event:QCoreApplication::notify
+ /usr/bin/signonpluginprocess:11:QNetworkReply::error:OAuth2PluginNS::BasePlugin::onPostFinished
Changed in canonical-devices-system-image:
assignee: nobody → David Barth (dbarth)
importance: Undecided → High
milestone: none → ww02-2016
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package signon-plugin-oauth2 - 0.23+16.04.20151209-0ubuntu1

---------------
signon-plugin-oauth2 (0.23+16.04.20151209-0ubuntu1) xenial; urgency=medium

  [ Alberto Mardegan ]
  * Merge from upstream
    - BasePlugin: don't use QObject::sender() for network callbacks, as it can
      be NULL (LP: #1521800)

  [ CI Train Bot ]
  * No-change rebuild.

 -- David Barth <email address hidden> Wed, 09 Dec 2015 09:02:30 +0000

Changed in signon-plugin-oauth2 (Ubuntu):
status: Confirmed → Fix Released
Alberto Mardegan (mardy) on 2016-01-11
Changed in webapps-sprint:
status: Confirmed → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers