Ubuntu

Shutter ignores typed-in save location

Reported by Vladimir Rutsky on 2010-10-10
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Shutter
Low
Mario Kemper (Romario)
shutter (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: shutter

Steps to reproduce:
1. Create directory for screenshots:
 $ mkdir -p /tmp/shutter/screenshots/dir
2. Start shutter with clean configuration:
 $ cd
 $ mv .shutter .shutter_
 $ shutter
3. Open Edit -> Preferences. Main tab. By default "Directory" is home directory.
4. Click on directory value---list of common directories will be poped down, select "Other..."---directory selection menu will apper.
5. Enter in Location "/tmp/shutter/screenshots/dir/" and press Enter. Shutter will show, that Directory for saving screenshots is "dir".
5. Close Shutter Preferences with "Close" button. Close Shutter: File -> Quit
6. Check which directory is saved in cofiguration:
 $ grep -o -e 'folder="[^"]*"' .shutter/settings.xml

Observed behavior---selected directory "/tmp/shutter/screenshots/dir/" not saved in configuration:
 $ grep -o -e 'folder="[^"]*"' .shutter/settings.xml
folder="/home/bob"

Expected behavior---folder should be set to "/tmp/shutter/screenshots/dir/":
 $ grep -o -e 'folder="[^"]*"' .shutter/settings.xml
folder="/tmp/shutter/screenshots/dir"

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: shutter 0.85.1-1ubuntu1.1
ProcVersionSignature: Ubuntu 2.6.32-24.43-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-24-generic x86_64
NonfreeKernelModules: compat_firmware_class nvidia
Architecture: amd64
Date: Sun Oct 10 12:10:40 2010
PackageArchitecture: all
SourcePackage: shutter

Related branches

Vladimir Rutsky (rutsky) wrote :

Please post your observations in the original bug report. The described behaviour was supposed to be fixed in the package 0.85.1-1ubuntu1.1.

Vladimir Rutsky (rutsky) wrote :

Mario,

Please see comments #29-#32 of https://bugs.launchpad.net/shutter/+bug/511942 bug discussion (you marked this bug as duplicate of that). Described here bug is reproducable in 0.86.4 from Shutter's ppa, detailed description and screencast of bug can be found in comments #29, #30 of https://bugs.launchpad.net/shutter/+bug/511942 .

You are right. This is a new bug. Sorry for the delay.
I am working on it.

Changed in shutter:
status: New → Confirmed
assignee: nobody → Mario Kemper (Romario) (mario-kemper)
milestone: none → 0.87
importance: Undecided → Medium

Could you please select the new folder manually instead of pasting? Does this work? Might be a bug in gtk's filechooser.

Vladimir Rutsky (rutsky) wrote :

> Could you please select the new folder manually instead of pasting? Does this work?
Yes, it works: if I select folder by walking with mouse through directories until contents of /tmp/shutter/dir/ is shown and then pressing "Open", then screenshots are made into /tmp/shutter/dir/.

How can be tested is this a GTK's bug? Will you post bug report to GTK team?
Which information you need?
I'm using:
  Gnome - 2.30.2
  libgtk2-perl - 1:1.221-4ubuntu2
  libgtk2.0-0 - 2.20.1-0ubuntu2

I've already posted the bug to the gtk2-perl-list, see:
http://<email address hidden>/msg06423.html

Maybe somebody knows the problem.

I was also able to reproduce the problem with gnome-screenshot. I'll open a bug report for it as soon as possible.

Nick Callaghan (niknak) wrote :

WORKAROUND:

Editing in the folder options manually in the ~/.shutter/settings.xml provides a workaround

See Jeremy's answer here:
http://<email address hidden>/msg06423.html

It is not a bug. gnome-screenshot uses the same (wrong) call. I'll open a new bug report for gnome-screenshot.

The code in Shutter is fixed now. I'll upload a new testing version as soon as possible so you can verify the fix (you can also get the code here if you want to try it now: https://code.launchpad.net/~mario-kemper/shutter/devel).

Changed in shutter:
status: Confirmed → Fix Committed
importance: Medium → Low

There is already a bug report for gnome-screenshot. I've added the solution as a comment:
https://bugzilla.gnome.org/show_bug.cgi?id=579232

summary: - Shutter don't preserve screenshot saving directory
+ Shutter ignores typed-in save location
Changed in shutter (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Sam Macintier (macintier) wrote :

Following the suggestion from post #9, I attempted to edit ~/.shutter/settings.xml to find that it was, for some reason, read only. I changed it to read and write and that resolved the issue completely. Preference changes I make in Shutter are now remaining. Running 0.86.4, Rev.906.

Changed in shutter:
status: Fix Committed → Fix Released
Krzysztof Klimonda (kklimonda) wrote :

It doesn't seem to be fixed in 0.87 - there is still this code in bin/shutter:
$settings{'general'}->{'folder'} = $saveDir_button->get_current_folder();
and according to the thread from http://<email address hidden>/msg06423.html it should be:
$settings{'general'}->{'folder'} = $saveDir_button->get_filename();
also, I can still reproduce the bug by following steps.

Changed in shutter:
milestone: 0.87 → 0.87.1
status: Fix Released → Fix Committed

Confirmed and fixed in Shutter 0.87.1. The code is available here:
https://code.launchpad.net/~mario-kemper/shutter/devel

New packages are available in this PPA:
https://launchpad.net/~shutter-testing-team/+archive/ppa/+packages

Changed in shutter:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package shutter - 0.87.1-0ubuntu1

---------------
shutter (0.87.1-0ubuntu1) natty; urgency=low

  * New bugfix only upstream release.
  * Fixes bug when Shutter ignored typed-in save location. (LP: #657585)
 -- Krzysztof Klimonda <email address hidden> Tue, 15 Mar 2011 23:29:32 +0100

Changed in shutter (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.