Ubuntu

Shutter has disabled features: Web capture, Edit and Send

Reported by komputes on 2010-03-27
88
This bug affects 21 people
Affects Status Importance Assigned to Milestone
shutter (Ubuntu)
Low
Andrew Starr-Bochicchio

Bug Description

Binary package hint: shutter

The features of Edit, and Send are not available unless gnome-web-photo, libgoo-canvas-perl, and nautilus-sendto.

Shutter should ask user to install missing packages at first run **OR** change gnome-web-photo, libgoo-canvas-perl, nautilus-sendto from suggests to recommends.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: shutter 0.85.1-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-17.26-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-17-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Sat Mar 27 12:19:44 2010
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100318)
PackageArchitecture: all
ProcEnviron:
 LANG=en_CA.utf8
 SHELL=/bin/bash
SourcePackage: shutter

Related branches

komputes (komputes) wrote :
komputes (komputes) wrote :

Confirmed, with libgoo-canvas-perl not installed, Shutter's Edit button is greyed out. Other packages from the Suggests line cause the same kind of issues.

This is especially relevant when using the Software Center to install packages like Shutter: Suggests don't get "suggested" to users, so parts of the application aren't available.

Changed in shutter (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
jakebiesinger (jake-biesinger) wrote :

No go on a fresh install of Ubuntu 10.04 x86_64.

After:
sudo apt-get install libgoo-canvas-perl gnome-web-photo nautilus-sendto shutter

I still have greyed out "Edit" and "Export " buttons. Reinstalling shutter via synaptic and doing a complete removal then reinstallation doesn't help.

What additional info can I provide on this to help out?

Oded Arbel (oded-geek) wrote :

Using Lucid, after installing the requirements I've quit Shutter and restarted it. Now editing works.

I hope this issue will be fixed by an update because Shutter's editing feature makes it a killer app in the area of screen capture programs, and by proxy makes Ubuntu an attractive choice for people who need that functionality (graphic designers, web developers, technical writers, product managers, etc.).

In the current setup a user has no way of discovering this great capability, unless they:
- know about this feature ahead of time
- know about launchpad
- know to search for this issue in launchpad and know how to read technical discussions in bug reports
These are some heavy requirements for Ubuntu's target audience ("Human beings", according to the old tag line)

@Packagers:
Please change gnome-web-photo, libgoo-canvas-perl, nautilus-sendto from suggests to recommends.

komputes (komputes) wrote :

@jakebiesinger
I have just tested this on a fresh install of Ubuntu 10.04 x86_64, and the "Edit" and "Export " buttons appear. Make sure you restart the program after installing those packages. It sounds like you may have a bug on you own, in which case I suggest you press alt-f2 and run "ubuntu-bug-shutter" to report your issue.

Cheers and good luck!

Fabián Rodríguez (magicfab) wrote :

Tested this again today for documentation purposes. nautilus-sendto is installed by default so Send should work now. I guess this changed between the report time and the release.

summary: - shutter program has disabled features
+ Shutter has disabled features: Web capture, Edit and Send
Krzysztof Klimonda (kklimonda) wrote :

The current relationship between shutter and gnome-web-photo, libgoo-canvas-perl, nautilus-sendto and libnet-dbus-glib-perl (in 0.86.3 release) is the right one. A Recommends field lists strong, but not absolute, dependencies - i.e. something that should be installed in all but edge cases. Suggests on the other hand lists packages that, if installed, enable additional functionality. In 10.10 it is going to become easier to install suggested packages through Ubuntu Software Center.

I'm closing this bug as Invalid because features do work after you install suggested packages.

Changed in shutter (Ubuntu):
status: Confirmed → Invalid
koushik (koushik-ms) wrote :

I disagree with the above comment.

I recently installed Shutter and could figure out why the web screenshot button was greyed out - there was a clear tooltip explaining gnome-web-photo needs to be installed and looking for gnome-web-photo was directly able to locate the package.

On the other hand, figuring out why the edit button was greyed out was not easy.

The Tooltip indicated "Goo: Canvas/libgoocanvas needs to be installed". The same was output as an warning message when I ran shutter from the command line. From the tooltip, I searched around for goocanvas (aptitude search goocanvas) - and noticed libgoocanvas3 and some other packages with libgoocanvas in their name were already installed. It is after some searching around that I realised the missing dependency is libgoo-canvas-perl. I think the aptitude search didn't list libgoo-canvas-perl also because of the '-' in the middle of the name. All other packages (including libgoocanvas) and also the shutter tooltip treat goocanvas as one word whereas the missing package name splits it into 2 words (libgoo-canvas).

I heard from a forum what the edit button enables and hence persisted, but for a new user trying to discover what shutter does, not having this dependency stated at least as a recommended dependency is really making it difficult. From reading the blurb about Shutter on its website and in software center/synaptic, drawing on to the screenshot is a rather basic, fundamental use-case of Shutter. In my opinion, this is THE killer feature that sets shutter apart from run-of-the-mill screenshoting programs. Thus the dependency of shutter on libgoo-canvas-perl & gnome-web-photo is rather strong and needed is most typical usages/ installations of shutter.

Not making this relationship apparent dilutes the first-impression of shutter and the user experience - making it look like yet another tool to capture screenshots.

koushik (koushik-ms) wrote :

Sorry if I sound rude in my previous comment. That is not my intention. I love shutter and I feel strongly about making it work to its full potential in ubuntu. I don't see any reason why the dependencies can't be made stronger.

Hence the detailed rant :-).

Vadim Rutkovsky (roignac) wrote :

As many users don't read console output and don;t install recommended packages by default, maybe we should add a message box with a list of disabled features and packages when Shutter is starting?
Also, a checkbox "Don't notify again" would be useful.

>
> Sorry if I sound rude in my previous comment. That is not my intention.
> I love shutter and I feel strongly about making it work to its full
> potential in ubuntu. I don't see any reason why the dependencies can't
> be made stronger.
>
> Hence the detailed rant :-).
>
>
@koushik: That's fine. Thanks for your detailed information. This is a
decision made by the maintainers of Shutter's ubuntu package. You can still
stick to our "official" packages that are available here:
http://shutter-project.org/downloads/

As many users don't read console output and don;t install recommended
> packages by default, maybe we should add a message box with a list of
> disabled features and packages when Shutter is starting?
> Also, a checkbox "Don't notify again" would be useful.

@Vadim: I like the idea. I'll open a new bug for this.

Fabián Rodríguez (magicfab) wrote :

The original reporter indicated "Shutter should ask user to install missing packages at first run..." so no need for another bug report. Exposing functionality that can't be enabled in an intuitive way is and remain the current problem in this package.

Changed in shutter (Ubuntu):
status: Invalid → Triaged

> Exposing functionality that can't be enabled in an intuitive way is and
> remain the current problem in this package.

Why is it disabled? For what purpose? Saving disk space? That is the
maintainer's decision and not the developer's.

I - as the developer of Shutter - have implemented Shutter this way
because the relevant packages were not available in all distributions
(especially the Perl bindings of libraries like libgoocanvas). I can
easily change the implementation in order to make these libraries
mandatory.
But I simply won't do that because of other distributions.

I'm going to have to disagree with Krzysztof, and I am preparing an upload resolving this. I might agree if these functions we hidden in a plugin menu and not exposed on the default toolbar. Mario's comment above clearly explains that upstream intends this functionality to work out of the box. These indeed should be "strong, but not absolute, dependencies - i.e. something that should be installed in all but edge cases." The edge case is running this program on a distribution where these packages are not available.

Changed in shutter (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Andrew Starr-Bochicchio (andrewsomething)
Changed in shutter (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package shutter - 0.86.3-0ubuntu2

---------------
shutter (0.86.3-0ubuntu2) maverick; urgency=low

  * debian/control: Move gnome-web-photo and libgoo-canvas-perl
    from Suggests to Recommends in accordance with the upstream
    developer's wishes. Functionality exposed in the default
    toolbar should work out of the box. (LP: #549679)
 -- Andrew Starr-Bochicchio <email address hidden> Mon, 04 Oct 2010 18:04:43 -0400

Changed in shutter (Ubuntu):
status: Fix Committed → Fix Released
koushik (koushik-ms) wrote :

Great ! Thanks, Andrew, for the fix.

MGdesigner (shoichi-chou) wrote :

Confirmed!

izar (izar00) wrote :

for some reason i had same problem with ubuntu 12.04
i did:
sudo apt-get install gnome-web-photo libgoo-canvas-perl nautilus-sendto
and it fixed the issue.

BETLOG (betlog-hax) wrote :

On Kubuntu 12.04 : do I really need to install 47Mb of gnome stuff simply to make web capture work?
Is there a more efficient KDE workaround? Or an actual first install/update fix?

Shutter 0.88.1
rev: 1184

Vadim Peretokin (vperetokin) wrote :

Web capture is provided by an external program in Shutter.
On Nov 15, 2012 1:50 PM, "BETLOG" <email address hidden> wrote:

> On Kubuntu 12.04 : do I really need to install 47Mb of gnome stuff simply
> to make web capture work?
> Is there a more efficient KDE workaround? Or an actual first
> install/update fix?
>
> Shutter 0.88.1
> rev: 1184
>
> --
> You received this bug notification because you are a member of Shutter
> Team, which is subscribed to shutter in Ubuntu.
> https://bugs.launchpad.net/bugs/549679
>
> Title:
> Shutter has disabled features: Web capture, Edit and Send
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/shutter/+bug/549679/+subscriptions
>

Vadim Peretokin (vperetokin) wrote :

Ops, the email sent early. So nothing is actually broken in Shutter and
there is no update to correct this - Shutter is a gtk app and uses the
functionality of gnome-web-photo instead of reimplementing it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers