shotwell's unity progress bar hangs halfway across

Bug #987046 reported by cometdog on 2012-04-23
92
This bug affects 17 people
Affects Status Importance Assigned to Milestone
shotwell (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned

Bug Description

TESTCASE:
- run shotwell under unity
- without the update the progress bar on the launcher icon stays
- with the update it should be dismissed once loading is done

I love that shotwell supports the Unity progress bar on shotwell's launcher icon.

But, when I open shotwell it uses the CPU heavily for several minutes, during which time the progress bar makes it about halfway across, and then stops. The progress bar stops, and fortunately the CPU usage eventually dies down as well. But then the progress bar merely remains there indefinitely.

This process repeats every time I start shotwell. It's entirely possible that shotwell's trying to perform some task (related to making NEF's into jpeg thumbnails, for example?) but never finishes for some reason? So I don't know if the issue is with the progress bar specifically, or with some other task that never completes and then is re-started every time I start shotwell. In any case, I have to leave shotwell open all the time as it is difficult to work with during the extended heavy CPU usage that occurs during every startup.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: shotwell 0.12.2-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
ApportVersion: 2.0.1-0ubuntu5
Architecture: amd64
Date: Sun Apr 22 20:01:05 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120327.1)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: shotwell
UpgradeStatus: No upgrade log present (probably fresh install)

cometdog (ericctharley) wrote :
mlaverdiere (mlaverdiere) wrote :

Same thing here. Here's a screenshot after Shotwell has finished loading. The halfway progress bar remains on Shotwell's icon on the Launcher.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in shotwell (Ubuntu):
status: New → Confirmed
Adam Dingle (adam-yorba) wrote :

Odd. I've opened a ticket upstream at

http://redmine.yorba.org/issues/5100

How many photos are in your library? While the Unity progress bar is advancing, do you see a progress bar within Shotwell indicating what is going on?

mlaverdiere (mlaverdiere) wrote :

I have more than 6K photos & videos. No, there's no progress bar stalled within Shotwell.

(I used to experiment the ""Writing metadata to files..." never finishes" bug as well, but not lately. See: https://bugs.launchpad.net/ubuntu/+source/shotwell/+bug/894553)

Sebastien Bacher (seb128) wrote :

I can't confirm the cpu spike but here shotwell starts with 2 icons, then one is dismissed and one remain with an half done progress bar over the unity launcher and it stays this way

Changed in shotwell (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Adam Dingle (adam-yorba) wrote :

We can reproduce this at Yorba. We'll fix this soon.

jaynis (kranz-jannis) wrote :

Same problem here. The progress bar on the unity launcher icon hangs at ~50% .

Changed in shotwell (Ubuntu):
status: Triaged → Fix Committed
Sebastien Bacher (seb128) wrote :

The bug has been fixed upstream in
http://git.yorba.org/cgit.cgi/shotwell/commit/?id=46e39b3cd4a69f619d0c281cbdcacaa89be0783a

Adam, do you have any idea when 0.12.3 is planned? I don't think that fix is urgent or warrant a release but I'm pondering if we should do a distro backport of the fix or wait for your next tarball

Adam Dingle (adam-yorba) wrote :

Sebastien, we're planning to release 0.12.3 in the next week or two, including this fix and a couple of other low-risk changes. So if I were you I'd wait for our tarball. Thanks!

Sebastien Bacher (seb128) wrote :

Works for me, thanks ;-)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package shotwell - 0.12.3-0ubuntu1

---------------
shotwell (0.12.3-0ubuntu1) quantal; urgency=low

  * New upstream version, fixes:
    - Shotwell deletes tags at random (lp: #999108)
    - shotwell's unity progress bar hangs halfway across (lp: #987046)
    - Shotwell will not detect mts moviefiles on memory card (lp: #990725)
 -- Sebastien Bacher <email address hidden> Wed, 16 May 2012 15:18:16 +0200

Changed in shotwell (Ubuntu):
status: Fix Committed → Fix Released
Changed in shotwell (Ubuntu Precise):
importance: Undecided → Low
status: New → Fix Committed
description: updated

Hello cometdog, or anyone else affected,

Accepted shotwell into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Roman Yepishev (rye) wrote :

Verified to be fixed in 0.12.3-0ubuntu0.1

tags: added: verification-done
removed: verification-needed
cometdog (ericctharley) wrote :

Progress bar diappears for me in 0.12.3-0ubuntu0.1, so seems like that fixes it.

However my problem with shotwell consuming resources and thrashing the hard drive for several minutes after startup persists, so I guess I should open a separate bug for that.

mlaverdiere (mlaverdiere) wrote :

I don't know if it's a completely different bug (see Bug #992403) than the one reported here, but now, Shotwell icon in the launcher is missing... I'm on a freshly updated 12.04 with Shotwell 0.12.3.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package shotwell - 0.12.3-0ubuntu0.1

---------------
shotwell (0.12.3-0ubuntu0.1) precise-proposed; urgency=low

  * New upstream version, fixes:
    - Shotwell deletes tags at random (lp: #999108)
    - shotwell's unity progress bar hangs halfway across (lp: #987046)
    - Shotwell will not detect mts moviefiles on memory card (lp: #990725)
 -- Sebastien Bacher <email address hidden> Wed, 16 May 2012 15:29:40 +0200

Changed in shotwell (Ubuntu Precise):
status: Fix Committed → Fix Released

mlaverdiere, I have the same problem and created bug 1012286, please click "affects me too" there!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers