Trouble setting library location to Pictures/Photos

Bug #975636 reported by Dylan McCall
42
This bug affects 9 people
Affects Status Importance Assigned to Milestone
shotwell (Ubuntu)
Low
Unassigned

Bug Description

At some point, I believe since upgrading to Shotwell 0.12.1, my library location change from /home/dylan/Pictures/Photos (which I think I had set myself) to /home/dylan/Pictures. So, Shotwell began importing photos to the wrong place.

Setting the location _back_ has proven difficult. I tried changing the dconf key back to Pictures/Photos, but Shotwell changed the path back to Pictures when I started it. I tried selecting it from the file chooser in the Preferences dialog, but I encountered the same behaviour. I tried setting to a completely different folder, /home/dylan/Documents, and the library location was changed to just /home/dylan.

I have had trouble determining exactly what is going on here. I kept trying and eventually I did something that made Shotwell _not_ change import-dir back. However, Shotwell Preferences still says the selection is "(None)".

I am attaching a screenshot of dconf-editor and Shotwell's Preferences dialog.

Sorry about the vagueness of this bug report. I'll try to provide some more information if you ask.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: shotwell 0.12.1-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
Uname: Linux 3.2.0-22-generic x86_64
ApportVersion: 2.0-0ubuntu4
Architecture: amd64
Date: Fri Apr 6 17:49:56 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110906)
SourcePackage: shotwell
UpgradeStatus: Upgraded to precise on 2012-02-04 (62 days ago)

Revision history for this message
Dylan McCall (dylanmccall) wrote :
Revision history for this message
Adam Dingle (adam-yorba) wrote :

Odd. I'm also on 12.04 but am completely unable to reproduce this. I've ticketed this upstream:

http://redmine.yorba.org/issues/5027

Changed in shotwell (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Revision history for this message
Yulian Ardiansyah (yulian-ardiansyah) wrote :

I can confirm the same problem. After I changed the import directory/library location in preferences, Shotwell somehow changed it back to ~/Pictures some other time I opened it again. However, this is a rather random behaviour since I can't always reproduce the issue even after I've done some editing, merging event directories or deleting photos in Shotwell.

Revision history for this message
wlx (wangliangxu) wrote :

I can confirm the similar problem here, ubuntu 12.04 amd 64, shotwell 0.12.3-0ubuntu0.1, the problem here is the default import directory is my home, and it is can not changed, even in gconf or the edit preference window.

Revision history for this message
Pantelis Panayiotou (p-panayiotou) wrote :

I can also confirm this. I tried chaning the import directory to ~/Pictures/shotwell multiple times, using both the configuration dialog and gconf-editor, but Shotwell keeps setting it directory back to ~/Pictures every single time.

Revision history for this message
Pantelis Panayiotou (p-panayiotou) wrote :

I'm changing this back to New because I really think someone should take a look at it. Many people (me included) store images in ~/Pictures that they don't want Shotwell to index. Not being able to change the import directory makes the software effectively useless for them.

Changed in shotwell (Ubuntu):
status: Triaged → New
Revision history for this message
Eric Gregory (eric-yorba) wrote :

For those of you experiencing this issue, does the directory you're pointing to actually exist? AFAIK Shotwell will not create a new folder for you; if the folder doesn't exist, it will switch to the child folder.

So for example if you point it at ~/Pictures/shotwell, but only ~/Pictures exists, Shotwell will use that folder.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in shotwell (Ubuntu):
status: New → Confirmed
Revision history for this message
Dylan McCall (dylanmccall) wrote :

Yes, ~/Pictures/Photos exists and contains lots and lots of photos from before Shotwell went senile ;)

I guess one detail I didn't mention is that _some_ folders in my home folder are symlinks to a larger hard drive (while everything else lives on an SSD). ~/Pictures and ~/Pictures/Photos, however, are not: they live completely on the SSD.

Playing with it now, it does seem to have stopped immediately reverting my changes to import-dir in dconf: it stays set to /home/dylan/Pictures/Photos when I start Shotwell, and it appears to do the right thing. However, Preferences still shows "Import photos to (None)".

Revision history for this message
Pantelis Panayiotou (p-panayiotou) wrote :

Hi Eric,

~/Pictures/shotwell exists and has correct permissions
gconftool reports that /apps/shotwell/preferences/files/import_dir is set to ~/Pictures/shotwell
gconftool also reports that /apps/shotwell/preferences/files/auto_import is set to false

However, in its preferences dialog, Shotwell has "import photos to" set to ~/Pictures and "watch library directory for new files" checked. In other words, it seems to completely ignore its gconf settings. Also, changing the settings in the preferences dialog does not make any difference: next time Shotwell starts, the settings are reset to the defaults and Shotwell starts to automatically index my ~/Pictures folder (though the gconf values remain unchanged to ~/Pictures/shotwell and false, respectively).

Let me know if I can provide any further info.

Revision history for this message
Dylan McCall (dylanmccall) wrote : Re: [Bug 975636] Re: Trouble setting library location to Pictures/Photos

Pantelis, Shotwell uses dconf now, not gconf. So you need to use
gsettings and dconf-editor to get at Shotwell's stored settings.

Revision history for this message
Pantelis Panayiotou (p-panayiotou) wrote :

OK, thanks Eric. I made some progress:

gsettings set org.yorba.shotwell.preferences.files auto-import false
This seems to work. Box "watch library directory for new files" is now unchecked in the preferences dialog, and Shotwell doesn't attempt to import files when started.

gsettings set org.yorba.shotwell.preferences.files import-dir '~/Pictures/shotwell'
This only works if ~/Pictures/shotwell is empty. Otherwise "Import photos to" shows (None), and it doesn't.

Weird.

P.S. The reason I thought Shotwell uses gconf is that it populates gconf keys on startup. But I guess this must be a feature, not a bug.

Revision history for this message
Pantelis Panayiotou (p-panayiotou) wrote :

So, I guess this bug should be summed up as:

Setting the import directory to a path that already contains photos may fail silently, with Shotwell setting it back either to ~/Pictures or to (None).

Note that this happened to me after I deleted ~/.shotwell. My (very uneducated) guess is that the program may need to keep the files in the import directory in sync with the data in ~/.shotwell, ignoring the import-dir setting if that's not possible.

Revision history for this message
Adam Lyall (magicmyth) wrote :

I can confirm this is affecting me on 12.10 as well. I have edited my XDG_PICTURES_DIR (.config/user-dirs.dir) to use a different folder: ~/My Media/Pictures. I was using F-Spot before but choose not to run the auto import as over time I had accidentally ended up with two Photo folders on my system. So I merged them into one under $XDG_PICTURES_DIR/Photos. I started F-Spot. Changed the library folder to ~/My Media/Pictures/Photos and Shotwell correctly imported everything. Restarting Shotwell I found the folder had been set back to the XDG_PICTURES_DIR path. If I change the folder then import an image it would still import to $XDG_PICTURES_DIR/[date-path]/image.jpg

I tried changing my XDG_PICTURES_DIR path to point to the Photos directory instead but this caused Shotwell to not copy photos into the library directory at all (despite explicitly choosing the "Copy photos" button). Changing the XDG_PICTURES_DIR path back to what I had before does not fix this. It seemed Shotwell was now totally confused.

I deleted my Shotwell data directory (.local/share/shotwell), set XDG_PICTURES_DIR="$HOME/My Media/Pictures/Photos", started Shotwell, imported a photo and it ended up in $HOME/My Media/Pictures/[date-path]/image.jpg. I was expecting at the very least for it to be the default $HOME/Pictures directory. The behavior makes me think it is hard coded to a folder called "Pictures".

Note that changing XDG_PICTURES_DIR tends to be reflected in Nautilus right away. I don't know if it is cached somewhere though which Shotwell may have read from.

Revision history for this message
Przemek Wesolek (pwes) wrote :

I can confirm having the bug in 12.04. However, I also managed to get rid of this.

After setting directory to ~/Pictures/Photos via dconf-settings, Shotwell behaved as in comment #12, the input field in preferences is set to "(None)". The structure of the Photos dir was:

  2005/
  2006/
  ...
  2012/
  some_text_file

I removed some_text_file, so only year folders were left. After restarting Shotwell, Photos folder is correctly displayed in preferences and I can import photos to that folder.

Revision history for this message
Clint Rogers (clinton-yorba) wrote :

Unfortunately, we're unable to reproduce this here, even when using the setup conditions suggested in comments twelve and fifteen (along with things like deliberately omitting the trailing slash, using '~' instead of typing out the full path to my home directory, etc.).

For those of you still affected by this, in addition to offering our apologies for the inconvenience, I'd like to ask if there's anything else you might know of that could help us trigger this; as soon as we can reproduce it in-house, we'd be happy to fix it for you.

Revision history for this message
Andrew DeMaria (lostonamountain) wrote :

This also affects me. I can not change the default ~/Pictures to ~/Pictures/Camera. Although I have my Pictures directory symlinked to another hard drive, I also tried setting it to a folder local to the home drive and I had no luck.

3.2.0-40-generic
Ubuntu 12.04
Shotwell 0.12.3

Revision history for this message
Jim Nelson (yorba-jim) wrote :

We'v e been unable to reproduce this since it was reported, although we have some suspicion that the GConf to GSettings conversion is behind some of the reported problems.

I noticed you're running Shotwell 0.12.3. That's quite old and a great deal of bug work has been done in the interim. I recommend upgrading to 0.14.1, available on the Yorba PPA: https://launchpad.net/~yorba/+archive/ppa

Revision history for this message
John (john-mcq1llan) wrote :

This continues to be a problem in 0.18.
I set the library location in 'preferences', then imported photos.
Shotwell then crashed catastrophically (i.e. it actually crashed the OS). Connecting a camera with an empty memory card seems to cause the crash.
When I restarted shotwell, the library location is now set to "none" and any changes I make are not saved.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers