Shotwell completely freezes upon start

Bug #909254 reported by rfcmedia on 2011-12-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Shotwell
New
Undecided
Unassigned
shotwell (Ubuntu)
Low
Unassigned

Bug Description

[what I did, although probably irrelevant to the problem, as described below]
I have a removable drive with all my photos on it.
Initially, I started shotwell with the drive UNplugged, so it showed lots of pictures as "missing".
I then quit, plugged in the drive, and started up shotwell.
It promptly froze, and subsequent kill/restarts continued to freeze.

[probably the cause of the problem]
It appears as if there is a /usr/bin/shotwell-video-thumbnailer process that ends up in state 'Sl' according to ps, and it runs on a '/media/SDCARD/PRIVATE/AVCHD/BDMV/MOVIEOBJ.BDM', some data file that gets generated by Panasonic cameras. Once I kill that process and wait a few seconds, shotwell comes back to life.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: shotwell 0.11.6-0ubuntu0.1 [modified: usr/share/glib-2.0/schemas/gschemas.compiled]
ProcVersionSignature: Ubuntu 3.0.0-14.23-generic-pae 3.0.9
Uname: Linux 3.0.0-14-generic-pae i686
ApportVersion: 1.23-0ubuntu4
Architecture: i386
Date: Tue Dec 27 22:43:22 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110921.2)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: shotwell
UpgradeStatus: No upgrade log present (probably fresh install)

rfcmedia (rfcmedia) wrote :
Adam Dingle (adam-yorba) wrote :

Thanks for the bug report. We've ticketed this upstream:

http://redmine.yorba.org/issues/4541

Could you possibly attach the offending video (MOVIEOBJ.BDM) here, or post a link to it if it's too large to attach?

Sebastien Bacher (seb128) wrote :

Setting to incomplete until the requested information is provided

Changed in shotwell (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
rfcmedia (rfcmedia) wrote :

I have an identical problem. Attached my MOVIEOBJ.BDM

Lucas Beeler (lucas-yorba) wrote :

Changed setting from "incomplete" to "confirmed" since a user other than the original reporter has both encountered the problem and attached a sample file. Because this involves a soft lockup of Shotwell, we've upped the priority on the upstream bug here: http://redmine.yorba.org/issues/4541

Changed in shotwell (Ubuntu):
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers