shotwell crashed with SIGABRT in editing_host_page_display_copy_of(): "_tmp1_ != NULL"

Bug #861870 reported by Till Kamppeter
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
shotwell (Ubuntu)
Medium
Unassigned

Bug Description

Removed old photos which I have viewed with shotwell simply via command line ("rm -rf ..."), to make space for an upgrade to Oneiric on my Asus eeePC 900. After completing the upgrade I opened shotwell. Old thumbnails shortly appeared, disappeared, clicked on "Missing Files", froze for some time, crash.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: shotwell 0.11.2-0ubuntu1 [modified: usr/share/glib-2.0/schemas/gschemas.compiled]
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic-pae 3.0.4
Uname: Linux 3.0.0-12-generic-pae i686
ApportVersion: 1.23-0ubuntu2
Architecture: i386
Date: Wed Sep 28 23:50:36 2011
ExecutablePath: /usr/bin/shotwell
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcCmdline: shotwell
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 6
SourcePackage: shotwell
StacktraceTop:
 __kernel_vsyscall ()
 raise () from /lib/i386-linux-gnu/libc.so.6
 abort () from /lib/i386-linux-gnu/libc.so.6
 g_assertion_message () from /lib/i386-linux-gnu/libglib-2.0.so.0
 g_assertion_message_expr () from /lib/i386-linux-gnu/libglib-2.0.so.0
Title: shotwell crashed with SIGABRT in __kernel_vsyscall()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lpadmin netdev plugdev sambashare tape video
XsessionErrors:
 (update-notifier:1860): libgdu-WARNING **: Couldn't call GetAll() to get properties for /org/freedesktop/UDisks/devices/sdc: Method "GetAll" with signature "s" on interface "org.freedesktop.DBus.Properties" doesn't exist
 (nautilus:1478): GdkPixbuf-CRITICAL **: gdk_pixbuf_composite: assertion `dest_x >= 0 && dest_x + dest_width <= dest->width' failed
 (nautilus:1478): GdkPixbuf-CRITICAL **: gdk_pixbuf_composite: assertion `dest_x >= 0 && dest_x + dest_width <= dest->width' failed

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :
visibility: private → public
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 g_assertion_message (domain=0x0, file=0x83b0c01 "i686-linux-gnu/PhotoPage.c", line=4621, func=0x83b1b80 "editing_host_page_display_copy_of", message=<optimized out>) at /build/buildd/glib2.0-2.30.0/./glib/gtestutils.c:1425
 g_assertion_message_expr (domain=0x0, file=0x83b0c01 "i686-linux-gnu/PhotoPage.c", line=4621, func=0x83b1b80 "editing_host_page_display_copy_of", expr=0x83b0f83 "_tmp1_ != NULL") at /build/buildd/glib2.0-2.30.0/./glib/gtestutils.c:1436
 editing_host_page_display_copy_of (self=0xa6dc0b0, controller=0xa73b1a8, starting_photo=0xa4bcc48) at i686-linux-gnu/PhotoPage.c:4621
 library_photo_page_display_for_collection (self=0xa6dc0b0, return_page=0xa7de000, photo=0xa4bcc48, view=0x0) at i686-linux-gnu/PhotoPage.c:9649
 library_window_switch_to_photo_page (self=0xa72c018, controller=0xa7de000, current=0xa4bcc48) at i686-linux-gnu/library/LibraryWindow.c:4528

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in shotwell (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Revision history for this message
Clint Rogers (clinton-yorba) wrote : Re: shotwell crashed with SIGABRT in __kernel_vsyscall()

Hi, and thank you for taking time to report this to us. I've filed a bug on our side; please see http://redmine.yorba.org/issues/4199.

Does this happen every time you open Shotwell now, or did it only happen once? Also, if you feel comfortable doing so, can you send us a copy of your photo database? (You can find it in your home directory in .shotwell/data/).

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

It happened only once. After I reported this bug I opened Shotwell again and clicked on "Missing Files" again, thumbnails appeared, no crash happened. Then I have clicked "Mark All" and after that "Remove from library" in the "Edit" menu, to get rid of the stale photo entries. Probably I have also removed the cause of the crash with that. Should I still send my photo database?

Revision history for this message
Clint Rogers (clinton-yorba) wrote :

If the crash is no longer occurring, this might not be needed.

Between the deletion and the assertion I spotted in Stacktrace.txt, I believe we have enough clues to investigate further at this point.

In the meantime, if you do happen to perform roughly the same sequence of actions (delete images via the filesystem, launch Shotwell, have it die when trying to look at the missing photo page) and get the same crash, please let us know and have a copy of the db at that point.

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

I have done the same steps again, on the same computer, and it did not crash this time.

summary: - shotwell crashed with SIGABRT in __kernel_vsyscall()
+ shotwell crashed with SIGABRT in editing_host_page_display_copy_of():
+ "_tmp1_ != NULL"
Revision history for this message
dino99 (9d9) wrote :

This version has expired long time ago, and is no more supported

Changed in shotwell (Ubuntu):
status: New → Invalid
Revision history for this message
PeterPall (peterpall) wrote :

Just got this problem with Ubuntu Yakkety. At least apport tells me that the crash I get is this problem. All I have to do in order to make shotwell crash is to open it (it will use 100% of one CPU and output warnings apparently about having problems with thumbnailing videos) and wait for a few hours.

Changed in shotwell (Ubuntu):
status: Invalid → Confirmed
Revision history for this message
Jens Georg (yg-jensge) wrote :

That is a completely different crash to the inital report

Revision history for this message
Jens Georg (yg-jensge) wrote :

Er sorry, mixed up launchpad reports

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers