Shotwell does not pick up on Android pictures properly.

Bug #771757 reported by Danté on 2011-04-27
64
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Shotwell
New
Unknown
gPhoto2
Unknown
Unknown
shotwell (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: shotwell

Using an Android device, Shotwell scans the entire directory for pictures. It also picks up pictures used by apps. Whereas it should only pick up pictures taken by the camera and sent by bluetooth.

Considering that there are other camera applications which can also create thier own folders outside of the 'offical' folder. I would suggest Shotwell look for pictures taken by the phone's camera (which is marked by metadata depicting it as such) as well as scanning Bluetooth folders. (Which no apps now create their own versions of) and to ignore all other folders.

As it is right now, Shotwell can pick up and remove pictures from the device which damage or make unusable applications on the phone. Requiring a reinstall of the application.

Lucas Beeler (lucas-yorba) wrote :

This is a known issue, ticketed upstream at: http://trac.yorba.org/ticket/1903

Changed in shotwell:
status: Unknown → New
Changed in shotwell (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Fabián Rodríguez (magicfab) wrote :

It seems this is a gphoto bug + Android DCIM spec implementation being wrong, if I read upstream's report comments right.

Upstream @gphoto:
http://sourceforge.net/tracker/?func=detail&aid=3000202&group_id=8874&atid=108874

Android issue 2960: Camera / DCIM compliance problem:
http://code.google.com/p/android/issues/detail?id=2960

I am raising this to high as Android devices are increasingly common and many replace hand-held cameras now. This problem essentially makes Shotwell import (and others depending on gphoto, I presume) unusable for practical purposes. Shotwell being a core application and given Android devices increasing penetration, this issue will only affect an increasing number of users.

Although there is a proposed fix in Android's code, it won't make it in a practical timeframe (or at all) for most Android phones/devices users (unless perhaps those using CyanogenMod or other modified code). Perhaps Shotwell could implement a configurable preference to only scan certain directories and exclude Thumbnails. I'll comment on that upstream @Shotwell.

Changed in shotwell (Ubuntu):
importance: Low → High
Mario Vukelic (mario-vukelic) wrote :

Nautilus behaves similarly and shows an "Open Shotwell" button in the window of a mounted Android storage - see screenshot. Is this something that would be fixed in Shotwell (if and when it is), or is there need to open a separate bug report for nautilus?

Jim Nelson (yorba-jim) wrote :

If this is fixed in gPhoto (which I hope it will be), then it *could* resolve this problem for both Shotwell and Nautilus. However, I'm unsure if you really want this fixed in Nautilus, as there are good reasons to be able to traverse your Android's entire filesystem and not just its photos. That makes sense in Nautilus, but not in Shotwell.

If, however, we simply fix it in Shotwell with a workaround, then the behavior you see in Nautilus would remain the same (which, as I've said, may be desirable anyway).

Mario Vukelic (mario-vukelic) wrote :

Maybe I wasn't clear: I don't propose to take away Nautilus's ability to traverse the filesystem. I just want it not to show the "Open Shotwell" button. I think Nautilus shows it only for SD cards if they contain images, anyway. Is it better to open a bug report now, referring to this one, or to wait until it's clear whether gPhoto will have a fix?

(OT here, but if Nautilus wants to offer an image browse button whenever it encounters a folder - or an external storage (not limited to SD) - that somewhere contains images, then Shotwell would probably be the wrong tool anyway. Something like eog would work better for this purpose)

Jim Nelson (yorba-jim) wrote :

I see. Yes, that would be a separate bug report for Nautilus.

Mario Vukelic (mario-vukelic) wrote :

I opened bug #860281 for Nautilus.

I can confirm this for MeeGo Harmattan (Nokia N9). It stores its photos in a DCIM directory, but Shotwell scans the entire device content for image files.

Timo Witte (spacefish) wrote :

The button in Nautilus to import photos is fine i think. Because this is the action most users want to perform, if they connect a camera or device with photos on it. (import them to store them).

Shotwell should be fixed to by default only search in DCIM Directories if they are present on a device. (currently traverses the whole FS and gets every image)

Adam Dingle (adam-yorba) wrote :

This has been fixed upstream: Shotwell will now search only the DCIM directory if it is present. The fix is present in 0.11.93 and will be in the upcoming 0.12 release.

Sebastien Bacher (seb128) wrote :

closing the bug since 0.11.93 is in precise

Changed in shotwell (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.