No thumbnails are generated

Bug #682118 reported by Peter Hultqvist on 2010-11-27
46
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Shotwell
New
Unknown
shotwell (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: shotwell

There is no images for thumbnails, only gray.

.shotwell/thumbs contains empty folders.

I have tried to reinstall shotwell but no change.

No other kind of indication of error(no terminal output).

Please let me know if there is anything else I can contribute.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: shotwell 0.7.2-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.35-23.40-generic 2.6.35.7
Uname: Linux 2.6.35-23-generic i686
Architecture: i386
Date: Sat Nov 27 14:54:40 2010
ProcEnviron:
 PATH=(custom, user)
 LANG=sv_SE.UTF8
 SHELL=/usr/bin/zsh
SourcePackage: shotwell

Peter Hultqvist (hultqvist) wrote :
Adam Dingle (adam-yorba) wrote :

Peter,

hm - this is quite unusual. Could you try the following?

1. Delete or rename your ~/.shotwell directory.

2. Start Shotwell like this:

% SHOTWELL_LOG=1 shotwell

3. Import a few photos. Do their thumbnails appear gray this time?

4. Exit Shotwell.

5. Attach the file ~/.cache/shotwell/shotwell.log to this bug report.

Peter Hultqvist (hultqvist) wrote :

For your convenience I ran.
LANG=C SHOTWELL_LOG=1 shotwell

The log is from my current .shotwell folder. I did also try to remove .shotwell and run again, in both cases I got the same outcome:

Previously imported images with missing thumbnails are still missing.
When Importing new images the thumbnails get created.

From the log it appears that shotwell complains about missing thumbnail files but no indication whether it tried to generate new ones, the mentioned original images does exist as they also show in shotwell.

Peter Hultqvist (hultqvist) wrote :
Jim Nelson (yorba-jim) wrote :

Shotwell won't attempt to generate new thumbnails if the thumbnail file is missing. That's something worth considering, however. I've ticketed it here: http://trac.yorba.org/ticket/2889

Regarding the original problem, is there anything unusual about your home directory or the .shotwell directory, i.e. is one or another symlinked onto a different drive, for example?

The log file you attached appears to be from running Shotwell after photos with missing thumbnails have been imported. Can you re-run Shotwell as Adam specified (removing/renaming ~/.shotwell, with SHOTWELL_LOG, etc.) and attaching the log file after exiting Shotwell *without* re-running it? (Shotwell deletes the old log file at each invocation.) That way I can see what's happening during the initial import, when the thumbnails are not being written.

Peter Hultqvist (hultqvist) wrote :

Thank for confirming that thumbnails are not generated if missing, that is basically what this entire bug is about.
I would suggest that thumbnail creation is triggered right where the missing thumbnail error is generated, on demand. Anything at startup should be avoided to prevent a slow startup.

Yes, as I wrote the log is from my current .shotwell folder since that is where the problem occured. Running fresh as you suggested worked without any problem/thumbnails got created.

Removing a thumbnail folder is usually considered a safe action. When I first asked about this issue on askubuntu, http://askubuntu.com/questions/15020/thumbnails-in-shotwell-are-all-gray that is exactly the advice I got.

Omer Akram (om26er) on 2010-12-08
Changed in shotwell (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Changed in shotwell:
status: Unknown → New
Vipul Mathur (vipul) wrote :
Thibault D (thibdrev) wrote :

Yep, I have the same issue, but with another test case :

I wanted a fresh install for 11.10, so this is what I have done:
1. Upgrade to Ubuntu 11.10 (in order to have the same version of shotwell),
2. Save my "./shotwell/data/photo.db" file and install Ubuntu 11.10,
3. Do not save the ".shotwell/thumbs" directory as it takes me more than 500 Mo and I think shotwell will generate it again (!),
4. Install Ubuntu 11.10,
5. Launch Shotwell to initialize the ".shotwell" directory than does not exist yet,
6. Close shotwell,
7. Copy my backup of "photo.db" to the now existing "./shotwell" directory,
8. Open shotwell and discover that the thumbs are not generared !

I think there should be a simple way to back up Shotwell's database.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.