To print in shotwell one has to call an extra dialog for setting the page size

Bug #677575 reported by Till Kamppeter
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Till Kamppeter
Shotwell
Fix Released
Unknown
shotwell (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: shotwell

Photo printing under Linux has many usability issues, as shown in the Blueprint

https://blueprints.launchpad.net/ubuntu/+spec/packageselection-desktop-n-improve-photo-printing

One of them is that in shotwell (and other GNOME photo managers) one has to call an extra dialog ("File" -> "Page Setup") to set the page size (which is not the default size in most cases) before one opens the print dialog to print the photo(s).

This can be fixed with a simple patch which I attach to this bug report.

Changed in shotwell (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
summary: - To print in shot well one has to call an extra dialog for setting the
+ To print in shotwell one has to call an extra dialog for setting the
page size
Revision history for this message
Till Kamppeter (till-kamppeter) wrote :
Revision history for this message
Till Kamppeter (till-kamppeter) wrote :
Changed in shotwell:
status: Unknown → Confirmed
Revision history for this message
Lucas Beeler (lucas-yorba) wrote :

Hi Till,

We're about to review your patch upstream, but at Yorba we generally deal with straight UNIX diff/patch files (i.e., output by "diff" or preferably "svn diff" and patched in with "patch") instead of debdiffs. This is much easier for us, since we have some people who prefer to work on Fedora, etc. So could you please re-submit your patch as a simple diff against the Shotwell source tree? What would be even better is if you could check out the current Shotwell trunk at svn://svn.yorba.org/shotwell/trunk and then svn diff against that. This would allow us get your changes into trunk as soon as possible!

Thanks,
Lucas

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

Lucas Beeler, the pure patch is already attached to the upstream report, http://trac.yorba.org/ticket/2733.

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

Now I have also added the patch based on the SVN trunk to the upstream bug.

Changed in shotwell:
status: Confirmed → Fix Released
Vish (vish)
Changed in hundredpapercuts:
importance: Undecided → Medium
milestone: none → nt6-photo-video
status: New → In Progress
tags: added: patch
Changed in shotwell (Ubuntu):
status: In Progress → Fix Committed
Changed in hundredpapercuts:
status: In Progress → Fix Committed
Revision history for this message
Omer Akram (om26er) wrote :

shotwell 0.8 is now in Natty.

Changed in shotwell (Ubuntu):
status: Fix Committed → Fix Released
Vish (vish)
Changed in hundredpapercuts:
assignee: nobody → Till Kamppeter (till-kamppeter)
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.