Corruption of files on export

Bug #665006 reported by Michael Hendry on 2010-10-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Shotwell
Invalid
Unknown
shotwell (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: shotwell

Description: Ubuntu 10.04.1 LTS
Release: 10.04

shotwell:
  Installed: 0.7.2-1~lucid1
  Candidate: 0.7.2-1~lucid1
  Version table:
 *** 0.7.2-1~lucid1 0
        500 http://ppa.launchpad.net/yorba/ppa/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status
     0.5.0+dfsg-1.1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ lucid/universe Packages

I have been compiling a selection of images of my son since his childhood in preparation for his marriage later this year, but when I exported those I'd tagged I found a number of the exported files were damaged. The original image seems to be present, but overlaid with offset and darker versions.

I have noticed this phenomenon occasionally on viewing images within Shotwell, but the problem seemed to go away spontaneously.

I've also been able to export one of the affected files successfully, and you can view the original, a successfully exported version and the failed version at:

http://rotarycupar.org/download/MG004 rescanned BAD.jpg
http://rotarycupar.org/download/IMG004 rescanned GOOD.jpg
http://rotarycupar.org/download/IMG004 rescanned ORIGINAL.jpg

I haven't done any systematic experiments to pin down this phenomenon - I've been able to work around it - and I'm not certain that I used the same compression setting when I generated the "GOOD" image as when the "BAD" image was exported.

I'd be happy to do some further tests with expert guidance on what to try.

Jim Nelson (yorba-jim) wrote :

To make it easier for other people, I'm reposting the links with URL encoding:

http://rotarycupar.org/download/IMG004%20rescanned%20BAD.jpg
http://rotarycupar.org/download/IMG004%20rescanned%20GOOD.jpg
http://rotarycupar.org/download/IMG004%20rescanned%20ORIGINAL.jpg

Also (since this might be a factor) can you tell me what parameters you used to export this file (size, quality, etc.)?

Thanks,

-- Jim

Omer Akram (om26er) wrote :

setting incomplete since information was requested.

Changed in shotwell (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
Changed in shotwell:
status: Unknown → New

On Fri, 2010-10-22 at 18:53 +0000, Jim Nelson wrote:
> To make it easier for other people, I'm reposting the links with URL
> encoding:
>
> http://rotarycupar.org/download/IMG004%20rescanned%20BAD.jpg
> http://rotarycupar.org/download/IMG004%20rescanned%20GOOD.jpg
> http://rotarycupar.org/download/IMG004%20rescanned%20ORIGINAL.jpg
>
> Also (since this might be a factor) can you tell me what parameters you
> used to export this file (size, quality, etc.)?
>
> Thanks,
>
> -- Jim
>
> ** Bug watch added: trac.yorba.org/ #2717
> http://trac.yorba.org/ticket/2717
>
> ** Also affects: shotwell via
> http://trac.yorba.org/ticket/2717
> Importance: Unknown
> Status: Unknown
>

Jim,

If I remember correctly, the first export of these files was with size
limited to 1200 and quality of 100%.

I've tried these parameters again, without reproducing the problem, so I
tried 90%, again with negative results.

I'm sure I didn't use 75% first time round, but this time the export of
all 46 files yielded one corrupt file - this time from a different
original.

I deleted all the exported files and tried again with settings of 1200
and 75%, and got this error message:

"Unable to export the following photo due to a file error.

/home/michael/DebugShotwell/IMG005 rescanned.jpg

Would you like to continue exporting?"

I said yes, and this time the previous file was exported correctly, and
although a file was apparently exported for "IMG005 rescanned.jpg", it
wasn't readable as a jpg.

Here are links to the set of files...

http://www.rotarycupar.org/download/IMG012%20rescanned%20BAD.jpg
http://www.rotarycupar.org/download/IMG012%20rescanned%20GOOD.jpg
http://www.rotarycupar.org/download/IMG012%20rescanned%20ORIGINAL.jpg

...this time with proper URLs!

Having cleared the export directory I tried again, and this time I got
warnings of file errors (as in the error message above) about two
completely different files, both of which had previously been
successfully exported.

At the next attempt, all files were successfully exported.

So the problem occurs frequently, but (so far) not reliably
reproducible.

Regards,

Michael

Sebastien Bacher (seb128) wrote :

is that still an issue with newer versions?

Changed in shotwell (Ubuntu):
status: Incomplete → Triaged
importance: Medium → Low
Michael Hendry (hendry-michael) wrote :

On Tue, 2011-04-05 at 11:45 +0000, Sebastien Bacher wrote:
> is that still an issue with newer versions?
>
> ** Changed in: shotwell (Ubuntu)
> Status: Incomplete => Triaged
>
> ** Changed in: shotwell (Ubuntu)
> Importance: Medium => Low
>

I've gone through the same export sequence several times, and haven't
managed to reproduce the fault in Shotwell 0.9.0.

Unfortunately, it was an intermittent fault with the older versions, so
I can't be absolutely sure it's fixed.

Incidentally, the problem with duplicate filenames is still there. I
think the files are processed in the order chosen in View=>Sort Photos,
and if there is more than one file with the same name, the last one
processed appears to be the only one which is exported. Many of my
images are scanned negatives, named IMG001.jpg, IMG002.jpg etc to
correspond with the number of the negative, and separated into an
individual folder for each film (./1960-01, ./1960-02 etc).

I'll see if I can find my original complaint about this fault, and mark
it as still being there.

Adam Dingle (adam-yorba) wrote :

I've marked the upstream ticket as worksforme since Michael has said he can't reproduce this in Shotwell 0.9 and since we have enough to do trying to fix the bugs we *can* reproduce. :) If this rears its head again then we can certainly reopen.

Changed in shotwell:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.