Ubuntu

Rename option "Mirror" to "Flip Horizontally"

Reported by Vish on 2010-06-10
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Unassigned
Shotwell
Fix Released
Unknown
shotwell (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: shotwell

The option Photo > Mirror is an odd name for a "Flip Horizontal" option.

In EOG and other Image editors [GIMP, Inkscape] the option is named "Flip Horizontal" .
Even the standard icon name is "object-flip-horizontal".
Re-naming the option would help maintain consistency within an operating system.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: shotwell 0.5.0+dfsg-1.1
Uname: Linux 2.6.34-020634-generic i686
Architecture: i386
Date: Thu Jun 10 19:34:20 2010
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20091209)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: shotwell

Vish (vish) wrote :
Vish (vish) on 2010-06-10
summary: - Rename option "Mirror" to "Flip horizontal"
+ Rename option "Mirror" to "Flip Horizontal"
description: updated
Changed in hundredpapercuts:
importance: Undecided → Low
milestone: none → maverick-round-5-photo-management
Changed in shotwell (Ubuntu):
importance: Undecided → Wishlist
Adam Dingle (adam-yorba) wrote :

We just discussed this briefly on the Shotwell team at Yorba. Although we appreciate your desire for user interface consistency between applications, we've decided to keep the Mirror name for now. We think it's clear enough what it does (it produces a mirror image) and we like the fact that it's more concise than Flip Horizontal.

Vish (vish) wrote :

Not only is it different/inconsistent in Ubuntu [Linux OS] , I'v looked at other image editors/photo managers in other platforms , but none of them name the "Flip Horizontal" option as "Mirror" :
http://picasa.google.com/support/bin/answer.py?hl=en&answer=39035
http://help.adobe.com/en_US/photoshop/cs/using/WSfd1234e1c4b69f30ea53e41001031ab64-7638a.html
http://office.microsoft.com/en-us/help/HP062473301033.aspx
http://office.microsoft.com/en-us/frontpage-help/rotate-or-flip-a-graphic-HP005261159.aspx?CTT=1

Further, some editors have an effect called "Mirror effect" :
http://www.photoshopessentials.com/photo-effects/mirror-image/
http://www.adobe.com/designcenter/photoshop/articles/phs8mirror.html
Which can be even more confusing.

Additionally , mirroring an image doesnt specify the direction. [default gnome config is to not have any icons in the menu, so the flip direction will not be clear]
As you can see from the above mirror effects , the mirror effect can be either horizontal or vertical.
To make it clearer it needs to named "Mirror Horizontal" , still an odd name.

It is not clear what the benefit is in using the current shortened name"Mirror".
We are not saving the menu width by shortening the name , even if the option is moved to the edit menu , "Revert to original" is longer.And in the current "Photos" menu there are atleast 4 options which are longer.

It is better if the option was named "Flip Horizontal" , which almost every end-user will be able to associate with quicker.

Changed in hundredpapercuts:
status: New → Confirmed
Vish (vish) wrote :

Confirming bug since this is a known issue.

Changed in shotwell (Ubuntu):
status: New → Confirmed
Roman A. Taycher (rtaycher) wrote :

I like Mirror but if we are changing it Flip Horizontally is better then Flip Horizontal.

Kai Tamkun (ktamkun) wrote :

<rant>
I agree with Roman. I know it'd be difficult to change or at least difficult to get other project devs to change it, but it'd be better to have an adverb instead of an adjective. "He awkward spoke." Is that the kind of sentence you like? No, but it's equivalent to "Flip Horizontal."
</rant>

Tiago Silva (tiagosilva) wrote :

To me, "Mirror" by itself means absolutely nothing.
'Mirror' or 'Flip' is a transformation using a reference axis of a picture (even two, depending on the implementation).
The direction must be known before application.

+1 for the "Flip Horizontally" string

Changed in shotwell (Ubuntu):
assignee: nobody → Joel Auterson (joel-auterson)
Changed in shotwell (Ubuntu):
assignee: Joel Auterson (joel-auterson) → nobody
Vish (vish) wrote :

Joel Auterson , you can leave the papercut task assigned to yourself :)

Changed in hundredpapercuts:
assignee: nobody → Joel Auterson (joel-auterson)
Adam Dingle (adam-yorba) wrote :

We at Yorba have reconsidered, and have decided to rename the menu items to Flip Horizontally and Flip Vertically:

http://trac.yorba.org/ticket/2223

This will happen for 0.7. No need for you guys to create a special branch. :)

Vish (vish) wrote :

> Adam Dingle wrote:
> We at Yorba have reconsidered, and have decided to rename the menu items
> to Flip Horizontally and Flip Vertically:
>
> http://trac.yorba.org/ticket/2223
>
> This will happen for 0.7. No need for you guys to create a special
> branch. :)
>

Neat! Thanks. And 0.7 is expected to be in Maverick?

summary: - Rename option "Mirror" to "Flip Horizontal"
+ Rename option "Mirror" to "Flip Horizontally"
Changed in shotwell (Ubuntu):
status: Confirmed → Triaged
Changed in hundredpapercuts:
status: Confirmed → Triaged
Vish (vish) wrote :

@Adam Dingle : FWIW , I'v asked the docs team as to which is more preferable too [ Horizontal/Horizontally ] , and they mentioned:
Flip Horizontally , Flip Vertically is better . Even though a few others apps use Horizontal/Vertical

Bruno Girin (brunogirin) wrote :

@Vish: yes, 0.7 is expected to be in Maverick.

Changed in shotwell:
status: Unknown → New
Changed in shotwell:
status: New → Fix Released
Vish (vish) wrote :

This has now been fixed Upstream.

Joel Auterson , thanks for working on the Branch.

Changed in hundredpapercuts:
assignee: Joel Auterson (joel-auterson) → nobody
status: Triaged → Fix Committed
Changed in shotwell (Ubuntu):
status: Triaged → Fix Committed
Vish (vish) wrote :

This was fixed in update:

shotwell (0.6.90-0ubuntu1) maverick; urgency=low

  * New upstream release
 -- Robert Ancell <email address hidden> Wed, 11 Aug 2010 09:10:03 +1000

Changed in shotwell (Ubuntu):
status: Fix Committed → Fix Released
Changed in hundredpapercuts:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.