SRU the current 0.30.10 stable version

Bug #1882952 reported by Sebastien Bacher on 2020-06-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
shotwell (Ubuntu)
Low
Unassigned
Focal
Undecided
Unassigned

Bug Description

* Impact

The update is an upstream bugfix one, including translations updates and fixes to youtube's publishing

* Test case

Import photos, make sure than browsing and tagging works as expected

* Regression potential

Check that publishing content to a youtube account works correctly since there were fixes in the corresponding sources

The translations are going to slightly regress but it's needed to be compliant with the service and translations updates will be part of the next language pack refresh

Sebastien Bacher (seb128) wrote :
Changed in shotwell (Ubuntu):
importance: Undecided → Low
status: New → Fix Released
Jens Georg (yg-jensge) wrote :

Please not that this will lose you most of the translations for the Google-related log-in screens (Photos and YouTube). but making them compliant with Google's requirements is one of the major points of that update

Sebastien Bacher (seb128) wrote :

Thanks Jens, indeed that's unfortunate but we should probably take the update to be compliant with the service anyway. I've updated the SRU description to mention the issue now

description: updated

Hello Sebastien, or anyone else affected,

Accepted shotwell into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/shotwell/0.30.10-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in shotwell (Ubuntu Focal):
status: New → Fix Committed
tags: added: verification-needed verification-needed-focal
Sebastien Bacher (seb128) wrote :

Testing 0.30.10-0ubuntu0.1 works without (new) issue. Importing photos, browsing a collection, login to youtube for publishing.

The actual video publishing to youtube failed on quote error but the focal version does the same, unsure if the issue is the API key and number of users or with the account used for publishing

the error printed on the standard output

Authentification requise : {
  "error": {
    "code": 403,
    "message": "The request cannot be completed because you have exceeded your \u003ca href=\"/youtube/v3/getting-started#quota\"\u003equota\u003c/a\u003e.",
    "errors": [
      {
        "message": "The request cannot be completed because you have exceeded your \u003ca href=\"/youtube/v3/getting-started#quota\"\u003equota\u003c/a\u003e.",
        "domain": "youtube.quota",
        "reason": "quotaExceeded",
        "debugInfo": "Code: 8; Description: ?metric=youtube.googleapis.com/default&limit=defaultPerDayPerProject&qs_error_code=INSUFFICIENT_TOKENS"
      }
    ]
  }
}

defaultPerDayPerProject suggests it's probably a shotwell prohect key limit ... Jens, is that a known issue upstream? should I open a bug on gitlab for it?

It's also worth noting that the UI states that the publish succeded while the error is printed on the command line and the video isn't available online

tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal
Jens Georg (yg-jensge) wrote :

Yes, the overall daily quota of 100k points is exceeded. Not much I can do at the moment. But please file a ticket regarding the poor user experience, this should be clearly visible in the UI

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package shotwell - 0.30.10-0ubuntu0.1

---------------
shotwell (0.30.10-0ubuntu0.1) focal; urgency=medium

  * New stable version (lp: #1882952)
  * debian/patches/git_warnings_build.patch:
    - removed, fixed in the new version

 -- Sebastien Bacher <email address hidden> Wed, 10 Jun 2020 15:18:36 +0200

Changed in shotwell (Ubuntu Focal):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for shotwell has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers