Shotwell does not save comments to photo reliably

Bug #1746093 reported by remerson on 2018-01-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
shotwell (Ubuntu)
Undecided
Unassigned

Bug Description

Hello,

If I go to an Event and then choose a photo e.g. IMG_20180110_111615448.jpg right click "Edit Comment" then type in some comment "Foo" and press the "Save" button the comment text appears as I expect in the "Extended Information" view.

However, if I then close Shotwell and re-open it, when I go back to the same image, the comment is empty. Shotwell has "lost" comment I made.

This doesn't seem to happen reliably to just certain images. Some images in the event do save their comments and appear when I re-open, others don't. There doesn't appear to be much of a pattern.

It's quite disappointing though to add a lot of comments to many images in an editing session to then find the next day that half of these have randomly disappeared.

Any idea what's going on here and how can I help someone fix this?

Thanks.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: shotwell 0.22.0+git20160108.r1.f2fb1f7-0ubuntu1.1
ProcVersionSignature: Ubuntu 4.13.0-32.35~16.04.1-generic 4.13.13
Uname: Linux 4.13.0-32-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.15
Architecture: amd64
CurrentDesktop: XFCE
Date: Mon Jan 29 20:39:09 2018
EcryptfsInUse: Yes
InstallationDate: Installed on 2015-03-14 (1052 days ago)
InstallationMedia: Xubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64 (20150218.1)
SourcePackage: shotwell
UpgradeStatus: Upgraded to xenial on 2017-12-02 (58 days ago)

remerson (ubuntu-remerson) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers