Fujifilm X-T10 regression on 17.10: "Unable to fetch previews from the camera: Unspecified error (-1)"

Bug #1731341 reported by Aaron Whitehouse on 2017-11-09
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
libgphoto2 (Ubuntu)
High
Unassigned
shotwell (Ubuntu)
High
Unassigned

Bug Description

I have a Fujifilm X-T10. This worked perfectly in Shotwell in 17.04. Since upgrading to 17.10, I receive an error whenever I try to import photos:
Unable to fetch previews from the camera: Unspecified error (-1)

lsusb gives:

    Bus 001 Device 010: ID 04cb:02c8 Fuji Photo Film Co., Ltd

dmesg gives:

    [ 585.129167] usb 1-2: new high-speed USB device number 10 using xhci_hcd
    [ 585.269979] usb 1-2: New USB device found, idVendor=04cb, idProduct=02c8
    [ 585.269980] usb 1-2: New USB device strings: Mfr=0, Product=2, SerialNumber=3
    [ 585.269981] usb 1-2: Product: USB PTP Camera
    [ 585.269981] usb 1-2: SerialNumber: 59353130303416092266F93011BFE6

This looks like the same issue reported in Ask Ubuntu (with no answer) here:
https://askubuntu.com/questions/972613/usb-ptp-camera-no-longer-working-after-upgrade-to-17-10

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: shotwell 0.26.3-1ubuntu1
ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
Uname: Linux 4.13.0-16-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.7-0ubuntu3.1
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Thu Nov 9 21:36:30 2017
EcryptfsInUse: Yes
InstallationDate: Installed on 2016-07-03 (494 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
SourcePackage: shotwell
UpgradeStatus: Upgraded to artful on 2017-10-29 (11 days ago)

Related branches

Jens Georg (yg-jensge) wrote :

Hi,

please try to log out of your desktop environment and call gphoto2 -T. If that also fails, there is a regression with gphoto2. A similar issue was also reported on Fedora upstream.

$ gphoto2 -T

*** Error ***
An error occurred in the io-library ('Unspecified error'): No error description available
*** Error (-1: 'Unspecified error') ***

For debugging messages, please use the --debug option.
Debugging messages may help finding a solution to your problem.
If you intend to send any error or debug messages to the gphoto
developer mailing list <email address hidden>, please run
gphoto2 as follows:

    env LANG=C gphoto2 --debug --debug-logfile=my-logfile.txt -T

Please make sure there is sufficient quoting around the arguments.

===
$ env LANG=C gphoto2 --debug --debug-logfile=my-logfile.txt -T

*** Error ***
An error occurred in the io-library ('Unspecified error'): No error description available
*** Error (-1: 'Unspecified error') ***

nathan (nathan95-b) on 2017-11-12
Changed in gphoto2 (Ubuntu):
status: New → Confirmed
Changed in shotwell (Ubuntu):
status: New → Confirmed

Marcus has said in the upstream bug:
"I released 2.5.16 some weeks ago.

the commit fixing this issue for backporting is 472a9461b457b4d08ecf10a93bb7f1efdc2124c0 "

It would be excellent if this could please make its way into Ubuntu.

asala (asala) wrote :

Just adding that this also affects Fujifilm X-T20, for easier finding of this thread by owners of this model googling around (which was to be expected as it is a close cousin of X-T2).

Sebastien Bacher (seb128) wrote :

The new libgphoto2 which includes the fix has been uploaded to the current serie
https://launchpad.net/ubuntu/+source/libgphoto2/2.5.16-1

That fix is probably worth a SRU for 17.10 as well if somebody wants to work on that (https://wiki.ubuntu.com/StableReleaseUpdates)

affects: gphoto2 (Ubuntu) → libgphoto2 (Ubuntu)
Changed in libgphoto2 (Ubuntu):
importance: Undecided → High
status: Confirmed → Fix Committed
Changed in shotwell (Ubuntu):
importance: Undecided → High
status: Confirmed → Invalid
wrapperband (drajdoyle) wrote :

It's a shame this fix did not get through to 17.10, it effects a number of cameras.

I'm crossing my fingers, is it fixed in 18.04?.

Sebastien Bacher (seb128) wrote :

The issue is fixed in 18.04 indeed

Changed in libgphoto2 (Ubuntu):
status: Fix Committed → Fix Released
wrapperband (drajdoyle) wrote :

The "issue" has not been fixed in 18.04 - or it has been fixed and broke something else or it was fixed in a not working way.

When you try to copy files it now goes ahead and then skips every photo with

unknown error
unknown camera

I am gutted, this fault needs an internal review to see why it keeps happening ....

wrapperband (drajdoyle) wrote :

I may have fixed it, I'll post a separate bug if it remains after further investigation.

Sebastien Bacher (seb128) wrote :

the issue there is fixed in 18.04, if you still have problems better to open a new report

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers