New release 0.26.3

Bug #1710270 reported by Cristian Aravena Romero on 2017-08-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
shotwell (Ubuntu)
Undecided
Unassigned

Bug Description

Hello,

https://git.gnome.org/browse/shotwell/log/?h=shotwell-0.26

Regards,
--
Cristian

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: shotwell (not installed)
Uname: Linux 4.13.0-041300rc4-generic x86_64
ApportVersion: 2.20.6-0ubuntu4
Architecture: amd64
CurrentDesktop: GNOME
Date: Fri Aug 11 14:53:29 2017
InstallationDate: Installed on 2017-07-05 (36 days ago)
InstallationMedia: Ubuntu-GNOME 17.04 "Zesty Zapus" - Release amd64 (20170412)
SourcePackage: shotwell
UpgradeStatus: Upgraded to artful on 2017-07-05 (36 days ago)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package shotwell - 0.26.3-1ubuntu1

---------------
shotwell (0.26.3-1ubuntu1) artful; urgency=medium

  * Sync with Debian git packaging (LP: #1710270). Remaining changes:
    - debian/control, debian/rules:
      + Build-depend on and run dh-translations
      + Build with Unity support.
      + Build-Depends on libunity-dev.
      + Build with scour for SVG optimization.
      + Build-Depends on python-scour.
    - clean out thumbnailer hacks, that's not user friendly and not
      something that should be recommended doing
    - Don't clutter up debian/ with old, disabled patches
  * Drop Ubuntu's autopkgtest since the required umockdev data hasn't been
    updated for 5 months.
  * Fix Breaks/Replaces for file move
  * Add 0001-appstream.patch and modify shotwell.install:
    - Fix install of appstream metadata

shotwell (0.26.3-1) unstable; urgency=medium

  * New upstream release (Closes: #855681, Closes: #841859).
    - debian/control: Add new appstream-util, libappstream-glib-dev and
      libgdata-dev to Build-Depends.
    - debian/shotwell.install: Drop now empty directory usr/share/appdata.
  * New README.source to explain the branching model used.
  * Use the automatic debug symbol packages:
    - Remove shotwell-dbg section from debian/control.
    - Remove override_dh_strip, override_dh_compress and some lines
      on dh_install from debian/rules.
    - Remove debian/shotwell-dbg.README.Debian.
  * Use the upstream ChangeLog as changelog and add NEWS to docs.
  * Remove debian/shotwell.1 to use the upstream man page.
  * Don't install man page at shotwell-common.
  * Remove unnecessary debian/menu.
  * Some packaging improvements (Closes:# 856708):
    - Move .desktop and appstream metadata from shotwell-common to shotwell.
    - debian/rules:
      + Use dh_auto_configure instead of ./configure.
      + Update rm paths for multiarch.
      + Don't install the .a file either.
    - Remove build-depend m4 since debhelper version 10 use autoconf.
    - Thanks to Jeremy Bicha <email address hidden>
  * debian/watch:
    Rewrite to find only stable releases.
  * Declare compliance with Debian Policy 4.0.0. (No changes needed).

 -- Jeremy Bicha <email address hidden> Fri, 22 Sep 2017 17:26:18 -0400

Changed in shotwell (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers