scrolling through many photos breaks the view

Bug #1606491 reported by Michael Zanetti on 2016-07-26
46
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Shotwell
Fix Released
Medium
shotwell (Ubuntu)
High
Unassigned
Bionic
Undecided
Unassigned

Bug Description

* Impact
Sometimes when scrolling in a photo collection the view becomes white and shotwell needs to be restarted

* Test case
No specific steps, but it seems that scrolling on a big collection sometime trigger the issue. It seems more likely on a 4k display. Scroll on a big collection, it should keep working

* Regression potential
Nothing special, make sure that scrolling works without visual artifacts.

---------------------------

Having some couple of thousand pictures in the photo library, scrolling through them with shotwell makes the picture view just go white. Shotwell needs to be restarted in order to recover. See attached video.

This is printed in the log:

(shotwell:9274): Gtk-WARNING **: drawing failure for widget `CheckerboardLayout': out of memory

(shotwell:9274): Gtk-WARNING **: drawing failure for widget `GtkViewport': out of memory

(shotwell:9274): Gtk-WARNING **: drawing failure for widget `LibraryMainPage': out of memory

(shotwell:9274): Gtk-WARNING **: drawing failure for widget `GtkNotebook': out of memory

(shotwell:9274): Gtk-WARNING **: drawing failure for widget `GtkBox': out of memory

(shotwell:9274): Gtk-WARNING **: drawing failure for widget `GtkPaned': out of memory

Michael Zanetti (mzanetti) wrote :
Michael Zanetti (mzanetti) wrote :

I have verified that the machine is not out of memory. It has 8GB of RAM and another 8GB of swap space which is not even touched yet.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in shotwell (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :
Changed in shotwell (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Changed in shotwell:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in shotwell:
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :

the issue has been fixed in upstream git

Changed in shotwell (Ubuntu):
status: Triaged → Fix Committed
Sebastien Bacher (seb128) wrote :

The issue is fixed in the current cosmic version

description: updated

Hello Michael, or anyone else affected,

Accepted shotwell into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/shotwell/0.28.4-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in shotwell (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Sebastien Bacher (seb128) wrote :

Using GDK_SCALE the bionic version hit that bug, no problem when using 0.28.4-0ubuntu1

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic

The verification of the Stable Release Update for shotwell has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package shotwell - 0.28.4-0ubuntu1

---------------
shotwell (0.28.4-0ubuntu1) bionic; urgency=medium

  * New bugfix update (lp: #1802895)
    - Fix "Out of memory" issues when scrolling through large collections
      (lp: #1606491)
  * debian/patches/git_notifications_segfault.patch:
    - direct: Fix crash when dismissing modifications (lp: #1723181)

 -- Sebastien Bacher <email address hidden> Mon, 12 Nov 2018 11:43:31 +0100

Changed in shotwell (Ubuntu Bionic):
status: Fix Committed → Fix Released
Changed in shotwell (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.