Crash on edit with external editor, results in corrupt image database entry

Bug #1511914 reported by Janne Moren on 2015-10-31
32
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Shotwell
Unknown
Unknown
shotwell (Ubuntu)
High
Unassigned
Xenial
High
Unassigned

Bug Description

Select "edit with external editor". The image opens in Gimp, but Shotwell crashes. Save the image, open shotwell (order doesn't matter).

* The image thumbnail doesn't change proportions to the edited image, resulting in squashed image. And rotated images lose their rotation information on screen. The underlying edited image is unaffected. This happens only with images edited with the crash above; previous images are fine.

* I am unable to permanently change associated data such as the grade/stars. Once I quite Shotwell those changes are gone. Again, this affects only images edited as above.

* This happened with the update to Wily Werewolf (Shotwell 0.22.0-Ubuntu5). Previous Shotwell version in Vivid was fine.

Janne Moren (jan-moren-gmail) wrote :

Tried to run Shotwell under gdb. Couldn't get it to produce a trace.

Janne Moren (jan-moren-gmail) wrote :
description: updated
Janne Moren (jan-moren-gmail) wrote :

Added info: If I first do an edit - any edit - using Shotwell itself so that it creates a changed file on disk, I can then edit the image with an external editor without problems.

So the issue seems to be connected to creating an editable copy of the image when triggering the action by using an external editor. Or possibly by using gimp, specifically, as the external editor?

Gertjan (gertjan-hofman) wrote :

Same problem seen here on Wily. Unable to open external editor without shotwell crashing. But I can even trigger a complete log-out ( x11 crash ?) ) with this operation, if I repeat a few times. Worked fine in Vivid.

Sebastien Bacher (seb128) wrote :

The stacktrace indicates the issue is due to the code not handling correctly the new glib file monitor events

Changed in shotwell (Ubuntu):
importance: Undecided → High
tags: added: rls-x-incoming
Will Cooke (willcooke) on 2015-11-23
tags: removed: rls-x-incoming
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in shotwell (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

That has been reported upstream as well, https://bugzilla.gnome.org/show_bug.cgi?id=759403

Janne Moren (jan-moren-gmail) wrote :

Any way I can help fix this? Shotwell is completely unusable now.

Amr Ibrahim (amribrahim1987) wrote :

It is fixed upstream.

Amr Ibrahim (amribrahim1987) wrote :
tags: added: xenial
Amr Ibrahim (amribrahim1987) wrote :

Please update Shotwell to fix this bug.

Øyvind Stegard (oyvinst) wrote :

Any chance the fix will be backported to Shotwell in 16.04 ?

John Ladasky (john-ladasky) wrote :

This bug has appeared for me in just the past week. I upgraded to Ubuntu GNOME 17.04 several months ago and have used Shotwell a few times. I was able to click "edit with external editor" without Shotwell closing... at first.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.