Cannot publish to Facebook

Bug #1453549 reported by Daniel Dionne on 2015-05-10
88
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Shotwell
Fix Released
High
webapps-sprint
High
Alberto Mardegan
shotwell (Ubuntu)
High
Unassigned
Trusty
High
Unassigned
Vivid
High
Unassigned

Bug Description

* Impact
the facebook integration doesn't work anymore because the current key has the right permissions (and is owned by mia upstreams)

* Test case
try to publish photo to facebook

* Regression potential
the change impacts only the facebook key id

-----------------

Whenever I try to publish to facebook I get the error:

"You have already logged in and out of Facebook during this Shotwell session. To continue publishing to Facebook, quit and restart Shotwell, then try publishing again."

No matter how many times I try this it happens,

I start shotwell, select the pics to publish, File - Publish, login into Facebook, then choose options and choose publish and the error appears. Happens everytime I do it.

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in shotwell (Ubuntu):
status: New → Confirmed
ChrisH (tipichris) wrote :

I have the same problem. I've tried removing Shotwell from the list of apps authorised for Facebook and then reauthorising and Shotwell doesn't seem to request posting permission.

ChrisH (tipichris) wrote :

Should add I'm using 0.20.2, being the latest version in the yorba PPA for Trusty.

Matt Raines (matt-raines) wrote :

I'm getting the same error in 0.22.0 from the yorba PPA on Vivid.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, what version of Ubuntu and shotwell are you using?

Changed in shotwell (Ubuntu):
importance: Undecided → High
status: Confirmed → Incomplete
Sebastien Bacher (seb128) wrote :

similar to https://bugzilla.gnome.org/show_bug.cgi?id=748847 and likely something that changed on the facebook side that requires change in shotwell

Alberto Mardegan (mardy) on 2015-05-19
Changed in shotwell (Ubuntu):
assignee: nobody → Alberto Mardegan (mardy)
Alberto Mardegan (mardy) wrote :

I can reproduce the bug as well. I'll have a look, it may be that we need to change something in order to use the new Facebook APIs.

Changed in shotwell:
importance: Unknown → Medium
status: Unknown → Confirmed
David Barth (dbarth) on 2015-05-20
Changed in webapps-sprint:
milestone: none → sprint-9
milestone: sprint-9 → sprint-10
Alberto Mardegan (mardy) wrote :

Adding logs. It seems that we correctly get an access token from Online Accounts (we are able to get the user information), but the album creation fails. This might be due to the access token have insufficient permissions or to the publishing code itself needed some update. I'll debug this further.

Changed in shotwell (Ubuntu):
status: Incomplete → Confirmed
Alberto Mardegan (mardy) wrote :

I confirm this bug on vivid, shotwell 0.20.2-0ubuntu3.

Alberto Mardegan (mardy) wrote :

I'm back with more information.

The shotwell code is correct, as far as I can tell. The reason why it's failing is because the access token it gets only carries the permissions to see the public profile, and not the permissions to publich photos or videos. Why this happens, I'm not sure.

My guess is that the Shotwell application in not properly registered in the Facebook servers to comply with the v2.0 API. As far as I know, only Yorba has access to that key, so there isn't much we can do about it.

I've tried playing with the authorization URL (note: you should first remove Shotwell from your profile at https://www.facebook.com/settings?tab=applications):

https://www.facebook.com//dialog/oauth?client_id=162702932093&redirect_uri=https://www.facebook.com/connect/login_success.html&response_type=token&scope=publish_actions,user_photos,user_videos
 and it seems that it always ignores the permissions ("scope" parameter) we request.

Incidentally, I discovered a bug in our Online Accounts integration with Shotwell, which causes the application to retry the authentication forever when the access to the application is revoked from the facebook site. The attached branch fixes this.

Sebastien Bacher (seb128) wrote :

Thanks Alberto!

Jeremy Nickurak (nickurak) wrote :

See also: https://bugzilla.gnome.org/show_bug.cgi?id=748991

FWIW, I also hit this under Fedora 21 with shotwell-0.20.2-2.fc21.x86_64

David Barth (dbarth) on 2015-05-27
Changed in webapps-sprint:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Alberto Mardegan (mardy)
Changed in shotwell (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package shotwell - 0.22.0-0ubuntu4

---------------
shotwell (0.22.0-0ubuntu4) wily; urgency=medium

  * Update autopilot test recorded ioctls for libgphoto 2.5.7.

 -- Martin Pitt <email address hidden> Wed, 27 May 2015 16:05:56 +0200

Changed in shotwell (Ubuntu):
status: Fix Committed → Fix Released
Daniel Dionne (ldshifftyone) wrote :

I installed shotwell (0.22.0-0ubuntu4) and now it doesn't have the option to publish to facebook although facebook is listed under plugins in the preferences.

Daniel Dionne (ldshifftyone) wrote :

I am using Linux Mint 17.1 Mate

Sebastien Bacher (seb128) wrote :

the error handling has been fixed but not the upstream key issue, which is something only the shotwell team can resolve

Changed in shotwell (Ubuntu):
status: Fix Released → Confirmed
assignee: Alberto Mardegan (mardy) → nobody
David Barth (dbarth) on 2015-06-15
Changed in webapps-sprint:
milestone: sprint-10 → sprint-11
nairbv (nairbv) wrote :

same issue, 0.20.1, LMDE 2 Betsy \n \l

Same issue, 0.18.0 - any news from Yorba?

TomasHnyk (sup) wrote :

Messages in mailing list go unresponded (but I guess anothe rone would not hurt) : https://mail.gnome.org/archives/shotwell-list/2015-June/thread.html and most got commits recently have just been translations updates: https://git.gnome.org/browse/shotwell/log/ - I think Shotwell is sadly on brink of being an abandonware (Geary, the new flagship product looks more alive, even though there are not that many commits either: https://git.gnome.org/browse/geary/log/ )

PasQty (pas-i) on 2015-08-02
tags: added: shotwell
tags: added: facebook
Changed in shotwell:
status: Confirmed → Invalid
TomasHnyk (sup) on 2015-08-18
Changed in shotwell:
importance: Medium → Unknown
status: Invalid → Unknown
Changed in shotwell:
importance: Unknown → High
status: Unknown → Confirmed
David Barth (dbarth) on 2015-09-21
Changed in webapps-sprint:
milestone: sprint-11 → sprint-14
David Barth (dbarth) on 2015-10-05
Changed in webapps-sprint:
milestone: sprint-14 → sprint-15
David Barth (dbarth) on 2015-10-08
Changed in webapps-sprint:
milestone: sprint-15 → none
status: Confirmed → Fix Released
TomasHnyk (sup) wrote :

What, is this fixed?

Alberto Mardegan (mardy) wrote :

No, not completely. Note that the status on the Shotwell project is still "confirmed".

Changed in shotwell (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package shotwell - 0.22.0-0ubuntu5

---------------
shotwell (0.22.0-0ubuntu5) wily; urgency=medium

  * debian/patches/06_uoa.patch:
    - use new facebook ID, thanks Alberto Mardegan (lp: #1453549)

 -- Sebastien Bacher <email address hidden> Fri, 09 Oct 2015 11:11:18 +0200

Changed in shotwell (Ubuntu):
status: Fix Committed → Fix Released
description: updated
TomasHnyk (sup) wrote :

This should by SRUed for Trusty, no? ( I guess it is beside the point for Utopic now).

Sebastien Bacher (seb128) wrote :

there are SRUs waiting for review in the queue for trusty and vivid

Hello Daniel, or anyone else affected,

Accepted shotwell into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/shotwell/0.18.0-0ubuntu4.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in shotwell (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Chris J Arges (arges) wrote :

Hello Daniel, or anyone else affected,

Accepted shotwell into vivid-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/shotwell/0.20.2-0ubuntu4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Sebastian Gebhard (sege) wrote :

I have just tested 0.20.2-0ubuntu4 from vivid-proposed.

It does not fix the issue for me. When I try to "publish" pictures, I do not even have the option of publishing to Facebook anymore.
The only option is "Piwigo" or "Add more accounts" (translated from German).
When I click on "Add more accounts", the dialog window closes and nothing happens.

See attached screenshot.

tags: added: verification-failed
removed: verification-needed
Changed in shotwell (Ubuntu Trusty):
importance: Undecided → High
Alberto Mardegan (mardy) wrote :

I installed the packages from vivid-proposed in wily and it works fine.

Sebastian, do you have a Facebook account configured in System Settings -> Online Accounts? Is shotwell enabled for that account?

When you click on "Add more accounts" the Online Account page from the System Settings should appear; unfortunately that can take a few seconds, and indeed the shotwell dialog is closed immediately, therefore giving the impression that nothing is happening.

Sebastian Gebhard (sege) wrote :

Hi Alberto,
thanks for looking into this. Indeed, I do not have these settings.

I am on Xubuntu and System Settings / Online Accounts is not installed by default. A quick search makes me think, that it might be provided by package ubuntu-system-settings-online-accounts, but installing it looks like it needs to install the complete Unity environment.

Is this really how it is supposed to work or did I not get that correctly?

Sebastien Bacher (seb128) wrote :

@Sebastian, your issue is a different one from the one discussed in here, see bug #1314904

tags: added: verification-needed
removed: verification-failed
Sebastian Gebhard (sege) wrote :

@Sebastien: Oh, thanks for pointing it out and sorry for any disturbances!

The proposed package resolves my issue.

On Sun, Oct 18, 2015 at 9:33 AM, Sebastian Gebhard <
<email address hidden>> wrote:

> @Sebastien: Oh, thanks for pointing it out and sorry for any
> disturbances!
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1460329).
> https://bugs.launchpad.net/bugs/1453549
>
> Title:
> Cannot publish to Facebook
>
> Status in Shotwell:
> Confirmed
> Status in webapps-sprint:
> Fix Released
> Status in shotwell package in Ubuntu:
> Fix Released
> Status in shotwell source package in Trusty:
> Fix Committed
> Status in shotwell package in Fedora:
> Unknown
>
> Bug description:
> * Impact
> the facebook integration doesn't work anymore because the current key
> has the right permissions (and is owned by mia upstreams)
>
> * Test case
> try to publish photo to facebook
>
> * Regression potential
> the change impacts only the facebook key id
>
> -----------------
>
> Whenever I try to publish to facebook I get the error:
>
> "You have already logged in and out of Facebook during this Shotwell
> session. To continue publishing to Facebook, quit and restart
> Shotwell, then try publishing again."
>
> No matter how many times I try this it happens,
>
> I start shotwell, select the pics to publish, File - Publish, login
> into Facebook, then choose options and choose publish and the error
> appears. Happens everytime I do it.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/shotwell/+bug/1453549/+subscriptions
>

tags: added: trusty verification-done
removed: shotwell verification-needed
affects: shotwell (Fedora) → fedora
Changed in fedora:
importance: Unknown → Undecided
status: Unknown → New
affects: fedora → hundredpapercuts
Changed in hundredpapercuts:
status: New → Fix Released
affects: hundredpapercuts → ubuntu-translations
no longer affects: ubuntu-translations
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package shotwell - 0.18.0-0ubuntu4.4

---------------
shotwell (0.18.0-0ubuntu4.4) trusty; urgency=medium

  * debian/patches/06_uoa.patch:
    - use new facebook key, thanks Alberto Mardegan (lp: #1453549)

 -- Sebastien Bacher <email address hidden> Tue, 13 Oct 2015 16:02:33 +0100

Changed in shotwell (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for shotwell has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package shotwell - 0.20.2-0ubuntu4

---------------
shotwell (0.20.2-0ubuntu4) vivid; urgency=medium

  * debian/patches/06_uoa.patch:
    - use new facebook key, thanks Alberto Mardegan (lp: #1453549)

 -- Sebastien Bacher <email address hidden> Tue, 13 Oct 2015 16:04:34 +0100

Changed in shotwell (Ubuntu Vivid):
status: New → Fix Released
Changed in shotwell (Ubuntu Vivid):
importance: Undecided → High
Changed in shotwell:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.